Bug 126850 - Homedirectory wasn't created
Summary: Homedirectory wasn't created
Status: CLOSED DUPLICATE of bug 135625
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: libuser   
(Show other bugs)
Version: 3.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-28 13:11 UTC by Falko Pilz
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Falko Pilz 2004-06-28 13:11:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
Hello,

if I use redhat-config-users the homedirectory wasn't created.
I doesn't do something other then on ix86. The RPM seems not been
created/compiled for S390 (noarch). 

Because off that no error is displayed and it is a binary, I'm not
able to say what's going wrong.  

Kind Regards

Falko

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.18-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.open "redhat-config-user"
2.create a new user
3.check "create homedir"
4.homedir="/home/<username>"
5.click "ok"

    

Actual Results:  user was created
/home is empty

Expected Results:  user and homedirectory should been created after
hiting the "Ok"-button

Additional info:

every input would show the same

Comment 1 Nils Philippsen 2004-08-11 15:22:10 UTC
Just checking whether I get this correctly: You are trying to add a
user on an s390 box (31 or 64 bits?) and it fails to create the home
directory, right?

As you noticed, the package is noarch because it doesn't contain
architecture specific stuff. The binary you are referring to is
probably /usr/bin/consolehelper (/usr/bin/redhat-config-users is just
a symlink to it) which is used to let ordinary users run the tool,
then ask for the root password and then run the real tool which is
/usr/share/redhat-config-users/redhat-config-users and everything else
in the same directory. If you want to take a look, please do there ;-).

Just for the record: I tried to reproduce this on x86, but it works as
expected (creates the user's homedir).

Comment 2 Falko Pilz 2004-10-13 12:21:48 UTC
Sorry an Isue with Lotus Notes on RedHat for zSeries does take my time
so I couldn't test until now. Al i got from my user was that he not us
"/home/<uerid>" because it should be an user for a deamon who should
have his homedir linked to the applikationdirektory, sorry for the
wrong informations.

Now I tested a little bit and all I got was:

redhat-config-users
libuser fatal error: lu_homedir_populate() called with non-NULL
*error/usr/share/redhat-config-users/redhat-config-users: line 4:
29068 Aborted                 /usr/bin/python2.2
/usr/share/redhat-config-users/redhat-config-users.py

So it should be a problem in redhat-config-users, isn't it???

Comment 3 Nils Philippsen 2004-11-19 12:13:16 UTC
This rather seems like a problem in the underlying libuser package. Which
version of that one do you have?

Comment 4 Miloslav Trmač 2004-11-19 13:52:09 UTC
This should be fixed in the upcoming RHEL 3 update 4.

*** This bug has been marked as a duplicate of 135625 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:04:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.