This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1268649 - Corner case where lightdm allows the login even if the provided password is wrong
Corner case where lightdm allows the login even if the provided password is w...
Status: CLOSED DUPLICATE of bug 1271377
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-04 06:40 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-13 15:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 15:51:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-04 06:40:50 EDT
Description of problem:
I found what seems a corner case where lightdm allows the login even if the provided password is actually "wrong". This might not be a true bug, but *in my opinion* the behavior of lightdm is not what an user expects.

Version-Release number of selected component (if applicable):
lightdm-1.10.5-4.fc23.i686

How reproducible:
Always

Steps to Reproduce:
1. Create an user without password.
2. Login through lightdm with that user.
3. Provide a password for the login.

Actual results:
ligthdm allows the user to login.

Expected results:
At least in my opinion, lightdm should refuse the login. The real password is blank, so if no blank password is provided, the real combination of "login name + password" is not actually matched.

Additional info:
Fedora 23 Final TC1 (32 bit) on qemu-kvm.
lxdm has got the same approach (See bug 1268624).
Comment 1 Rex Dieter 2015-10-13 15:51:30 EDT

*** This bug has been marked as a duplicate of bug 1271377 ***

Note You need to log in before you can comment on or make changes to this bug.