Bug 1269104 - pulseaudio not started when logging in as root
pulseaudio not started when logging in as root
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
: Regression
: 1272241 (view as bug list)
Depends On:
Blocks: 1104057 1190227 1252514
  Show dependency treegraph
 
Reported: 2015-10-06 06:56 EDT by Rainer Koenig
Modified: 2015-11-19 04:29 EST (History)
6 users (show)

See Also:
Fixed In Version: pulseaudio-6.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:29:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2015-10-06 06:56:01 EDT
Description of problem:
Testing RHEL 7.2 snapshot3 actually 

Version-Release number of selected component (if applicable):
pulseaudio-module-x11-6.0-6.el7.x86_64
pulseaudio-utils-6.0-6.el7.x86_64
pulseaudio-6.0-6.el7.x86_64
pulseaudio-gdm-hooks-6.0-6.el7.x86_64
pulseaudio-module-bluetooth-6.0-6.el7.x86_64
alsa-plugins-pulseaudio-1.0.27-3.el7.x86_64
pulseaudio-libs-6.0-6.el7.x86_64
pulseaudio-libs-glib2-6.0-6.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 7.2 snapshot3
2. Login as root
3. check sound settings

Actual results:
Sound config panel doesn't show any sound devices because pulseaudio is not running. If you try to play sound with "aplay <file>" then you get a message, that it can't connect to pulseaudio:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

aplay: main:722: audio open error: Connection refused

Expected results:
Pulsaudio starts also for the root user.

Additional info:
This behaviour is now similar to Fedora 22 and there are bugs for Fedora 22 already filed, but not resolved:

https://bugzilla.redhat.com/show_bug.cgi?id=1234710
https://bugzilla.redhat.com/show_bug.cgi?id=1226141

Sound works perfectly when logging in as a "normal" user. 

When you're still in the gdm login screen then pulseaudio is running as a process of gdm. Tried to login from a console and using aplay, but that doesn't work either. 

So now RHEL 7.2 behaves exactly like Fedora 22. ;-) My fear is that this could affect the sound tests of redhat-hardware-certification.
Comment 3 Wim Taymans 2015-10-06 10:46:58 EDT
Autostart is disabled for root so pulseaudio doesn't automatically start on login. A rather easy fix is available for this.
Comment 6 Wim Taymans 2015-11-03 11:22:35 EST
*** Bug 1272241 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2015-11-19 04:29:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2106.html

Note You need to log in before you can comment on or make changes to this bug.