Bug 126926 - Blank screen on installer startup (text mode)
Blank screen on installer startup (text mode)
Status: CLOSED DUPLICATE of bug 121819
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 03:50 EDT by Rafal Smyka
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rafal Smyka 2004-06-29 03:50:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Not sure if anaconda is a right component to report. I haven't found
anything better though.

My screen goes blank when I start installation.
I boot from FC2 CD1. Then on boot prompt I proceed. Then I can see
'loading vmlinuz...', 'loading initrd.img...' and then it switches to
darkness.

My hardware is: Nvidia GeForce2 MX-200, motherboard Asus P4S333.

I tried to run installer on another PC and it was fine there. I ran
mediacheck there and it succedded for all the CDs.

I thought it could have been the fb problem, so I tried nofb, text,
skipddc, noprobe arguments in different combinations. No result.

Then I tried to press random keys on my keyboard. Hitting enter caused
my CD spinning for a while. Apparently it was performing mediacheck.
So the good news was, the installer was running, only the display failed.
This brought me to another Idea. I restarted install, and when it
stopped, I pressed right arrow key and then enter to bypass the
mediacheck. And the miracle happened - the graphical installer started
and I could see it! Then I could proceed with install.
Funny thing is that when my graphical installer opens, I can switch to
the text consoles (Alt+F1, 2, etc.) and they work. So the screen is
blank only until the graphical mode is started.

So finally I succeeded with installation.
Now I have the same behaviour on system load. When I start loading
from grub, my screen goes blank and then it switches to a graphical
mode. Afterwards the virtual text consoles work fine.
If I start to boot to a text mode, I cannot see anything.

It looks like it switched to a text mode my card doesn't support on boot.

BTW, I had installed on the machine Aurox Linux and it was fine. I
guess it is based on RH9. So I pressume that RH9 installation would work.

I searched the web for similiar problem but haven't seen anything like
that.  Perhaps my video card is somehow broken. But why can I see the
text consoles after the graph mode has been initialized then?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from install CD1.
2. On boot prompt press enter.
3. The screen goes blank.
    

Additional info:
Comment 1 Jeremy Katz 2004-06-29 15:01:05 EDT

*** This bug has been marked as a duplicate of 121819 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.