Bug 121819 - (p4p800) Asus P4P800 motherboard doesn't install
Asus P4P800 motherboard doesn't install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 121449 123033 123067 123279 123581 123709 123975 124004 124068 124096 126336 126882 126884 126926 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 00:53 EDT by David Lawrence
Modified: 2015-01-04 17:05 EST (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 22:49:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom kernel .config (44.95 KB, text/plain)
2004-05-16 17:48 EDT, raxet
no flags Details
dmesg output from P4P800 SMP boot kernel-smp-2.6.5-1.358 (15.23 KB, text/plain)
2004-05-26 22:34 EDT, Bob Arendt
no flags Details
dmidecode output from ASUS P4P800 system (19.61 KB, text/plain)
2004-05-27 03:02 EDT, Bob Arendt
no flags Details
dmesg output from P4P800 uniproc patched kernel-2.6.5-1.358 (9.42 KB, text/plain)
2004-05-27 16:59 EDT, Bob Arendt
no flags Details

  None (edit)
Description Mike Sowka 2004-04-28 00:53:59 EDT
I took the oppertunity to jump back on the "RH" wagon with the
"almost" ready FC2 test2, but:

- I've tried USB-Key diskimage.img and CD install
- I get the prompt and using every possible combination including:
      linux noprobe skipdcc nofb text
- images load up... 
- @ the top "Uncompressing kernel... Ok, boot linux" (or something
along those lines) apears
- AND THAT'S IT!!! NOTHING FROZEN! i.e. CapsLock NumLock don't work,
it reset

The machine is a fairly common configuration:
- Asus P4P800 w/ P4 2.8 HT
- 2G ram
- Radeon 9200 w/ 2 x Samsung 191T
- CDRW/DVD
- 2 x SATA drives (-->I have tried both legacy, and enhanced modes<--)
(Note... this is not my system ;), my supervisor likes to spoil his
graduate students)

The even version number in 2.6 does stand for stable kernel version
right?! ;) SUSE's 2.4.21 works just fine in S-ATA legacy mode.
Comment 1 Jan Bernhardt 2004-04-28 11:19:15 EDT
same here, almost the same setup:

* asus p4p800 deluxe
* p4 northwood 2.8 ht
* 512mb ram
* 1 x sata native

fc2t2 worked, even though the current kernel 2.6.5-1.327 in up style
showed the same error. smp works. disabling ht does not help either.
Comment 2 Stanislav Polasek 2004-04-28 11:31:07 EDT
Same here: asus p4p800, p4 3.0 northwood, 2x512 DDR ram, 2x sata native.

The same hw with different motherboard (asus p4g8x) works. The same
mobo with the different processor does not. (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121449). The SMP
kernel also works.
Comment 3 J.Jansen 2004-04-28 15:17:51 EDT
Same for me
 * asus p4p800 deluxe with P4 (2.8Ghz)
 *2x512 ram
 2x s-ata (seagate)
 
 I never got fc2t2 working, but at least the installer worked.
Comment 4 Eric Beyer 2004-04-30 13:46:15 EDT
Hate to say it but me too. When trying to install FC2t3 I get as far 
as "Uncompressing Linux... ok, booting the kernel" and it hangs with 
a flashing cursor on the left side of the screen.

* ASUS P4P800 w/ P4 2.6GHz HT
* 512 MB (PC2700)
* 1 SATA (Seagate 120GB), 1 PATA (Seagate 40GB)
* GeForce 5600 Ultra (128MB)
* 40x Pioneer DVD-ROM, 8/4/32 Plextor CDRW

Tried various boot options nosmp, noapic, noacpi, nousb, etc... no 
luck. Requires a hard reset.
Comment 5 Andrew Buyuk 2004-04-30 19:13:48 EDT
I have the same problem, but I am using an old ASUS mobo.  My setup is

ASUS P3C2000
512 MB (PC100)
1 20GB IDE drive
GeForce 3 card
PIII processor

At this point I think it is the mobo or the video card.  I can install
FC2T3 on my windows box just fine.  I was so hoping to check out FC2
since FC1 just added to an already great product.  If I can find my
old G400 card I will try that out.
Comment 6 Marek Kassur 2004-05-03 18:13:41 EDT
Motherboard more likely as we have different video cards (ATI or
Nvidia as I see).

My setup:
Asus P4P800 Delux, P4 2.6 HT, 1G RAM
ATI 9200.
1 120G IDE drive.
1 9G SCSI drive (aic7xxx).
Comment 7 Eric Beyer 2004-05-03 21:45:38 EDT
It even appears that if affects more than one model of motherboard 
though they have Asus in common. Makes you wonder if someone has 
something against Asus... (j/k). I hope they fix it before Fedora 
Core 2 is released though I could always revive my old computer with 
the Tyan board to use a the server...
Comment 8 Rok Papez 2004-05-04 14:42:54 EDT
Asus P4P800
Install fails with "Uncompressing kernel, OK booting..." ot similar :).

I've tried booting with "linux printk_early=vga" and with "linux
noprobe noapic prink_early=vga" and it still prints the same line and
nothing else.
Comment 9 Masiej Fly 2004-05-10 16:52:03 EDT
Same here:
- Asus P4P800SE
- Pentium 4 2.8GHz HT
- 512mb RAM
- GeForce FX 5700
- 80Gb SATA drive
- LG DVD-ROM
Comment 10 Jeremy Katz 2004-05-11 14:22:12 EDT
*** Bug 123033 has been marked as a duplicate of this bug. ***
Comment 11 Leonard den Ottolander 2004-05-14 12:43:18 EDT
*** Bug 123067 has been marked as a duplicate of this bug. ***
Comment 12 raxet 2004-05-14 13:23:48 EDT
Just my two cents here ditto comment #4 except I have an ATI 9700 PRO
and 1 GIG of 3200 dimm and a P4 2.8 Ghz 800 mhz FSB on a Asus P4P800SE
Comment 13 Stephen Biggs 2004-05-14 13:47:23 EDT
I am having some very weird problems with my MB (P4P800-VM)... I have
NEVER gotten Redhat to successfully boot all the way with any release
(RH 9, FC1, or FC2-T3).  Actually, FC2-T3 DVD install boots with a
bunch of undefined symbols in an IDE driver each time it tries to
enumerate the disk, then hangs for a LONG time in /sbin/loader, but
after about 5-10 minutes, it comes up to a blue screen with red text
along the bottom, nothing works with the keyboard, then it continues
to boot until the install X server comes up fine.  I am understandibly
a little apprehensive about installing this release with all the
problems I am having due to this MB and Linux not working for me. 
KNOPPIX 3.4 has other weirdnesses when I try to boot into 2.6 kernel.
Comment 14 Jim Cornette 2004-05-14 17:56:40 EDT
Has acpi=on been tried as a parameter to the kernel? This worked for
me on an HP laptop.

I got to a lockup with pcmcia without acpi=on given to the kernel. The
problem is different, but I cannot install any version of Linux
without the kernel parameter.

I heard about this problem on the test list. Just giving out ideas.

Jim
Comment 15 Dave Jones 2004-05-14 19:22:41 EDT
acpi=on is the default in the fc2 kernel. adding it to the command
line makes no difference at all.
Comment 16 redhat admin 2004-05-15 06:44:07 EDT
Me too, 

P4P800 Deluxe, 2gb RAM, Geforce2 Video, 2.8ghz HT P4 800mhz.

FC1 works well, with auto detection of HT, SATA but no sound.


Is this fixed for FC2 ???? I hope so or I'm off to MandrakeLand !!!!
Aaaaaaaghn.
Comment 17 redhat admin 2004-05-15 06:47:04 EDT
I meant is the FC2 test3 hanging on "Uncompressing Linux ..." fixed
for FC2 ?
Comment 18 Marek Kassur 2004-05-15 15:51:02 EDT
Something new to consider:
http://marc.theaimsgroup.com/?l=linux-kernel&m=108464291803496&w=2
Comment 19 Dave Jones 2004-05-15 17:15:44 EDT
*** Bug 123279 has been marked as a duplicate of this bug. ***
Comment 20 redhat admin 2004-05-15 18:56:59 EDT
He does not specifically mention which 'linux' ie kernel. Knoppix 3.4
standard (2.4 kernel) works fine on my p4p800, but knoppix3.4 (2.6
kernel) does not. Other 2.4 kernels (eg FC1) work properly. I have
1016 BIOS.

Would seem like it is 2.6 related for me.
Comment 21 redhat admin 2004-05-15 19:48:46 EDT
He does not specifically mention which 'linux' ie kernel. Knoppix 3.4
standard (2.4 kernel) works fine on my p4p800, but knoppix3.4 (2.6
kernel) does not. Other 2.4 kernels (eg FC1) work properly. I have
1016 BIOS.

Would seem like it is 2.6 related for me.
Comment 22 raxet 2004-05-15 20:55:47 EDT
It is kernel 2.6 related... specifically any 2.6.5 kernel. I've tried
all of arjanv's and I'm retrying them to try and make some sense of it
all. Actually the 2.6.3 FC2 T2 kernel sucks as well. I'm running FC2
T1 after doing a complete fresh install. That's as far as she goes. :)
Comment 23 raxet 2004-05-15 21:16:28 EDT
I just remembered something. When the message: "Uncompressing
kernel... Ok, boot linux" arrives the system just reboots. That's
important. Doesn't hang here.
- Asus P4P800SE
- Pentium 4 2.8GHz HT
- 1024mb RAM
- ATI 9700 Pro
- 120Gb Seagate SATA drive
- BUSLink Firewire External 48x12x12
Comment 24 raxet 2004-05-16 17:48:39 EDT
Created attachment 100259 [details]
custom kernel .config

Check it out
Comment 25 raxet 2004-05-16 17:49:43 EDT
I have it WORKING! Updated with a rawhide custom kernel
2.6.5-1.358custom and I used the stock config for smp instead of non
smp for i686. If anyone is interested, I will attach the .config file
for others to try. I might add that I updated all packages to FC2 T3
or later before doing this. Before this I was running 2.6.1-1.65smp
kernel.
Comment 26 HalShaw 2004-05-17 12:10:05 EDT
My Asus motherboard (A7V8X) will not work with FC2-T2 or FC2-T3.
Although both versions install on this motherboard, when it reboots to
initialize the OS, I don't get a display on the screen at all.
Comment 27 raxet 2004-05-18 09:24:06 EDT
I tried release and of course it fails. See comment #25. But
downloading 2.6.6-1.368 does the same thing. It reboots after
inflating initrd.gz.
This is strange and not sure why building a custom kernel with the
release FC2 2.6.5-1.358 smp works. You got me here people.
Comment 28 raxet 2004-05-18 11:03:43 EDT
More in the saga. I can make an smp kernel work as in 2.6.6-1.368.
Boots just fine. So what happens during the install process. I can't
imagine it being kernel related. Is anaconda the culprit?
Comment 29 Mike Sowka 2004-05-18 12:07:43 EDT
Folks...

The smp version of the kernel had ALWAYS worked... kinda strange that
RH decided to release FC2 with this bug persistent.

Here is what I've tried in getting bootdisk.img working (on the
premise that smp kernels work):

NOTE THIS IS A WORK-AROUND!

#1: gunzip and mount initrd.img
#2: gunzip and cpio -i modules.cgz
#3: replace all the modules (*ko) from the modules.cgz with their smp
couterparts from the 358 kernel
#4: "cpio and gzip"-up modules.cgz
#5: umount and gzip the initrd.img and place it back on the usbkey
#6: --> replace the vmlinuz <--- with the 358smp version

THE USBKEY BOOTS FINE<-- but it seems that I've done something wrong
or missed something else in the initrd.img (md5sums, magic numbers?)
since when anaconda tried loading the modules for USB etc. it borks
complaining a number of times about:

"cpio: Bad magic"

Give me a hand here folks, and we'll all be able to at least get the
FC2 smp variant installed...

Mike
Comment 30 Bryan Venable 2004-05-18 14:00:37 EDT
add '-H crc' to your cpio command
Comment 31 Mark Niemann 2004-05-18 15:42:38 EDT
Hi, 


I have two Systems with the ASUS P4P800
One with Bios Version 1013 and one with 1016
I tried to install both with fc2 (final)

The one with 1013 bios works fine but the other one crashes 
with a "Reboot Loop"

Mark



Comment 32 Mike Sowka 2004-05-18 16:30:12 EDT
Well ;) I'm posting this comment from FC2!

With some credit going to Bryan for his cpio hint, I've managed to
install FC2 on an BIOS version 1016 P4P800 with a hacked bootdisk.img!

Now, I'd like to share this bootdisk.img with You but the actual file
was on my previous installation, i.e. it's GONE, and I don't know how
to dd a new image from my USB key without creating a 256M file (that
is the size of the key). Any suggestions...

If I can't figure out how to do that... I will creat another modified
image, or post instructions on how to do it, when I get a chance. I
really should get back to my studies for Today.

AGAIN: THIS IS A WORK-AROUND, NOT A FIX
Comment 33 Mark Niemann 2004-05-18 16:34:09 EDT
Hi,

towards comment 31 it's not the bios revision i tried 1013 on my
second board
There must be a great diffrent in the motherboard revison.

the production date for the first board is may 2003 (this one works)
the production date for the second board is december 2003 (does not work) 

Mark
Comment 34 Mark Niemann 2004-05-18 16:35:27 EDT
Hi,

towards comment 31 it's not the bios revision i tried 1013 on my
second board
There must be a great diffrent in the motherboard revison.

the production date for the first board is may 2003 (this one works)
the production date for the second board is december 2003 (does not work) 

Mark
Comment 35 Oliver Van Assche 2004-05-18 17:18:35 EDT
Hi,
I have a P4P800-E deluxe with BIOS V1002 and i have the same problem i
cant install FC2 it just reboots after loading or trying to load the
initrd.img. Is there a way to see more debug info?

cheer oli
Comment 36 duma 2004-05-18 20:23:20 EDT
Hi, I also have a P4P800-E deluxe with BIOS V1002 and have one SATA
drive installed.  It just reboots during loading of initrd.img also.

-Duma
Comment 37 Shane McAliece 2004-05-19 05:02:41 EDT
P4P800S with the 1003 bios version, reboots straight after loading 
initrd.img.
Comment 38 biatche 2004-05-19 05:54:31 EDT
same for 1004
Comment 39 Andy Lee 2004-05-19 12:34:33 EDT
I have a P4P800 Dlx
2.4Ghz P4 'C'
512Mb RAM
ATi 9600 Pro

I also get this error
Comment 40 David Murphy 2004-05-19 12:42:44 EDT
re: comment #32.

I'd love to get my hands on that usb image.  even if you create a 256
meg image with dd, it should compress down to about the size of the
image you put into it.  could you please post that?
Comment 41 Jarkko 2004-05-19 13:25:26 EDT
Is this bug SATA related? If yes, with 2.4 kernels it helps if you
switch off "Sharing PCI IDE interrupts support" in the "IDE, ATA and
ATAPI Block devices" part. I have ASUS P4P800 and two SATA drives...
Comment 42 Chris Chabot 2004-05-19 16:09:06 EDT
Woops, ran into this same brick wall as everyone else here.

Asus P4P800
3.0 Ghz P4
1Gb ram (2x512, 800mhz)
ATI 9800XT
Maxtor (ATA100) 80gb HD

Re: comment #41 doesnt seem to be SATA related, since i'm using a 
normal ide drive..

Now in the funny situation that FC2 test 1 installs fine, _but_ nukes 
my partition table (and kills XP in the process) or FC2 which can not 
be installed.. Goodie! :-)
Comment 43 Phil Salkie 2004-05-19 18:30:26 EDT
Another work-around: Same sort of setup, (P4P800, 3.2G P4, 512M Ram) -
I had an install of FC2 Test 2 on a new HDD that installed properly,
but crashed on boot-up afterward.  I tried to put FC2 Test3 on top of
it, but that did the boot-hang on unpacking the kernel from
ramdisk-thing.  So, I ran RH9 on my existing HDD, mounted the new disk
with the FC2 Test 2 install, and plopped a 2.6.6mp kernel which I had
built (and was running on RH9) onto the new harddrive.   I added the
new kernel to the new drive's /boot/grub/grub.conf, copied over the
entire /lib/modules/2.6.6 directory, and made the new disk the primary
HDD - booted into FC2 Test 2 just fine.  Then I copied all four CD's
of FC2 Test3 into a directory, deleted the kernel RPM's, and did "rpm
-F --nodeps *rpm" - the system now thinks it's FC2 Test 3.  I suspect
I'll do the same once I D/L the FC2 final CD's.  Again, not a fix,
just a workaround so I can try out the new stuff.

Also, for what it's worth, I tried every stock kernel and pre-patch
from 2.6.0 to 2.6.6 in UP and SMP modes on this system (hoping for USB
to get sane enough to talk to my Neuros Audio Computer) (all versions
were without using a ramdisk, BTW) and had no problems booting on any
of them.  Don't know if it's a Red Hat patch, some obscure .config
setting, or a problem with ramdisks...

Comment 44 biatche 2004-05-19 21:16:23 EDT
fedora ought to release a prepatch cd1 w/ fix for p4p800se.. it's so 
silly of em to release a final with this preexisting massive issue
Comment 45 Jeremy Katz 2004-05-19 22:24:52 EDT
*** Bug 123581 has been marked as a duplicate of this bug. ***
Comment 46 Michael Jones 2004-05-19 23:01:06 EDT
I am using an Asus P4PE / 2.53Ghz P4 / 512MB with BIOS 1007 and I am
getting the same behavior as the P4800's... FC2 final will not boot
from the CD, as soon as my SCSI (Adaptec AHA-2940U/UW/D / AIC-7881U)
bios recognizes the bootable CD it just restarts the system... over
and over till I remove the CD and allow it to boot to Grub and my FC1
system. CDROM is a Yamaha CRW2100S. Video card is a Radeon 9000. I
have no pen drive to try the USB boot image... I did try the rescuecd
and same thing.
Comment 47 Michael Jones 2004-05-19 23:16:16 EDT
sorry... My BIOS is NOT 1007, it is 1002.
Comment 48 Randy Ramsdell 2004-05-20 02:11:57 EDT
Same here rebooting upon install. Amazing that this WELL known bug
makes it thru to the final release. I can't imagine that only a few
people have an ASUS board. Therefore, the final release was released
knowing this bug remains. 

PS. Not sure if this is forwarded to the final release. It should be,
but I could not find any reference searching fc 2 here
Comment 49 Mazzy 2004-05-20 03:40:41 EDT
Hi, Same there with my Box, P4P800-E Dlx, P4 3.0c, 2 EIDE HD, 1 DVD-
ROM all off the intel chipset port.
There're few new betas Bios for some P4P800 series to try, but 
there're available only on the Taiwan FTP site, often source of bad 
or corrupted bios.
Comment 50 Arjan van de Ven 2004-05-20 04:19:21 EDT
*** Bug 123709 has been marked as a duplicate of this bug. ***
Comment 51 Chris Chabot 2004-05-20 04:39:33 EDT
I went ahead and tried a beta version bios for my motherboard (P4P800 
SE), latest version was 1005 beta (only a few days old). Still the 
same problems though.

Comment 52 Florian Painke 2004-05-20 05:38:44 EDT
Just wanted to note that Mandrake 10 Community with 2.6.3 kernel works
fine on my ASUS P4P800 (BIOS 1016), no matter if with or without smp.
Comment 53 Moritz Baumann 2004-05-20 07:09:54 EDT
I have an ASUS P4P800 SE and have the same problem as you guys.

I was able to build a modiefied diskboot.img and put it on my usb-stick.
The problem I have now is that I only downloaded the dvd and it seems
to me that the diskboot.img lacks udf support (it tells me that it
can't find the Fedora CD, although the dvd is inside).
The image was build like mentioned in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c29 and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c30, and
can be downloaded from http://mo.homeip.net/FC2/bootnet.img.bz2
(please be patient since i only have 16kb/s upload).

While I download the cds I'll try to add udf support to the image.
Comment 54 Moritz Baumann 2004-05-20 07:11:29 EDT
damn the url is: http://mo.homeip.net/FC2/diskboot.img.bz2
Comment 55 Moritz Baumann 2004-05-20 09:22:42 EDT
just adding udf.ko into the modules.cgz did not work... still
downloading the cds and hoping...

It would be nice if somebody who grabbed my diskboot.img and got it to
work (or did not) would post a note ... 

since there is no point in you people using up my complete upload, and
the image not working...
Comment 56 Moritz Baumann 2004-05-20 10:06:51 EDT
im moved the file to my universities account the new url is:
http://user.cs.tu-berlin.de/~baumannm/FC2/diskboot.img.bz2
Comment 57 Edward Almos 2004-05-20 10:53:58 EDT
I also get this problem but I am not running an ASUS motherboard, my
system is a VIA C3 800MHz. Could the problem be a timing issue as all
of us who have this issue are running 800MHz systems ?

Ed Almos
Budapest, Hungary
Comment 58 Joshua Weage 2004-05-20 11:29:36 EDT
I just had success getting SUSE Live 8.2 and 9.1 CD's to boot by using
IDE Compatibility Mode and disabling the S-ATA controllers.  This is
on an ASUS P4P800E.  Hopefully, this will also solve the installation
problems.

Comment 59 Roland Hermans 2004-05-20 13:02:37 EDT
Moritz,

My PC with an Asus P4P800 Deluxe motherboard (BIOS revision 1016) also
rebooted immediately after booting from the FC2 cd. I downloaded the
diskboot.img you created, installed it on a USB pen drive and booted
my PC with it. Unfortunately I still don't succeed in installing FC2.
The  kernel now hangs at ACPI. Adding the kernel option acpi=off got
me a little bit further. Now I'm stuck at the point where I can select
the medium that I want to use for installation. If I select CDROM the
following messages appear in the log:

* trying to mount CD device hdc
* unable to open loop device /tmp/loop0

I'm not able to eject the CD anymore at this stage so at least the
mount partially succeeded. Next I tried installation from network but
FC2 can't load my network device driver (sk98lin.o):

* modules to insert sk98lin
* module(s) sk98lin not found

So far my experiences with FC2 and your diskboot.img file.
Comment 60 David Murphy 2004-05-20 13:04:51 EDT
re: comment #56

I copied your disk image to my usb key, and tried booting from it.  I
get to the fedora splash, and after i hit enter to proceed, it DID 
get a bit further (no spontaneous reboots),  but it locked my machine
(p4p800 P4 2.6C) as soon as it started initializing the ACPI
subsystem.  Passing noapic and noacpi made no difference (are they
valid ?).  Disabling APIC/ACPI in my bios only allowed me to get one
more line into the boot sequence.   This is also with IDE
compatibility mode.
The final line with apic/acpi on in the bios is:
ACPI: Subsystem revision 20040326

The final line with apic/acpi off in the bios is one more line down:
ACPI IRQ 9 SCI: Edge Set to Level Trigger (something like that)

so.. we have progress... :)  ah.. i see someone just modified the
kernel params. I'll go try that :)
Comment 61 Florian Painke 2004-05-20 13:17:35 EDT
Re: #59, 60

What does the MPS Revision setting in your BIOS say? I remember having
problems with MPS Revision set to 1.4 (defualt); setting it to 1.1
helped at that time.
Unfortunately, I don't have a USB drive, so I can't test the
workaround ...
Comment 62 Roland Hermans 2004-05-20 13:42:09 EDT
re: comment #61

MPS Revision in my BIOS was set to 1.4. Setting it to 1.1 still
requires kernel option acpi=off.
Comment 63 David Murphy 2004-05-20 18:05:03 EDT
moritz: you built the new diskboot.img with a smp kernel, right?  If
so, did you adjust the path to the modules in the modules.cgz (and are
they smp modules as well?).

I just extracted your modules.cgz and it has the modules in the
2.6.5-1.358 dir, not a 2.6.5-1.358smp dir which i think it needs. Do
you have the files to rebuild it again with this change?
Comment 64 David Murphy 2004-05-20 18:30:00 EDT
I modified the latest diskboot.img from moritz and it seems to work. I
was able to get all the way to the graphical disk partitioner with no
problems. all the modules appeared to be loading properly.

please give this a try:
http://minotaur.mine.nu/fedora/diskboot.img.bz2
Comment 65 Moritz Baumann 2004-05-20 18:53:34 EDT
I moved them in the 2.6.5-1.358 dir but they came from the smp kernel...

I'll try your image tomorrow (it's 0:52am over here)
sorry i was just following the comments #29 and #30...

But If it works, great...
Comment 66 Phan Thai Trung 2004-05-20 21:02:35 EDT
Please give a solution, I'm a new comer and the victims include me :(
ASUS P4P800 w Ami BIOS, Intel P4 2.8, NIVIA GeForge
Reboot after "Uncompressing kernel..."

I will try all your solutions as #29, #30 and the USB key, but your 
experience is the best. Thanks.
Comment 67 Owen Taylor 2004-05-20 21:40:20 EDT
One other note that may help some people; I ran into this using
a modified boot.iso rather than a modified bootdisk.img but it
may also apply to using bootdisk.img.

Some of the modules aren't part of the boot image, but rather
part of the second stage that is loaded from the first CD. These
include the ext3 module and the RAID (md) drivers. The ext3
module in particular is pretty important to get a fully working
install.

Here's a method I got from Jeremy Katz to workaround this problem.
(This is from memory, so some of the paths are approximate, if
someone tries this, they may want to write down the exact paths
as they go and correct me)

 1. Once the CD is mounted (I think this is at the first graphical
    screen, but you may have to go a few further), switch back
    to VT running a shell. (One of Control-Alt-F1/F2/etc.)

 2. Change into the RPMS directory on the mounted CD

    # cd /mnt/sources/Fedora/RPMS/

 3. Uncompress the kernel-smp package into /tmp.

    # rpm2cpio kernel-smp-2.6.5-1.358.i68.rpm | (cd /tmp && cpio -id)

 4. Go into the modules directory:

    # cd /tmp/lib/modules/2.6.5-1.358smp/kernel

 5. Install the modules you need, e.g.

    # insmod fs/jbd/jbd.ko       [ Journalling Block Device, needed by
ext3 ]
    # insmod fs/ext3/ext3.ko
    # insmod drivers/md/xor.ko   [ XOR, needed by RAID5 ]
    # insmod drivers/md/raid0.ko
    # insmod drivers/md/raid1.ko
    # insmod drivers/md/raid5.ko

  (You probably don't need all those RAID drivers, there might
   be others you need if you are doing something unusual.)

 6. Do an lsmod to make sure that the modules actually got loaded
    (the insmod command is a stripped down version without
     error reporting)

 7. Switch back to the VT with the X server and continue the install.
Comment 68 Craig Ferguson 2004-05-21 07:36:36 EDT
To #64, I dd'd  image file to a USB flash disk and managed to get
further into the install boot than before. It loaded up the text based
install screen but immediately crashed at loading ata_piix module. It
seems the changes made to the boot image have helped but I'm not sure
where to go from here. Using a P4P800 Deluxe, like most other
unfortunate people :)
Comment 69 Steven Shiau 2004-05-21 13:17:44 EDT
steven@nchc.org.tw
Comment 70 redhat9009 2004-05-21 15:52:30 EDT
I cannot do this right now (Working)
I will lower the bus speed from 800 to 533 or 400 and try an install
tonight.
Someone else may have tried this first.
Anyone tried yet?

Wish me luck....
Comment 71 Edward Almos 2004-05-21 16:04:41 EDT
Sorry but I have tried lowering the speed on my board from 800MHz to
533 and 400 and the problem was still there. I thought at first that
this was a timing problem but this proves that it isn't so.

Ed Almos
Budapest, Hungary
Comment 72 Marco Ochse 2004-05-21 16:50:25 EDT
I am having p4p800, BIOS 1016, SATA, IDE and having the same problems 
as reported (uncompressing kernel ... reboot).

Actually I would like to know from the officials if there will be a 
fix in the near future!? I don't want to be stuck with FC1 though.

Thank your very much.
Comment 73 Kenneth Benson 2004-05-21 17:51:17 EDT
There is a 1017 beta bios at the ASUS web site. I intend to update to 
it (saving my 1016, of course) and try to do an install during the 
next week. I will update here and the devel list on the results. 

Comment 74 redhat9009 2004-05-21 23:20:57 EDT
Do not bother with the 1017 bios from Asus, I am running it right now.
No change at all.
Reboots like clockwork.....
FC 2 Test 2 will install.
FC 2 test 3 and later will not install
Comment 75 Phan Thai Trung 2004-05-22 02:35:10 EDT
The #64 with the flash USB, I tried and it works! 
But after finishing the installation, I have a small problem with the 
partition table. Hope the others work well. 
Comment 76 Arjan van de Ven 2004-05-22 04:18:49 EDT
*** Bug 123975 has been marked as a duplicate of this bug. ***
Comment 77 Roland Hermans 2004-05-22 05:46:15 EDT
Today I successfully upgraded from FC1 to FC2 using the boot image
from comment #64 . Note that if you don't follow the instructions in
comment #67 the installer will not detect existing installations of FC
or RH on ext3 partitions. The instructions from comment #67 must be
executed before the installer will look for existing installations.
Comment 78 mujo 2004-05-22 10:45:17 EDT
Today I try to upgrede FC1 to FC2. but I canot upgrade it becuase i
canot load ext3 module. (im doing same as in #77 comment). whats is
the error i dont know... 
Comment 79 Paolo Prandini 2004-05-22 11:41:11 EDT
Hi. 

I cannot install on ASUS P4P800S (i848 Chipset) I have only IDE drives.
Reboot loop.

- Regards
- Paolo
Comment 80 David Murphy 2004-05-22 12:31:31 EDT
after installing fc2 from my usb drive, something weird happened to my
drive as well. I wasn't able to dual boot from it anymore.  It would
reach the grub message on my screen and just stop.  I'm not sure if I
had a wonky partition setup before (fc2 setup complained about
improperly aligned partitions) or what, but I thought I would warn
others. I haven't lost anything, i just can't boot anymore :(  any
others see this?
Comment 81 bednar 2004-05-22 14:35:28 EDT
Could somebody put the link to prepared bootdisk.iso instead of
bootdisk.img. I have no USB key for img.
Comment 82 Alley 2004-05-22 15:27:06 EDT
Installed FC2-i386.disc* successfully on ASUS P4P800-VM BIOS 1009
running 2.8 mHz CPU, 512 MBs, 120 GB IDE HD and Liteon CD-ROM/DVD
Combo. On reboot system appear to take quite awhile (blank screen) to
get to GRUB loader phase2 message text. Reboot runs pretty normally
from there.

Contributing info only to indicate some success with ASUS P4P800
motherboard install (at least VM series).

One thing, I have noticed that is probably not related to this error
is that if I leave the system sitting idle for about 8 to 12 hours,
the keyboard (Standard 104 US) goes out to lunch and fails to send
keystrokes to the system (Browser window, Terminal window, etc)
necessitating reboot. Have not logged this as a separate bug until I
can reliably duplicate.
Comment 83 Xabier Bayon 2004-05-22 18:56:49 EDT
Hi, I also cant install Fedora Core 2 final on my machine, its a
Pentium 4 3 Ghz, p4p800 Deluxe, 1GB RAM, 1x120GB Seagate SATA drive,
ATI Radeon 9600. When I try to install Fedora the system is rebooted
while the kernel is descompressed.
Comment 84 Craig Ferguson 2004-05-23 01:06:37 EDT
The problem with ata_piix crashing during installation load was due to
having both an IDE and SATA drive in the system at once. FC2 really
does not like this on the P4P800 (with BIOS 1014). 

I managed to install FC2 to the SATA drive using the image, but FC2
will not boot with an IDE HDD on any channel - even with compatibility
mode on. Having an IDE cd-rom drive with SATA HDD is fine but when an
IDE HDD is installed, bootup crashes when the words Redhat Nash first
appear.

External USB drives are also not detected at all in FC2. They don't
appear in the hardware browser, and aren't found as /dev/sdb1 though
the BIOS picks them up. Might this be fixed with a BIOS update to 1016?
Comment 85 raxet 2004-05-23 10:26:33 EDT
In response to #84 I have to disagree. I didn't have any ide drive in
my system except the IDE cd-rom and my remarks to my experience you
can read in #12 also see #4.
Comment 86 Florian Painke 2004-05-23 18:51:05 EDT
OK, I tried the following:

Downloaded the bootdisk.img from above
Mounted it using Fedora Core 1
  (mount -o loop /tmp/bootdisk.img /mnt/image)
Moved everything from within isolinux into /boot
  (renaming vmlinuz to vmlinuz_fc2 and initrd.img to initrd_fc2.img)
Added vmlinuz_fc2 and initrd_fc2.img to /boot/grub/grub.conf
Rebooted, booted into *_fc2
Inserted Fedora Core installation disk 1
Installed Fedora Core 2
  (removing the old Fedora Core 1 partitions)

Got it up and running now, without USB memory stick or ZIP drive.
Thanks a lot guys!

Guess I will try to create a bootable FC2 disk 1 from bootdisk.img and
post my results here ...
Comment 87 Jeremy Katz 2004-05-23 22:27:41 EDT
*** Bug 124004 has been marked as a duplicate of this bug. ***
Comment 88 Bob Arendt 2004-05-24 00:42:35 EDT
ASUS P4P800 (BIOS 1014), ATA100 (no SATA), 512M, P4 3.06HT, GeForce4
MX440AGP8x

I'd incrementally installed the Rawhide kernel SMP images throughout
the test phases.  No problems at all.  I'm current with the existing
FC2 release kernel-smp-2.6.5-1.358 and all the other FC2 packages.

I installed the uniprocessor kernel-2.6.5-1.358.  It fails/reboots
immediately after grub - nothing in the log files or on-screen.  I've
tried adding acpi=off , apm=off, vdso=0 to the boot line (in various
combos) with no success or change.

This seems to be strictly a uni-processor kernel problem on this board.
Comment 89 Arjan van de Ven 2004-05-24 02:51:50 EDT
*** Bug 124096 has been marked as a duplicate of this bug. ***
Comment 90 Paolo Prandini 2004-05-24 06:40:35 EDT
Hi,

I have tried with HT turned off.
Same result.

- Regards
- Paolo
Comment 91 Need Real Name 2004-05-24 13:48:16 EDT
This bug is not found if you search Bugzilla for FC2 release only. It
needs to be there.

P.s. I have 54 P4P800 systems that I'd like to install FC2 on. But, am
getting the continous reboot problem. 
Comment 92 Andrew Buyuk 2004-05-24 13:50:55 EDT
I will try all the latest suggestions.  I've been following since I
posted comment #5.  It seems like an aweful lot of work to get FC2
running espcially since RH 6-9 and FC1 installed with such ease.  I
suspect this is kernel specific.

Asus P3C2000 Mobo w/ latest BIOS
PIII 600Mhz
512MB PC100 RAM
20GB IDE drive
Comment 93 Paolo Prandini 2004-05-24 14:01:41 EDT
Hi 

This bug should refer FC2 final, not test3.

- Regards
- Paolo
Comment 94 Scott Wade 2004-05-25 09:17:06 EDT
Has anyone tried taking a FC1 install on a system with the ASUS 
board that's having the problems and then upgrading the kernel to 
the 2.6 variety from the stock FC1 2.4 kernel? 
 
Just a thought...  Might shed some light if it crashes / hangs once 
the 2.6 kernel is installed. 
 
SWade 
Comment 95 Florian Painke 2004-05-25 09:57:56 EDT
Re to #94

Been there, done that. As soon as the up kernel is executed, the
machine reboots. The up 2.6 kernel from mandrake linux does not have
the reboot-loop-problem.
As I said in #86, I used FC1 to get FC2 to install. Since FC2 will use
the smp kernel by default on my system once installed, this works.

I have since then a different problem, which I would like to know if
it is again a problem with the ASUS mobo. While installing FC2, I
could only choose to create ext2 partitions, no ext3 or reiser.
Sometimes when coming up, FC2 will complain about the root partition
not having been cleanly unmounted and forces a fsck. There are three
inodes with zero dtime that get cleared and I have to reboot.
I used tune2fs -j and fstab to convert / to ext3, but that did not
solve the problem. Anyone else?
Comment 96 Eric Beyer 2004-05-25 10:00:45 EDT
Yes, I had been running a custom 2.6.3 kernel on my FC1 installation 
without any problems. Unless its a bug from kernels > 2.6.3 it should 
really work. Good thought though...

Eric
Comment 97 Dave Jones 2004-05-25 10:10:36 EDT
random shot in the dark: does booting with mem=128M (or however much
RAM you have) make any difference to this bug?
Comment 98 Tomaz Dobrisek 2004-05-25 10:36:04 EDT
mem=128M does not help it stil reboots after initd.

I am runing custom kernel 2.6.4 with SMP support on FC1 without any
problems. I'll try 2.6.5 too.
Comment 99 Paolo Prandini 2004-05-25 11:11:26 EDT
Hi 

ASUS P4P800S P4 2.6HT 512MB RAM no SATA, IDE only, ATI 9200 here.
I can boot Knoppix 3.4 (both kernel 2.4 and 2.6) Suse Live CD 9.1
(kernel 2.6),FC1,RH8,RH9... but not FC2 FINAL.
Md5sum Ok. Test disks is fine on another machine I can install FC2.
No change in Bios seems to change the result. Reboot Loop.

A proposal : Why FC Developers do not start an SMP Kernel by default
during install? Creating a new FC2 isodisk 1 will take less time now
it seems an SMP Kernel is the most mentioned walkaround, and it gives
all time to find a fix for up kernel. 
I think ASUS@800Mhz boards are pretty common and doing this will also
help us debug the whole Fedora Project by using it. If we are not able
to install we could not even help track other minor bugs.

- Regards
- Paolo

PS : I am so sad FC2 refuses my machine :-(


Comment 100 Bill Nottingham 2004-05-25 12:38:31 EDT
*** Bug 124068 has been marked as a duplicate of this bug. ***
Comment 101 Bas Mevissen 2004-05-25 17:35:23 EDT
Booting with an adapted boot image from a USB key seems OK.
Comment 102 Bas Mevissen 2004-05-25 17:36:08 EDT
Booting with an adapted boot image from a USB key seems OK.
Comment 103 Jason Greb 2004-05-25 17:52:30 EDT
This is also happening on an older Asus board of mine, at TXP4, which
is an older Socket7 motherboard. Thought I was gonna get my father
into Linux, but now I can't.

However, it did not happen on my Asus P4S8X-X.
Comment 104 Moritz Baumann 2004-05-26 04:55:33 EDT
I think the bug should be belong to FC2 and not test3...

Might confuse some people and think that it has gone inFC2...
Comment 105 redhat9009 2004-05-26 09:01:07 EDT
Please, please fix this.
Comment 106 Arjan van de Ven 2004-05-26 09:06:03 EDT
that is easier said than done; we don't have this hardware and we
haven't gotten any useful debug output from anyone either...
Comment 107 redhat9009 2004-05-26 09:48:50 EDT
What do we need to debug this with?
The reboot would wipe any logs from the kernel; correct?
Did Asus get someone in the Fedora team mad......
This has to be something in the Asus chipset design.
I have tried all the Asus BIOS releases.
So far the only solution is to mangle the installation iso.
But FC2 test 2 worked flawless. FC2 test3 is where this started.
Can I load FC2 test 2 and update via up2date to FC2 final release?
Comment 108 Michael Jones 2004-05-26 09:49:51 EDT
It seems we have a catch-22 then, I have the Asus P4PE and I can't 
even get the FC2 CD's to boot into the install to even get debugging 
info... I place the boot cd's in and the machine just goes into an 
infinate reboot just as the CD is recognized. 
 
What info would you like? I will provide it ASAP. 
Comment 109 Bas Mevissen 2004-05-26 09:53:45 EDT
What can owners of a P4P do to help? 

Arjan, what solution are you up to? Trying to fix the release with
some kernel parameter? The trick with the USB stick looks fine as the
motherboard supports it and an USB stick is a very common thing.
People without an USB stick but with Linux already installed on the
box can use the procedure described by Florian Painke in
<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c86>.

I'm curious about comment
<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c88> from
Bob Arendt that it only happens to the uni-processor kernel. 

Is the install kernel exactly the uni one of the FC2 release?
Comment 110 Marek Kassur 2004-05-26 12:14:41 EDT
Could someone post a dmesg from working SMP kernel.
Comment 111 Marco Ochse 2004-05-26 13:23:28 EDT
Yeah!

Finally I have found a solution that works out REALLY great! I did 
the following:

1. Format the destination partition as ext-3 or Reiser
2. Goto http://www.mandrakelinux.com/en/ftp.php3#iso and download the 
3 ISO Files
3. Install with the 1st CD
4. Boot into a pretty well & good designed Linux
5. Dear Red Hat & Fedora Team, please spare us with any comments like 
you wouldn't have hardware to test with, especially when it comes to 
a market leader concerning motherboards.

Sorry for the sarcasm here, but actually the Quality Assurance isn't 
really that great when it comes to the praised community version of 
Red Hat.

After using Red Hat for like 5 years now I'm deeply disappointed.
Comment 112 Randy Ramsdell 2004-05-26 15:51:52 EDT
For post #106

Debug info:

IT REBOOTS WHILE UNCOMPRESSING KERNEL!

Hope that helps.
Comment 113 Dave Jones 2004-05-26 17:46:40 EDT
if anyone with this board is prepared to do some detective work,
and do the same sort of investigation that was done on the C3 bug
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120685)
comment 34 onwards is where it starts to get interesting.

Given that FC2 doesn't install, install FC1, and then compile the FC2
kernel from source (with the appropriate config file from the configs/
dir).

With a for (;;); in init/main.c start_kernel() it should hang instead
of reboot if we're getting that far. If it does hang, move it down
through start_kernel() one line at a time until it produces a kernel
that reboots instead of hangs. At this point we'll have some idea of
where this crash is happening.

This all assumes that we get as far as start_kernel(), but without
someone doing some digging, guessing is all we can do right now.
Comment 114 Jean-Marc André 2004-05-26 18:49:59 EDT
Is there nothing more efficient than a for(;;) ? I mean something like
a printf that we could use like a 'flag'.
Comment 115 Jean-Marc André 2004-05-26 18:59:45 EDT
Sorry, I'm  a newbie but what is the right config file ?
kernel-2.6.5-i586.config or kernel-2.6.5-i686.config ?
I have a Pentium IV 2,6 GHz supporting HT.
Comment 116 Dave Jones 2004-05-26 19:36:25 EDT
the problem is this happens really early, likely before the initial
console has
been set up, so printk's won't show, not even early_printk's over serial
console.
                                                                     
                            
For a Pentium 4, kernel-2.6.5-i686.config is the right config file to use.
Comment 117 Marek Kassur 2004-05-26 22:02:59 EDT
It appears to reset in function dmi_scan_machine(); from
/arch/i386/kernel/setup.c

Will inspect further after my day work.
Comment 118 Bob Arendt 2004-05-26 22:34:56 EDT
Created attachment 100617 [details]
dmesg output from P4P800 SMP boot  kernel-smp-2.6.5-1.358

System from comment #88.  The first few lines of the dmesg were missing
(above the --------------) so I cut it out of /var/log/messages.
I'm going to build and test the -358 i686 unip kernel to see if I can
locate where it crashes (per comment #113)
Comment 119 Bob Arendt 2004-05-27 02:58:10 EDT
After a few hours of rebuilding kernels with the for(;;); inserted in
the source, I've narrowed it down to a *very* specific area of the
kernel, and I have a crude hack that will get a uniprocessor kernel
running; Here's the diff:

% cd /usr/src/linux-2.6.5-1.358/arch/i386/kernel
% diff -u dmi_scan.c{_orig,}
--- dmi_scan.c_orig     2004-05-26 22:34:13.000000000 -0700
+++ dmi_scan.c  2004-05-26 23:19:39.000000000 -0700
@@ -1149,7 +1149,7 @@
 {
        int err = dmi_iterate(dmi_decode);
        if(err == 0)
-               dmi_check_blacklist();
+               ; /* RDA dmi_check_blacklist(); */
        else
                printk(KERN_INFO "DMI not present.\n");
 }
========================

Yep, something in dmi_check_blacklist() is causing the reboot.

AND I've narrowed it down to a specific range of code.  The following
diff will hang on the for(;;) loop (instead of crashing):

--- dmi_scan.c_orig     2004-05-26 22:34:13.000000000 -0700
+++ dmi_scan.c  2004-05-26 23:05:33.000000000 -0700
@@ -1072,8 +1072,12 @@
 #endif

        d=&dmi_blacklist[0];
+       printk("RDA - start\n");
+       printk("d=%x\n",d);
        while(d->callback)
        {
+               printk("d->callback=%x\n",d->callback);
+               for(;;);
                for(i=0;i<4;i++)
                {
                        int s = d->matches[i].slot;
========================

Turns out printk doesn't do anything useful for me here. But the
problem is narrowed down to about 10 lines of code.  Hopefully Dave or
Arjan can fix this.

Two more pieces for the puzzle.  I believe all the boards mentioned
here show up in the blacklist tables in dmi_scan.c.  In particular:

        { exploding_pnp_bios, "ASUS P4P800", {  /* PnPBIOS GPF on boot */
                        MATCH(DMI_BOARD_VENDOR, "ASUSTeK Computer Inc."),
                        MATCH(DMI_BOARD_NAME, "P4P800"),
                        } },

This is probably what's tripping in the dmi_check_blacklist() code.

I've also attached the output of dmidecode (dumps the dmi data), so
the good kernel experts can hopefully figure out what's really
happening and the proper way to fix it.

Cheers,   (Smoke me a Kipper! - I'll be back for Breakfast!)
-Bob Arendt
Comment 120 Bob Arendt 2004-05-27 03:02:16 EDT
Created attachment 100620 [details]
dmidecode output from ASUS P4P800 system

Supporting data for comment #119
Comment 121 Arjan van de Ven 2004-05-27 03:03:50 EDT
ok now we're getting somewhere; eyeballing the code in question now.
Thanks for the great info so far.
Comment 122 Arjan van de Ven 2004-05-27 03:12:49 EDT
For a test, can anyone with a board try the boot.iso replacement from
http://people.redhat.com/arjanv/asusp4p800-boot.iso

it doesn't have a fix just a workaround, but I hope it'll boot/install
already.

(same procedure as in bug 120685 if you want a full install)
Comment 123 Bob Arendt 2004-05-27 03:42:55 EDT
Great turn-around, Arjan.  Where booting from FC2 disk1 would
immediately reboot, the asusp4p800-boot disk boots SUCCESSFULLY.
Basically, I burned a CD from the .iso and booted from it.
At the media prompt, I could eject the boot CD and replace it with
the FC2 disk1 and proceed (or do an NFS install, etc).  I'll leave
to someone else to validate a full install.

So - what was really happening?  It looks like there's a built-in
blacklist in the kernel, and this board is on it.  For some reason,
it *only* affected the uniproc kernel - SMP operation was fine.
Comment 124 Dave Jones 2004-05-27 07:06:03 EDT
That DMI blacklist struct should read..

        { exploding_pnp_bios, "ASUS P4P800", {  /* PnPBIOS GPF on boot */
                        MATCH(DMI_BOARD_VENDOR, "ASUSTeK Computer Inc."),
                        MATCH(DMI_BOARD_NAME, "P4P800"),
+                      NO_MATCH, NO_MATCH
                        } },

With that missing, we're dereferencing nonsense. The reason this works
on other distros is probably due to the different memory layout in the
Fedora kernel due to 4g/4g.
Comment 125 BachusII 2004-05-27 07:23:13 EDT
<offtopic>
  I'm going nuts over the CD's
</offtopic>

Currently I'm installing core 2. As per #122 & #123.

As I'm newly converted to linux. What debugging info do you need?
And where can I find that?
Comment 126 redhat9009 2004-05-27 08:53:14 EDT
Many Thanks to all.
Especially Arjan van de Ven.

Comment 127 Michael Jones 2004-05-27 09:51:31 EDT
Arjan, 
 
I have the Asus P4PE and it does the same thing as the P4P800, I was 
hoping they were the same bug... but the only reference to P4PE in 
the source is in drivers/pci/quirks.c and there is no reference in 
the dmi_scan.c to P4PE that is similar to the P4P800 line. 
 
Do I need to start a new bug report for the P4PE? 
 
I am going to try your new boot iso tonite to see if it works and if 
it doesn't I will try rebuilding the FC2 kernel on my FC1 sys with 
this added to dmi_scan.c to see if the bug is similar... 
 
        { exploding_pnp_bios, "ASUS P4PE", {  /* PnPBIOS GPF on boot 
*/ 
                        MATCH(DMI_BOARD_VENDOR, "ASUSTeK Computer 
Inc."), 
                        MATCH(DMI_BOARD_NAME, "P4PE"), 
+                      NO_MATCH, NO_MATCH 
                        } }, 
 
Do you think that might work? Is there any other code that would need 
to be added? 
 
thanx 
Comment 128 Bob Arendt 2004-05-27 11:16:36 EDT
Michael, it looks like the info to match the dmi_scan.c section
comes from Handle 0x0002 in the /usr/sbin/dmidecode output
(see attachment (id=100620) for example).  Find out how dmidecode
identifies your board, then see if it has a bad dmi_scan section.
As Dave points out, the crash/reboot happens because the structure
isn't fully initialized so it's dereferencing garbage.  My workaround
completely bypassed the dmi_check_blacklist() - so the problem code
wasn't executed (though maybe I'd have "exploding_pnp" problems?).
Comment 129 Moritz Baumann 2004-05-27 16:58:55 EDT
Arjan's asusp4p800-boot.iso from #c122
works fine on my P4P800SE (Bios 1004) with FC-2-DVD.

Luckily I only burnt the DVD image on a DVD+RW could sb. perhaps come
up with instructions how to loop mount the iso and incorporate the
changes before i burn it on a DVD-R.
Comment 130 Bob Arendt 2004-05-27 16:59:42 EDT
Created attachment 100643 [details]
dmesg output from P4P800 uniproc patched kernel-2.6.5-1.358

Looks like Dave Jones patch (Comment #124) is the right thing to do:
cd /usr/src/linux-2.6.5-1.358/arch/i386/kernel ; diff -u dmi_scan.c{_orig,}
--- dmi_scan.c_orig	2004-05-26 22:34:13.000000000 -0700
+++ dmi_scan.c	2004-05-27 13:45:32.882427507 -0700
@@ -787,6 +787,7 @@
	{ exploding_pnp_bios, "ASUS P4P800", {	/* PnPBIOS GPF on boot */
			MATCH(DMI_BOARD_VENDOR, "ASUSTeK Computer Inc."),
			MATCH(DMI_BOARD_NAME, "P4P800"),
+			NO_MATCH, NO_MATCH
			} },

	/* Machines which have problems handling enabled local APICs */
==============
After rebuilding the uniprocessor kernel, it boots properly.
More telling, the line:
   ASUS P4P800 detected. Disabling PnPBIOS
now shows in the (attached) dmesg text, showing that the
dmi_check_blacklist() routine is working properly.
Comment 131 Michael Jones 2004-05-27 23:01:34 EDT
I rebuilt the 2.6 kernel from FC2 on my FC1 machine, rebooted, it 
got to "Freeing unused kernel memory: 156K freed" and just stopped. 
The cursor kept flashing and the keyboard responded so I was able to 
reboot easily back to the FC1 kernel. 
 
I checked the output of /usr/sbin/dmidecode per Bob's suggestion, 
added a section to dmi_scan.c similar to the one for P4P800 and I am 
rebuilding the kernel now to see if that gets any further. 
 
I will also test the P4P800 iso to see what that does on this board, 
maybe nothing. 
 
I imagine, this is a different bug than the P4P800... should I start 
a new bug report or just keep going with this one? 
Comment 132 Michael Jones 2004-05-28 07:21:09 EDT
Ok, same thing... "Freeing unused kernel memory: 156K freed" and it 
hangs... When I recompiled the 2.6 source it said something about 
updating kernel-init?? When it hangs, I hit CTRL+ALT+DELETE and I 
see "md: stopping all devices" an it reboots. 
 
What else should I try? 
Comment 133 Arjan van de Ven 2004-05-28 07:23:47 EDT
the FC1 thing is an entirely different bug, please go away :)

(and put vdso=1 on the kernel commandline)
Comment 134 Dave Jones 2004-05-28 07:57:37 EDT
Wrong option, please go away 8-P

(You need vdso=0 actually for FC1)
Comment 135 Michael Jones 2004-05-28 11:31:08 EDT
Ok. 
 
P4PE bug has been set up 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124693 
 
thank you. 
Comment 136 Dave Jones 2004-05-28 11:54:20 EDT
*** Bug 124693 has been marked as a duplicate of this bug. ***
Comment 137 Paolo Prandini 2004-05-28 15:04:14 EDT
Hi,
Thanks to Arjan van de Ven !!
I have tried iso in comment #122 and it boots fine.
My ASUS is P4P800S, this means that I have got the little brother of 
i865PE chipset, the i848P. Same as big brother but no dual channel
memory here and some ports less.

- hope it helps
- Best Regards
- Paolo

PS : A little more... I do not want to trade FC2 for some other distro...
Comment 138 Need Real Name 2004-05-29 10:14:08 EDT
Hi,
Thanks to Arjan van de Ven !!
I have also tried iso in comment #122 and it boots fine.

I have installed six systems. All seem fine. CD/HTTP and NFS all
worked.
Comment 139 Craig Adams 2004-05-29 14:46:02 EDT
Hi,

I have tried the boot ISO on a P4P800S with 2.0Ghz Celeron, 512Mb RAM,
20Gb IDE, CD-RW, AHA2940UW (Scanner and Tape Drive).

The install goes fine, as expected, but after the patched kernel is
installed and an attempt to boot off the HDD is made, the machine
still immediately reboots.

I have tried this both at the end of the install, before reboot and
after install, doing a rescue.

Regards
Comment 140 Gabor Papp 2004-05-30 03:03:36 EDT
Hi,

I have a P4P800 P4 2.8 1MB Cache. I tried the new boot ISO, but it 
does not work. It reboots the same time/place. 

Regards
Comment 141 Andrew Rendall 2004-05-30 11:14:56 EDT
Same as #139. I have a Via C3 somethingorother motherboard that 
suffered from the same problem as the others. Managed to install fine 
using the altered ISO image, but reboots on start now (too fast to 
see what is going on).

Not sure how to proceed as I'm not so hot at twiddling the kernel 
options/boot params (bit of a newbie). Mind you, managed to get ip 
forwarding and filtering running again off rescue boot to put up this 
message!

Rgds, A.
Comment 142 Arjan van de Ven 2004-05-30 11:19:41 EDT
C3 is actually another bug with a slightly different workaround
procedure......
Comment 143 Andrew Rendall 2004-05-30 11:30:29 EDT
Ahh, oops. Er, sorry if I wasted your time.

:)

A.
Comment 144 Arjan van de Ven 2004-05-30 11:32:22 EDT
no problem just lets not confuse this bug (144 items already!) with
another very long bug ;)
Comment 145 Paolo Prandini 2004-06-01 08:03:36 EDT
Hi all. 

One question:
It's really a Kernel issue or ASUS P4P800 series are not manufactured 
according to Intel specs ?
Anything (pressure) we can do on them (new BIOS or whatever..) ?

- Regards
- Paolo
Comment 146 Dave Jones 2004-06-01 08:56:03 EDT
it was a kernel bug.
see above for a pointer to the fix.
Comment 147 ravagol 2004-06-03 07:27:07 EDT
I followed all your comments but i could not find any way out.
My pc:

Asus P4P-800s
P4 2.8 GHz, 800 MHz FSB
ATI Radeon 9800 SE
40 GB IDE 133 Hard disk (10 GB unpartitioned for Fedora Core 2)
ATI TV-Wonder video capture module. May it cause such a problem?

Hope in Fedora Core 3???
Comment 148 Bob Arendt 2004-06-03 10:49:19 EDT
You might try posting the output of /usr/sbin/dmidecode
(from the kernel-utils rpm) as an attachment.  Then we could see
if it's hitting the same dmi code in the kernel.
Comment 149 Bas Mevissen 2004-06-03 17:50:06 EDT
Regarding the iso of
<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c122>:

was able to boot and install with it. But the kernel of the kernel RPM
on it (kernel-2.6.6-1.383.i586.rpm) did NOT work for me. I got a very
quick reboot when starting the kernel without displaying anything as
far as I can tell.

Solution was to scp another kernel RPM over the network and install
it. I used kernel-2.6.6-1.406.i686.rpm. Now the machine booted fine.

So solution is to check if that kernel boots for everyone and if so,
make updated images (cdrom and DVD) and put an xdelta on the download
servers. An updated resque cdrom on short term is very welcome!
Comment 150 Jon Klaren 2004-06-03 18:52:14 EDT
I had an experience identical to that of Comment #149 - could install 
FC2 using the boot.iso replacement(see Comment #122), but the 2.6.6 
kernel from that image also would reboot immediately on me.

Solution for me was to boot from the image in rescue mode, chroot to 
my system partition. Compile custom kernel from the 2.6.5-1.383 
kernel-source rpm (after patching dmi_scan.c). Install to /boot and 
modify grub.conf.

Hardware is
Asus P4P800 Deluxe
P4, 2.8GHz, 800MHz FSB
1 GB RAM
120 GB Seagate EIDE
ATI Radeon 9200SE
Comment 151 Paul Relf 2004-06-04 09:55:55 EDT
Not sure if this is related or not.

I am trying to upgrade from RH8 to FC2. I have 2 SATA drives
running RAID 1 using the Promise controller (no IDE disk on board).

I boot from CD and get a prompt indicating that I have 2 /boot 
directories and the install aborts.

I am using P4800-DX-E
Comment 152 Craig Adams 2004-06-04 14:51:25 EDT
As per Comment #149 the kernel-2.6.6-1.406.i686.rpm from Testing works
for me.

Will the Fedora Project generate a new install disk (CD #1) after this
kernel leaves testing and is (hopefully) found to resolve this problem?

Regards
Comment 153 J.Jansen 2004-06-07 02:28:28 EDT
I tried  Comment #149 with a slightly different kernel :
  kernel-2.6.6-1.411.i686.rpm
Now it boots, but hangs at the moment the X-server is starting (the "x"
does not appear on the screen.

I got a 
  Asus P4P800de Luxe (1 Gb RAM)
  2x seagate S-Ata (120Gb)
  1 Asus v9596SD video card (=Nvidia Geforce X)

I do not see these problems when running core1
Comment 154 Andrew Buyuk 2004-06-09 20:21:08 EDT
I've tried everything in this thread (posted twice) as well as a few
others.  My mobo is a very old ASUS P3C2000.  I've even tried using
the modified .iso.  If anyone has another suggestion perhaps apt or
yum, I would be willing to try it.  I really want to check out the new
Core.  I've been with RH for ever.  I suppose I could finally move to
another distro.  Oddly enough Knoppix 3.4 works just fine.

My specs
PIII 600
ASUS P3C2000
512MB PC 100
GeForce 3
Comment 155 Andrew Buyuk 2004-06-09 20:23:48 EDT
Whoops.  Knoppix 3.4 doesn't work.  I thought it did.  Beware the red
herring.

It is definitely the kernel issue.
Comment 156 Carlo Todeschini 2004-06-10 04:59:00 EDT
I had the same experience to that of Comment #149 and my problem was
to an upgrade from FC1 to FC2. 

So I solved the problem with this steps:
 - re-installed kernel 2.4.22-1.2115.nptl
 - booted FC2 (it works...)
 - installed kernel 2.6.6-1.422 (kernel-2.6.6-1.422.i686.rpm); use
   rpm -ivh so you have both kernels...

My specs:
 MB: ASUS P4P800 Deluxe
 CPU: PIV 3.00GHz
 RAM: 1GB
 HD: 2 IDE ATA100 drives

Comment 157 cruverland 2004-06-10 12:29:15 EDT
Hello, my PC is P4 3000 ASUS P4P800-E DELUXE 1 GB ram 3 HD=80+80+80 It
would wish that they published a connection to a guide HOWTO of like
thus fixing the problem of resumption in PLATES P4P800 and like some
utility that solves it. THANKS Pardon for my bad INGLES.
Comment 158 Dave Jones 2004-06-14 20:41:38 EDT
*** Bug 121449 has been marked as a duplicate of this bug. ***
Comment 159 Rolf Zimmerli 2004-06-15 11:04:58 EDT
With the boot-iso from comment #122 and the actual kernel rpm 2.6.6-
1.435 the installation is possible on my P4P800 board. Thanks for 
your work.
But now I would expect a new version of the iso images (installation, 
rescue,dvd,pxeboot).
There are many people which own ASUS boards, and I think it's bad for 
the image of fedora if 'normal users' can not boot the installation 
media.
Comment 160 Adi Dobrota 2004-06-16 07:40:18 EDT
arjan's modified ISO works with an Asus P4P800 deluxe, but as some
other users already encountered, I encounter a quick reboot too after
boot loader.
A new FC2 CD1 for Asus users would be great.

Will follow this one with interest.
Comment 161 Josep S. Blanes 2004-06-17 14:38:13 EDT
Thanks to Arjan van de Ven!!!
I have tried iso in comment #122 and it boots fine.

Actualization to 2.6.6-1.435 it's ok and work fine.
Comment 162 Paul Pianta 2004-06-17 15:23:41 EDT
updated boot.iso works for me too on my P4P800.

thankyou
Comment 163 Raoul Scheffler 2004-06-18 04:58:55 EDT
Hi, i am new to linux, but not to computers. Decided to put windows 
in the trashbin and choose fedora. Now i am a bit disappointed 
because of this boot prob. the modified image works for me too, but 
after install the problem persists. can someone explain how to change 
the installed kernel after a sucsessfull boot with the boot.iso. i 
have read the thread but can't figure out how to do it.

Many Thanks in advance.
Comment 164 Benjamin Bach 2004-06-18 19:21:57 EDT
My FC2 freezes after saying press 'I' to enter Interactive setup. Is
this the same bug? I have an AsRock P4-800 board.
Comment 165 Willard Stanley 2004-06-19 17:19:54 EDT
I own the motherboard in question and have beening following since  
#5, used #64 and simply installed from the ISO images rather than 
buring them to a cd.  Installation works perfectly under SMB kernel. 
Thanks to everyone for your help. 
 
As to comment #111,  No research team can make an OS that is all 
things to all people.  That is why Open source came into being. If 
you find a problem, you are free to fix it. Just be glad this isn't 
windows, we'd have to wait for the fix from the creators. Have more 
faith. 
Comment 166 Arjan van de Ven 2004-06-20 04:24:06 EDT
*** Bug 126336 has been marked as a duplicate of this bug. ***
Comment 167 J.Jansen 2004-06-20 15:02:10 EDT
Comment #153 and #164 seem to be the same problem to me
My suspicion is the graphical card. In #153 I mixed up numbers
My graphical card is a Asus V9520/TD. Which one was  used in #164?
Comment 168 Marcelo Emilio 2004-06-21 17:56:42 EDT
I could not install FEDORA even using boot iso from c#122. The 
install stop when formating boot sector. I am having a similar 
problem trying to install RH 9.0. I was never able to complete the 
instalation. I am already trying for a week. Any help?

My specs:
 MB: ASUS P4P800 Deluxe
 CPU: 2.8 GHz HT
 RAM: 500 MB
 HD: SAMSUNG SP0802N
Comment 169 Marcelo Emilio 2004-06-21 18:03:20 EDT
I could not install FEDORA even using boot iso from c#122. The 
install stop when formating boot sector. I am having a similar 
problem trying to install RH 9.0. I was never able to complete the 
instalation. I am already trying for a week. Any help?

My specs:
 MB: ASUS P4P800 Deluxe
 CPU: 2.8 GHz HT
 RAM: 500 MB
 HD: SAMSUNG SP0802N
Comment 170 Karl Kiniger 2004-06-23 16:30:31 EDT
My experiences with FC2 + P4P800E-deluxe(hope got it right): 
AMI bios 1002.002 02/25/04 3.0 GHz P4 HT on 
 
Arjans boot CD works, the kernel installed from the rpm on the CD 
reboots instantly. (it may write something to the screen but I cant 
read that fast :) 
 
kernel-2.6.6-1.435 (i686) SMP and UP works OK. 
 
Because I need the Nvidia drivers (xorg nv driver gives problems -  
horizontal white lines with certain screen contents) I turned 
off the 4K stack and regparams and recompiled. 
 
The resulting kernel hangs just after "Uncompressing ..." 
 
Next I tried kernel-2.6.7-1.437_2.rhfc2.at from ATrpms - same hang. 
pnpbios=off et al. does not help. 
 
so the p4p800 issue is still somewhat mysterious to me. 
 
Thanks in advance for any further hints - Karl 
Comment 171 slim 2004-06-26 06:30:27 EDT
i have a :

* asus p4p800s
* p4 northwood 2.66
* 512mb ram
* 1 x sata native

i had the same installation problem, with a bootdisk, it works now.
but when i start the System, and i choose fedorac2 on the Bootmanager
  , the System reboot !!! :( 
anyone have an idea how it could be work? thanks.
Comment 172 Paolo Prandini 2004-06-28 03:09:03 EDT
Hi, 

I wanted to report a SUCCESS STORY.
I have an ASUS P4P800S (means ICH5 plus a stripped down version of
i685PE w/o Dual Channel Memory, the i848P) that you can consider a P4P800.
I have followed the info in 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c122
and I booted with the iso and then launched the installation.
All went fine. Having Hyperthreading Enabled, forced the installer to
install SMP Stock Kernel too. At boot I choosed the SMP Kernel and
everything went fine. Speedy and stable I have now FC2 installed on my
blacklisted motherboard.
Conversely, when trying to boot with stock uniprocessor Kernel gives
the reboot.
As soon as I'll update the kernels I will report if the new ones work
in both cases.

- hope it helps
- Paolo

PS : At least this "resolves" for those with HT processors, but a new
iso, maybe for the rescue disk only would be greately appreciated and
easier to maintain than a whole 1st ISO remake.
Anyway thanks to Arjan for the iso image! 

Comment 173 Jeremy Katz 2004-06-28 14:53:34 EDT
*** Bug 126882 has been marked as a duplicate of this bug. ***
Comment 174 Jeremy Katz 2004-06-28 15:05:36 EDT
*** Bug 126884 has been marked as a duplicate of this bug. ***
Comment 175 Jeremy Katz 2004-06-29 15:01:10 EDT
*** Bug 126926 has been marked as a duplicate of this bug. ***
Comment 176 John Tomlinson 2004-07-02 08:30:52 EDT
This is great, thanks for the Boot ISO, now I have Fedora installed
and everything is working great..no problems at all, for the first
time my internet and sound also worked right away ; )

John 
Comment 177 Paolo Prandini 2004-07-03 16:19:08 EDT
Hi, 

Just finish testing new available kernels on my new FC2 install (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121819#c172 on
how I did it) 
Both 2.6.6.1-435 and 2.6.6.1-435smp smp boot fine.
If there was something wrong this seemes to be inside the stock kernel.

- Hope it helps
- Paolo
PS : Again a big thank to Arjan. FC2 is soooo good.
Comment 178 C.Laurence Gonsalves 2004-07-04 00:26:37 EDT
The ISO also worked for me. Thanks!

I did run into some other issues though. I thought I'd mention it
here, since it seems like it might be a common problem for people
interested in this bug (ie: P4P800 users). If the message "Kernel
panic: VFS: Unable to mount root fs on unknown-block(0,0)" looks
familiar to you, you might want to check out bug 126953 where I've
posted a workaround.
Comment 179 Mike Sowka 2004-07-04 15:17:40 EDT
OK OK!

I'm a proud "first reporter" of this bug... but how the heck do I take
myself off of the CC list on this RedHat bugzilla system?!

Please HELP!

Mike
Comment 180 Manfredo Hopp 2004-07-04 16:55:49 EDT
The invers of the previous comment applies to me. How the heck can I 
add a comment.I ve sent one two days ago which is misssing. (Previous 
sign issues, etc).
Manfredo HOpp
Comment 181 Manfredo Hopp 2004-07-04 17:04:39 EDT
Ok. NOw that I am seeing my comments appear I add the previous one 
which somehow didnt appear.
I downloaded the Iso Boot mentioned in comment 122 from 
http://people.redhat.com/arjanv/asusp4p800-boot.iso.
I burned a Cd fom that ISO file from within Windows XP and tried to 
boot with that Cd.
Response: something like "Put a boot media and press any key" 
(it doesnt boot at all)
What am I doing wrong?

Manfredo HOpp

As you can see I am a new Linux user (at least trying to be)
Comment 182 Bas Mevissen 2004-07-04 17:13:56 EDT
Enough mail...
Comment 183 IT REM 2004-07-05 15:26:30 EDT
Mike,
open this bug and at the end of the page select yours and my address 
at the CC: -box, check Remove selecterd CCs and Commit
- I think.
Comment 184 Mike Sowka 2004-07-05 15:31:20 EDT
Itrem,

The problem is: MY EMAIL DOES NOT APPEAR IN THE CC LIST!!!

>:( "RH Bugzilla, stop spamming me!"

Mike
Comment 185 Manfredo Hopp 2004-07-06 14:09:41 EDT
Since I cant use Boot iso,(I only have Windows XP), could somebody
attach vmlinuz in order to try to boot with ISOLINUX.?
Comment 186 Manfredo Hopp 2004-07-08 11:54:10 EDT
After burning Boot Iso and tring to open files in resulting Cd,
Windows tells me that it is expecting a disquette on that drive. The
only file I can open/copy/etc (maniulate) is asus.patch. On the other
hand when I do the same with distribution Cd I can open all files. 
I dont have any work around since I am installing for the FIRST time
on my computer!!!!!!!!!!!!
Comment 187 Manfredo Hopp 2004-07-08 13:23:15 EDT
I created a new boot.iso under Windows with the
kernel-2.6.6-1.383.i586.rpm that is in the boot iso of #122, but I get
the following error message from the boot prompt: "Invalid or corrupt
kernel image". I CANNOT USE THAT KERNEL!!!!!!!!!!!!!!!!
Comment 188 Marko 2004-07-08 18:08:52 EDT
I have P4@2,4GHz with HT, P4P800S MB, 512MB RAM, Nvidia GeForce 
FX5200, HDD: 80GB & 40GB WD

Well, I did all like it says in comment #122 and I finished 
installation and rebooted. But when I tried to boot into linux 
computer just restarted. I tried booting from Arjans modified cd and 
booted with linux rescue with intention to recompile kernel with smp 
option on. When I did make menuconfig most of the letters on the 
screen where completely unreadable. I did manage to compile kernel 
with kernel-2.6.5-i586.smp.config (or wathever it is called) and then 
tried booting again just to find that ext3 is not suported. I will 
try to recompile again with ext3 included and see if it works then.
Is it possible that I did something wrong or is that another bug?

I will post If recompiling works for me.
Comment 189 Manfredo Hopp 2004-07-08 19:34:33 EDT
Hey , Arjan , dont pretend that Windows doesnt exist . And new users 
as well.
If it really happens that fedora.org is a Linux users only place then 
say it, and I wont bother here any more.
Meanwile Im here, sitting on a fence....
(Dont hink I will give up)
Comment 190 C.Laurence Gonsalves 2004-07-09 03:31:20 EDT
Apologies to others on the CC list.

Manfredo: I was able to burn the ISO from comment #122 using Windows
XP. I used the "ISO Recorder Power Toy" available from
http://alexfeinman.brinkster.net/isorecorder.htm . Perhaps your
download was corrupted or your burn was bad. Are you sure your BIOS is
set to boot from CD before HDD?

A number of people have reported that the ISO works, myself included,
so it seems unlikely that the problem is with the ISO, or some sort of
conspiracy to prevent it from working with Windows.
Comment 191 Aleksey 2004-07-09 07:23:05 EDT
Hi guys!

I have some problems when trying to install FC2..

Here's the configuration of my PC:

ASUS P4P800 Motherboard
Intel p4 2400 HT processor
512 Kingston DDR 400
TEAC 524 CD-RW
Gigabyte Ge-Force 3 Ti 200 Videocard
Creative Audigy soundcard
S-ATA Seagate 160gb HDD
Seagate 120gb HDD <- I install FC on this disk

First, i have a problem with my blacklisted motherboard, i pass 
through it by downloading boot image from arjanv's site.. everything 
goes ok, but after partitioning disk, selecting packages (i try all 
of presets: server, workstation, dekstop and custom) and entering 
root password i have message like: "you are trying to install on 
machine that doesn't supported by this release of Fedora Core." 
My friend trying to install this distrib on his Siemens-Fujitsu 
notebook and have same "error", another man install it (from this 
cd's) on many other PC's.. 

Maybe is there some way to pass through this error?.. Maybe smb have 
same problem?..
I hope on your help ..

P.S.: FC 1 installs succesfully, but when i trying upgrade it to FC2 
i have the same error..
Comment 192 Marko 2004-07-09 16:14:38 EDT
Well finally I can say that I managed to boot into FC2 and that it, 
for now, works without any problems (hopefully it will stay that way)
. Recompiling kernel with smp solved the problem.
Thanks everyone for their helpfull posts.
Comment 193 Manfredo Hopp 2004-07-09 18:49:13 EDT
Iso files are device dependant, thats why! My apologies...
Comment 194 Peter 2004-07-12 07:32:17 EDT
It may be nice to update the release notes on the Fedora home page to 
that which is contained on the release CDs. This would alert anyone 
with a P4P800 motherboard (myself included) that there is a problem 
before downloading the CDs and attempting to install. I will try the 
workarounds mentioned above. I've been using RedHat for many years 
now. Keep up the good work. Peter.
Comment 195 Clive Stubbings 2004-07-15 19:21:06 EDT
Add One more to the list....

Motherboard is a Micro-ATX P4P800-VM
Processor Intel P4 2.8G

Problem with booting FC2 - boot stops at:

    PCI: Using configuration type 1
    mtrr: v2.0 (20020519)
    ACPI: Subsystem revision 20040326
    ACPI: IRQ9 SCI: Edge set to Level Trigger.

At this point it just hangs. Its totally consistent.

I have tried the asusp4p800-boot.iso - no change.
I have disabled all ACPI/APM option in the bios - no change

System boots OK with FC1, Slackware 10.0, Knoppix 3.3. I have a S-ATA
HD and both Slackware and FC1 require the IDE to be in "compatability
mode" else they hang accessing the IDE. Knoppix just boots.. But they
are all 2.4 kernels..

Cheers
Clive



Comment 196 Björn Englund 2004-07-17 09:42:34 EDT
Don't know if it is the same problem but I have been having
problems with Fedora Core 2.90 (FC3test1)
Motherboard: P4C800-E Deluxe
2 SATA disks on the ich5 controller (not the promise)
1 cd/dvd on primary PATA

Bug 1:
When I try to install the kernel starts but hangs after printing:
ACPI: IRQ9 SCI: Edge set to Level Trigger

When I add acpi=off or acpi=ht I get past that

Bug 2:
If the bios has
Enhanced Mode Support on P-ATA + S-ATA
I get
ICH5: 100% native mode on irq 11
and the later on
irq 11: nobody cared! (screaming interrupt?)
A lot of repeated error messages
Disabling IRQ #11
Then it continues with
Loading ohci driver...
Loading sata_piix driver...
Loading ata_piix driver...
And hangs
(Maybe not surprising if it has disabled the interrupt?)

To get around this I changed the bios setting to only have
Enhanced Mode Support on S-ATA

Bug 3:
With the work around for bugs 1 and 2 I can install core 3 test 1
but I need to add 'acpi=ht' to the kernel options.

Now /sbin/poweroff doesn't turn off the power it just shutsdown and
prints 
powerdown.

I can provide more debug info if needed.


Comment 197 Clive Stubbings 2004-07-17 22:58:56 EDT
I've been running down the same road an #196 and getting similar
results. Good news is that I have the Asus board running FC2 cleanly
and without any "non standard" builds - it just needed the right
combination of magic

If I added acpi=off to the boot options then it didn't hang at the 

    ACPI: IRQ9 SCI: Edge set to Level Trigger.

point any more. It then got as far as 

    --| Loading SCSI driver |--
    Loading usb-storage driver...

and again hung. However it would now respond to ctrl-alt-del.
Further fiddling, my case has an inbuilt usb compact-flash  
card reader. Disconnected that and then got a little further but it
was having trouble finding the S-ATA hard disk.
If its in enhanced mode something crashes - I can see the repeated
tracebacks scrolling off the screen - too fast to make sense of, but
something to do with IRQ 11 and eventually it hangs again.Same problem
as #196 I think.

However.. Looks like the best disk config is:
    Compatability mode
    Secondary P-ATA+S-

Plug the CD into the secondary ATA channel and then it appears as hdd
and the S-ATA appears as sda (yes sda not hda)
Like that its all working - Clean FC2 install, reboot and still happy.

After the install I re-connected the card reader and that
works fine too.. A CF appears as /dev/sdb1

So I'm up and running. I will build a new kernel and turn on acpi
later to see what happens..

Cheers
Clive
Comment 198 Manfredo Hopp 2004-07-30 20:04:35 EDT
After installing with boot.iso #122 and having the reboot problem, I
booted with KNOPPIX as rescue Cd and rebuilt with 2.6.5-1.383.src.rpm
after applying asus patch. Now it comes to the point of displaying a
graphic (and corrupted) screen (Fedora Core 2) and the system hangs.
I built with 586 & 686 config files only disabling Module Support in
both cases , and get the same result.
I tried to built with 2.6.7-1.499.src.rpm but I get a compile error in
fs/ext3/inodexxxx. 
Hardware is:
Asus P4P800 Deluxe
INtel Celeron , 2.4 GHZ, 800 MHZ FSB
2 GB RAM
120 Gb SATA
NVIDIA nV18 [Geforce MX 4000 AGP 8X]
Comment 199 Dieter Van Houtte 2004-07-31 09:19:12 EDT
Same here !!

Asus P4P800 Deluxe...
512 Ram
250 Gb Maxtor ==> NON-SATA !!
It is an ordinary IDE disk ... :s
Comment 200 Manfredo Hopp 2004-08-12 13:07:54 EDT
Dieter: I think our problem is because asus patch is not correctly
applied. kernel should display console messg. detecting mobo(see dmesg
atchmnt). I used i503.src.rpm to build kernel, applying patches (some
of them manually) and adapting distro i586.config to have a minimum
set of built-in modules to allow me to boot in.
Comment 201 Mani Singh 2004-08-27 20:55:25 EDT
Hi, Newbie here:)

My System:
Asus P4P800S, P4 2.4 800MHZ FSB, ATIRadeon 9200SE, 512MB, 2 X
40GB-NON-SATA

I had the same problem . Here is how I got it working. 

1. get the patch from here:
http://people.redhat.com/arjanv/asusp4p800-boot.iso - burn the image
file to a cd with nero or woteva .

2, insert this new patched cd and it shud start linux installation. At
one step it will ask you to insert the  installation media , thats
where you wud insert FC2- Disk 1 and then continue with normal
Installation.

3. After installed , You wud see that you still wont be able to boot
from GRUB. Each time you boot to FC2, it will just reboot.

4. Ok now, download this Kernel file : kernel 2.6.6-1.435.1686.rpm
from here 
http://public.planetmirror.com/pub/fedora/linux/core/updates/2/i386/kernel-2.6.6-1.435.i586.rpm

or basically from the mirror near to you.. ok now you have to waste
one more cd and put this single RPM file of about 13 mb in the cd.(I
did that)

This kernel worked for me thats why I mentioned this one, or else
there is no special reason.

5. Ok now, Hoping that you have Fedora Core 1 Disk 1 (I used that) - I
think basically anything which can take you in rescue mode shud work,
at the boot prompt type : linux rescue

no need to start networking. keep hitting enter until  u r in ur bash
shell.

at ur bash shell:
5.1 type: chroot /mnt/sysimage - enter
5.2 type: mkdir /mnt/cdrom     - enter
5.3 Mount the cd:  
    mount -t iso9660 /dev/hdc /mnt/cdrom
 
5.4 Insert the single RPM CD and cd to kernel location: cd /mnt/cdrom
5.5 Install the new kernel : rpm -ivh kernel-2.6.6-1.435.i686.rpm
5.6 If gives error do a force install rpm -ivh --force kernel..  .rpm
5.6 Reboot and now you wud see 2 kernels in GRUB. choose the new 1.

Hope that Helps,
M.Singh

Comment 202 hector brocklredhat 2004-08-30 00:57:54 EDT
i have the same problem installing, but i have got the dvd version of
fedora,,, and this workaround doesn't work with it

recon i'm gonna have to get the cd version
Comment 203 gonegahgah 2004-09-13 14:25:13 EDT
Same mobo brand different CPU brand but same problem I guess.

I can install Fedora 2 okay but when it boots it hangs after:
"Uncompressing Linux... Ok, booting the kernel."

I have the problem with the following config.

ASUS A7N8X-E Deluxe
1GB (PC3200)
1 120GB IDE drive, 1 15GB IDE drive
ATI 9550
Athlon 3200+ processor
Liteon DVD-Burner

I've added this as a new bug as well seeing this is a different CPU.
The new bug report is:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=132464
Comment 204 Scott 2004-10-14 17:52:39 EDT
I have the similar problem on a Compaq Presario SN1020NX 
Celeron 2.8 GHz, 512 MB ram, motherboard is unknown.

I have tried all of above workarounds. The new CD 
http://people.redhat.com/arjanv/asusp4p800-boot.iso 
still reboots immediately after 'load initrd.img'.

I even tried Fedora 3.0 test release (10-5-04),  same thing happens.
Comment 205 Thierry P. Schneider 2004-10-26 01:23:46 EDT
Dear RH development team:
I don't think anybody asked that question, but I would like to know 
when this bug is expected to be fixed in a release/CD install version 
(I don't want to rely on the workaround 
http://people.redhat.com/arjanv/asusp4p800-boot.iso since it is only 
working 50% of the time?)

Thanks in advance for your answer.

Thierry S.
[RH9 user since Oct 2003 who would like to switch to FC2, FC2+ (with 
the fix) or FC3 to have his network controller/sound card/video card 
and printer driver working better!  I also hope to have my wireless 
card IEEE 802.11g detected and working]
Comment 206 Jesus Salvo Jr. 2004-10-26 20:20:00 EDT
I am experiencing the same problem ... with a small difference: 
 
I am able to install and boot from FC2 using the kernel that came 
with the CD ( /boot/vmlinuz-2.6.5-1.358 ). 
 
After upgrading the kernel to vmlinuz-2.6.8-1.521, it reboots after 
"Uncompressing kernel ....". 
 
The solultion for me is to reboot back to vmlinuz-2.6.5-1.35. 
 
Also, FC1 was previously installed on the machine and was working 
without problems. 
 
The only thing is that during boot, dmesg shows the following: 
 
ACPI: RSDP (v000 AMI                                       ) @ 
0x000fa970 
ACPI: RSDT (v001 AMIINT VIA_K7   0x00000010 MSFT 0x00000097) @ 
0x27ff0000 
ACPI: FADT (v001 AMIINT VIA_K7   0x00000011 MSFT 0x00000097) @ 
0x27ff0030 
  >>> ERROR: Invalid checksum 
ACPI: DSDT (v001    VIA   VT8371 0x00001000 MSFT 0x0100000b) @ 
0x00000000 
ACPI: Unable to map DSDT 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
ACPI: DSDT not present 
 
 
However, this warning / error message has been there before even with 
FC1, but it did not cause any problems so far. 
 
Comment 207 Cliff Lo 2004-11-02 04:13:11 EST
I am experiencing the same problem.
But this has happend when the bios version 
changes from p4p81007 to others. 
Comment 208 Edwin Chan 2004-11-09 18:51:44 EST
Looks like the motherboard doesn't install problem occurs under FC3 
as well... is there any body looking into it?

- http://www.fedoraforum.org/forum/showthread.php?t=26369
- Bug 138430 (a duplicate of Bug 138419)
Comment 209 J.Jansen 2004-11-10 03:02:32 EST
I previously had the same problem with Fc2, but no problem occurs with
FC3. Yesterday evening I installed FC3 out of the box. Everything
works including LAN and sound.

Before this I also installed the 3 test versions and many updates on
these and never experienced severe problems with this mobo.

I have a P4P800-deluxe
         2 S-ata drives
         Asus GforceX graphical card

   Jouk
Comment 210 Thanasis 2004-11-10 06:56:37 EST
Can some more people confirm that they have installed FC3 on this
types of mobos?
Comment 211 Stanislav Polasek 2004-11-10 11:43:36 EST
I did. No problems whatsoever. It was quite different story, half year
ago, using the exact same hw :-)
Comment 212 Mike 2004-11-11 23:03:50 EST
I have P4P800-E Deluxe and FC3 installed flawlessly where FC2 would 
not.
Comment 213 Tom 2004-11-12 10:03:20 EST
I just installed FC3 with this hardware and I keep crashing. the
system just hangs everyso often. Even Sysreq does not work. good to
here other people are not having problems though.
Comment 214 redhat admin 2004-11-14 00:45:14 EST
redhat@mckerrs.net
Comment 215 Jesus Salvo Jr. 2004-11-14 19:52:52 EST
I posted back on 26th of October of having this problem in the 
reverse ... where the kernel that came with the original FC2 release 
works and installs FC2, but upgrading to the kernel 2.6.5-1.358 
caused problems, as in during boot, I can see "Uncompressing 
xxxx...." and then reboots straightaway. 
 
In case anyone's wondering, here are some relevant output from lspci, 
just in case it might shed some light: 
 
# /sbin/lspci 
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] 
(rev 03) 
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 
AGP] 
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super 
South] (rev 40) 
00:07.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) 
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 1a) 
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 1a) 
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] 
(rev 40) 
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 
AC97 Audio Controller (rev 50) 
00:0a.0 Communication controller: Lucent Microelectronics LT WinModem 
00:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21153 (rev 
04) 
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA 
TNT2 Model 64/Model 64 Pro] (rev 15) 
02:00.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01) 
02:00.1 Ethernet controller: Sun Microsystems Computer Corp. Happy 
Meal (rev 01) 
02:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01) 
02:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy 
Meal (rev 01) 
02:02.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01) 
02:02.1 Ethernet controller: Sun Microsystems Computer Corp. Happy 
Meal (rev 01) 
02:03.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01) 
02:03.1 Ethernet controller: Sun Microsystems Computer Corp. Happy 
Meal (rev 01) 
 
Comment 216 Jesus Salvo Jr. 2004-11-14 19:54:54 EST
Sorry ... that should have said: 
 
"I posted back on 26th of October of having this problem in the  
reverse ... where the kernel that came with the original FC2 release  
works and installs FC2, but upgrading to the 
____kernel-2.6.8-1.521____  
caused problems, as in during boot, I can see "Uncompressing  
xxxx...." and then reboots straightaway. : 
Comment 217 slim 2005-05-19 12:42:33 EDT
has fedora 3 the same conflict with asus p4p800??
its time to do some thing Fedora!!!!!! :(
Comment 218 J.Jansen 2005-05-20 02:50:46 EDT
The problems I had with this mobo were with fc2 only
since august I'm a happy user of FC3.



Comment 219 Ken Smith 2005-09-15 08:25:39 EDT
Has the root cause of this problem been identified? Is there any reason to 
think that the problem is cleared in FC4? 

Or is the P4P800 series to be relegated to being a MS Windows only platform?
Comment 220 Phil Salkie 2005-09-15 14:35:27 EDT
I had this problem with FC2 and Asus P4P800 - it was found and fixed
(see 124 above) and there's been no traffic on this problem since
November.  My P4P800 has booted FC3, FC4 Test, and FC4 install CDs
just fine, for what that's worth - I'd say it's closed and fixed in latest release.
~                                   

Note You need to log in before you can comment on or make changes to this bug.