Bug 1269414 - yum-plugin-priorities does not blacklist all the obsoleted packages
yum-plugin-priorities does not blacklist all the obsoleted packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum-utils (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
Eva Mrakova
:
Depends On:
Blocks: 1313485 1269416 1275788 1289025 1299750
  Show dependency treegraph
 
Reported: 2015-10-07 05:40 EDT by Boris Ranto
Modified: 2016-11-03 20:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-35.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1269416 1329109 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:13:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2187 normal SHIPPED_LIVE yum-utils bug fix and enhancement update 2016-11-03 09:18:35 EDT

  None (edit)
Description Boris Ranto 2015-10-07 05:40:09 EDT
Description of problem:
When yum-plugin-priorities is configured to check (blacklist) obsoleting packages ( echo check_obsoletes=1 >> /etc/yum/pluginconf.d/priorities.conf ), it will blacklist only the latest obsoleting package, not the older ones that may be present in some other repos.


Version-Release number of selected component (if applicable):
yum-plugin-priorities-1.1.31-33.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a repo with 2 versions of a package that obsolete some other package
2. Bump the priority of the repo with the package that is being obsoleted
3. Try to install something that requires the obsoleted package with yum

Actual results:
Dependency problem because not all the obsoleted packages were masked.

Expected results:
The package installs fine.

Additional info:
Ceph upstream is hitting this when they are trying to install firefly branch on a rhel 7.1 host with epel enabled (*).

Here, base rhel 7.1 contains python-rados and python-rbd packages and epel contains python-rados and python-rbd packages. These packages obsolete python-ceph. The firefly branch of ceph does not split the python-ceph package into python-rados and python-rbd and uses the old python-ceph package. If you use the upstream repo for the firefly branch and bump its priority, 'yum install ceph' will fail because not all the python-rados and python-rbd packages were blacklisted/masked, only the latest one (as can be seen by yum install -v ceph).

(*) see upstream tracker http://tracker.ceph.com/issues/11104 for more details
Comment 2 Valentina Mukhamedzhanova 2015-12-09 10:05:57 EST
Boris, I can't seem to be able to reproduce the problem using the suggested steps. I believe https://github.com/rpm-software-management/yum-utils/blob/master/plugins/priorities/priorities.py#L164 should take care of the case you're describing. Could you provide a tarball with repositories for reproducing the problem?
Comment 3 Boris Ranto 2015-12-09 10:50:24 EST
Yeah, we do use yum-plugin-priorities. However, there is a bug that it fails to mask obsoleted packages if they occur twice (or more) in the repos. (e.g. base repo and testing repo)

Reproducer steps can be e.g. (contains two copies of ceph-common package in two separate repositories + link to upstream ceph repo):

wget http://lacrosse.corp.redhat.com/~branto/ceph.tar
cd /root/
tar -xvf ceph.tar
cp ceph.repo /etc/yum.repos.d/
yum install ceph # this will require some packages from epel so you need to have epel enabled as well

This will fail to install the older version of ceph packages even though there is priority=1 for the upstream repo.

Now, if you modify the ceph.repo file and disable the secondary local repo, it will install the packages just fine. Hence, the conclusion (confirmed by my last run with verbose yum output) that for obsoleted package the plugin masks only the latest package that it can find, not all of them.

btw: Please note that you need to have check_obsoletes=1 in /etc/yum/pluginconf.d/priorities.conf for the plugin to even mask the latest available package.
Comment 4 Valentina Mukhamedzhanova 2015-12-10 10:26:12 EST
Boris, thank you for the reproducer! This should fix the problem - https://github.com/rpm-software-management/yum-utils/commit/834a4ff4f2752631252cff4e3b2ba87bee62965b
Comment 10 errata-xmlrpc 2016-11-03 20:13:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2187.html

Note You need to log in before you can comment on or make changes to this bug.