Bug 1275788 - [ceph] yum-plugin-priorities does not blacklist all the obsoleted packages -- librados2-devel, librbd1-devel
[ceph] yum-plugin-priorities does not blacklist all the obsoleted packages --...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ceph (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Boris Ranto
Fedora Extras Quality Assurance
:
Depends On: 1269414 1269416
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 14:17 EDT by Boris Ranto
Modified: 2015-11-13 14:24 EST (History)
6 users (show)

See Also:
Fixed In Version: ceph-0.80.7-0.7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269416
Environment:
Last Closed: 2015-11-13 14:24:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Ranto 2015-10-27 14:17:46 EDT
+++ This bug was initially created as a clone of Bug #1269416 +++

+++ This bug was initially created as a clone of Bug #1269414 +++

Description of problem:
When yum-plugin-priorities is configured to check (blacklist) obsoleting packages ( echo check_obsoletes=1 >> /etc/yum/pluginconf.d/priorities.conf ), it will blacklist only the latest obsoleting package, not the older ones that may be present in some other repos.


Version-Release number of selected component (if applicable):
yum-plugin-priorities-1.1.31-33.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a repo with 2 versions of a package that obsolete some other package
2. Bump the priority of the repo with the package that is being obsoleted
3. Try to install something that requires the obsoleted package with yum

Actual results:
Dependency problem because not all the obsoleted packages were masked.

Expected results:
The package installs fine.

Additional info:
Ceph upstream is hitting this when they are trying to install firefly branch on a rhel 7.1 host with epel enabled (*).

Here, base rhel 7.1 contains python-rados and python-rbd packages and epel contains python-rados and python-rbd packages. These packages obsolete python-ceph. The firefly branch of ceph does not split the python-ceph package into python-rados and python-rbd and uses the old python-ceph package. If you use the upstream repo for the firefly branch and bump its priority, 'yum install ceph' will fail because not all the python-rados and python-rbd packages were blacklisted/masked, only the latest one (as can be seen by yum install -v ceph).

(*) see upstream tracker http://tracker.ceph.com/issues/11104 for more details

--- Additional comment from Boris Ranto on 2015-10-07 05:53:59 EDT ---

This is a bz to get rid of the second copies of python-rados and python-rbd that are in epel in order to avoid the issue mentioned in first comment.

--- Additional comment from Fedora Update System on 2015-10-07 05:55:34 EDT ---

ceph-0.80.7-0.6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-40bf39f476

--- Additional comment from Fedora Update System on 2015-10-07 15:19:40 EDT ---

ceph-0.80.7-0.6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update ceph'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-40bf39f476

--- Additional comment from Fedora Update System on 2015-10-26 14:55:32 EDT ---

ceph-0.80.7-0.6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 1 Boris Ranto 2015-10-27 14:20:50 EDT
The similar issue appears when you try to install ceph-devel, the librados2-devel and librbd1-devel packages need to be masked to fix this.
Comment 2 Fedora Update System 2015-10-27 14:21:53 EDT
ceph-0.80.7-0.7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e71600c1f0
Comment 3 Fedora Update System 2015-11-01 11:50:49 EST
ceph-0.80.7-0.7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update ceph'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e71600c1f0
Comment 4 Fedora Update System 2015-11-13 14:24:19 EST
ceph-0.80.7-0.7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.