Bug 1269477 - katello-service man page lists options not available
Summary: katello-service man page lists options not available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard: FAILEDQA in Upstream
Depends On: 1335214
Blocks: 1317008
TreeView+ depends on / blocked
 
Reported: 2015-10-07 12:14 UTC by Stuart Auchterlonie
Modified: 2019-11-14 07:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:57:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
katello-service man page (93.80 KB, image/png)
2016-06-17 17:23 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11826 None None None Never
Red Hat Bugzilla 1213767 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1213767

Description Stuart Auchterlonie 2015-10-07 12:14:46 UTC
Description of problem:

katello-service man page lists options not available

eg. allstopped is in the manpage but not supported

# katello-service --help
Usage: katello-service [options] [restart|stop|start|status|list]
        --exclude [SERVICES]         A comma-separated list of services to skip


Version-Release number of selected component (if applicable):

Sat 6.1.2

How reproducible:

100%


Steps to Reproduce:
1. Read man page
2. Try katello-service allstopped
3.

Actual results:

# katello-service allstopped
katello-service: Received unsupported arguments: allstopped


Expected results:

Don't list unsupported options in the man page


Additional info:

Comment 2 Bryan Kearney 2015-10-07 20:49:31 UTC
Connecting redmine issue http://projects.theforeman.org/issues/11826 from this bug

Comment 3 Bryan Kearney 2015-10-07 22:05:19 UTC
Upstream bug component is Documentation

Comment 5 Bryan Kearney 2015-10-21 20:06:57 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 6 Bryan Kearney 2015-10-21 20:07:00 UTC
Upstream bug component is Documentation

Comment 10 Tazim Kolhar 2015-11-20 19:10:33 UTC
FAILEDQA:
# rpm -qa  | grep foreman
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-debug-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511111339git7cbe47a.el7.noarch
foreman-compute-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
# katello-service allstopped
katello-service: Received unsupported arguments: allstopped

Comment 11 Bryan Kearney 2015-11-20 21:04:32 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11826 has been closed

Comment 12 Stuart Auchterlonie 2015-12-01 09:13:07 UTC
The status of this bugzilla does not make sense.

It purports to be a man page change, yet we have a QA fail from attempting
to use the allstopped command on katello-service.

From where i'm standing the QA test is completely wrong for this issue.

Tazim, why are we not testing the updated man page????

Comment 13 Stephen Benjamin 2015-12-02 18:00:51 UTC
Why was this even QA'd? Also, there's no need for your comment to be private, default to open please.

Comment 19 Tazim Kolhar 2016-03-22 08:35:37 UTC
Hi,

   Have sent an email describing the issue 
   and problems occurring while verification of
   man page for katello-service list

Thanks and Regards,
Tazim

Comment 20 Tazim Kolhar 2016-03-22 09:48:50 UTC
VERIFIED:
# rpm -qa | grep foreman
tfm-rubygem-foreman_gutterball-0.0.1-6.el7sat.noarch
ibm-x3550m3-09.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-selinux-1.11.0-1.el7sat.noarch
tfm-rubygem-foreman_theme_satellite-0.1.2-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.5.1.2-1.el7sat.noarch
tfm-rubygem-foreman_openscap-0.5.3.0-1.el7sat.noarch
ibm-x3550m3-09.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.10-2.el7sat.noarch
foreman-compute-1.11.0.6-1.el7sat.noarch
tfm-rubygem-foreman_bootdisk-6.1.0-1.el7sat.noarch
foreman-gce-1.11.0.6-1.el7sat.noarch
foreman-postgresql-1.11.0.6-1.el7sat.noarch
foreman-proxy-1.11.0.1-1.el7sat.noarch
foreman-installer-1.11.0.0-1.el7sat.noarch
tfm-rubygem-foreman-tasks-0.7.14.1-1.el7sat.noarch
foreman-vmware-1.11.0.6-1.el7sat.noarch
foreman-debug-1.11.0.6-1.el7sat.noarch
tfm-rubygem-foreman_hooks-0.3.9-2.el7sat.noarch
foreman-discovery-image-3.0.5-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-4.el7sat.noarch
foreman-1.11.0.6-1.el7sat.noarch
foreman-ovirt-1.11.0.6-1.el7sat.noarch
foreman-libvirt-1.11.0.6-1.el7sat.noarch
tfm-rubygem-foreman_discovery-5.0.0.1-1.el7sat.noarch
foreman-installer-katello-3.0.0.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-5.el7sat.noarch
tfm-rubygem-foreman_docker-2.0.1-1.el7sat.noarch
tfm-rubygem-foreman-redhat_access-1.0.1-1.el7sat.noarch
ibm-x3550m3-09.lab.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
puppet-foreman_scap_client-0.3.3-10.el7sat.noarch
tfm-rubygem-foreman_remote_execution-0.3.0.1-1.el7sat.noarch

Steps:
1. # katello-service --help
    Usage: katello-service [options] [restart|stop|start|status|list]
         --exclude [SERVICES]         A comma-separated list of services to skip
         --only [SERVICES]            A comma-separated list of services to include


2. # katello-service --only tomcat.service restart
    Success!
    Success!

3.  # katello-service --exclude tomcat.service restart
    Redirecting to /bin/systemctl stop  foreman-tasks.service
    Redirecting to /bin/systemctl stop  httpd.service
    Redirecting to /bin/systemctl stop  pulp_workers.service
    Redirecting to /bin/systemctl stop  pulp_resource_manager.service
    Redirecting to /bin/systemctl stop  pulp_celerybeat.service
    Redirecting to /bin/systemctl stop  foreman-proxy.service
    Redirecting to /bin/systemctl stop  tomcat.service
    Redirecting to /bin/systemctl stop  qdrouterd.service

    Redirecting to /bin/systemctl stop  qpidd.service
    Redirecting to /bin/systemctl stop  postgresql.service
    Redirecting to /bin/systemctl stop  mongod.service
    Success!
   
Irrespective of the output, the man page shows only
supported options

Comment 23 Stuart Auchterlonie 2016-05-10 09:37:52 UTC
There is still a problem here.

# man katello-service
man: warning: /usr/share/man/man8/katello-service.8.asciidoc.gz: ignoring bogus filename
No manual entry for katello-service

# rpm -q --whatprovides /usr/share/man/man8/katello-service.8.asciidoc.gz
katello-service-3.0.0-3.el7sat.noarch

So even if the man page has been fixed, we have a packaging issue here
because we are shipping an asciidoc file rather than a man page.


Regards
Stuart

Comment 24 Stephen Benjamin 2016-05-11 15:19:49 UTC
BZ1335214 will fix the build of the man page.  That needs a QACK.  Do note when someone QA's this again, `katello-service --help` isn't a man page, do `man katello-service` instead.

Comment 27 Corey Welton 2016-06-13 11:47:43 UTC
QE -> jcalla

Comment 28 jcallaha 2016-06-17 17:22:57 UTC
Verified in Satellite 6.2 Beta Snap 15.2

Man page works for katello-service and all options are currently valid. See attached screenshot.

Comment 29 jcallaha 2016-06-17 17:23:27 UTC
Created attachment 1169186 [details]
katello-service man page

Comment 31 errata-xmlrpc 2016-07-27 08:57:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.