Bug 1269756 - Python 3.5
Python 3.5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Python Maintainers
ChangeAcceptedF24, SystemWideChange
:
Depends On: 1282404 1282413 1291218
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 03:20 EDT by Jan Kurik
Modified: 2016-07-25 15:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-27 07:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-10-08 03:20:31 EDT
This is a tracking bug for Change: Python 3.5
For more details, see: https://fedoraproject.org//wiki/Changes/python3.5

Update the Python 3 stack in Fedora from Python 3.4 to Python 3.5.
Comment 2 Jan Kurik 2016-02-24 09:26:14 EST
On 2016-Feb-23, we have reached Fedora 24 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-Feb-26 meeting.  Contingency plan for System Wide Changes, if planned for Alpha (or in case of serious doubts regarding Change completion), will be activated.
Comment 3 Petr Viktorin 2016-02-24 10:12:56 EST
Currently I know of 4 remaining Python packages that FTBFS:
* python3-cherrypy - https://bugzilla.redhat.com/show_bug.cgi?id=1307958
  - FTBFS mainly due to a change to Python's private ast module
  - Pull request on review upstream
* python-wsme - https://bugzilla.redhat.com/show_bug.cgi?id=1307955
  - Strange test failures
  - Requires cherrypy
* python-shapely - https://bugzilla.redhat.com/show_bug.cgi?id=1307947
  - Missing test modules
  - Patch sent to maintainer, looks on track
* python-pykalman - https://bugzilla.redhat.com/show_bug.cgi?id=1307936
  - Test failures that seem related to SciPy; packager says they're working on it

Also, the packages "python3-bsddb3" and "ris-linux" depend on py 3.4 as well as 3.5 for some reason. Will investigate.

I'll try to have a more detailed summary for 2016-Feb-26.
Comment 4 Petr Viktorin 2016-02-24 10:18:32 EST
Ignore my comment about python3-bsddb3 and ris-linux, they look good.
It was a mistake in my methodology.
Comment 5 Robert Kuska 2016-02-25 06:39:42 EST
All of the important packages were successfully rebuilt.
Comment 6 Alan Pevec 2016-02-27 13:00:37 EST
python-wsme has been retired in f24 due to py3.5 incompatibility and ceased upstream development.
Comment 7 Jan Kurik 2016-04-20 11:02:10 EDT
On 2016-Apr-19 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 24 release. At this point all the Changes not at least in in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 8 Petr Viktorin 2016-04-21 04:19:23 EDT
All green.

python-wsme was retired, the others fixed.
Comment 9 Petr Viktorin 2016-06-27 07:22:36 EDT
Fedora 24 has been released, and there was much rejoicing.
Possible remaining issues shouldn't be tracked here.

Note You need to log in before you can comment on or make changes to this bug.