Bug 126981 - Broadcast client broken in 4.2
Broadcast client broken in 4.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Ryska
http://bugzilla.ntp.org/show_bug.cgi?...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 20:28 EDT by Charles Gillet
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 19:25:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Gillet 2004-06-29 20:28:27 EDT
Description of problem:

Broadcast client broken


Version-Release number of selected component (if applicable):

4.2.0


How reproducible:

Easily


Steps to Reproduce:
1. Set up a box to broadcast NTP time on your net
2. Set up another client as broadcastclient in /etc/ntp.conf
3. Note no time sync!
  
Actual results:

ntpq -p returns no associations


Expected results:

ntpq -p should show your broadcasting time server


Additional info:

I rely on broadcasts so I only have to manually configure ip addresses
 in step-tickers, and make use of broadcasts to keep sync over time. 
Posting the bug so it gets on the Fedora radar.
Comment 1 Harald Hoyer 2004-08-31 08:11:35 EDT
please attach your ntp.conf
Comment 2 Charles Gillet 2004-08-31 13:01:29 EDT
A file with only one line is needed:

broadcastclient

/etc/sysconfig/ntpd has:

# Drop root to id 'ntp:ntp' by default.  Requires kernel >= 2.2.18.
OPTIONS="-U ntp -p /var/run/ntpd.pid"

I tried removing "-U ntp" so the daemon would run as root, in case
root is needed to listen to broadcasts, but it didn't help.
Comment 3 Henning Schmiedehausen 2004-12-26 11:27:03 EST
add 

disable auth

Then it works. Same for multicast.
Comment 4 Charles Gillet 2005-01-02 17:00:34 EST
Progress I guess.  Now I get a different error.

bind() fd 10, family 2, port 123, addr 192.168.128.15, in_classd=0
flags=8 fails: Address already in use

This looks like the ntp.org bug 267, i.e. not figuring out how to
treat the broadcast address properly.  Henning, can you post your
happily-running broadcastclient ntp.conf ?
Comment 5 Charles Gillet 2005-01-21 19:25:13 EST
Ok, I was able to get everything working with disable auth.  Thanks 
Henning!

Note You need to log in before you can comment on or make changes to this bug.