Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1269842 - [webadmin] Selected display type is not supported by the operating system.
Summary: [webadmin] Selected display type is not supported by the operating system.
Keywords:
Status: CLOSED DUPLICATE of bug 1269843
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-08 10:41 UTC by Jiri Belka
Modified: 2015-10-08 12:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-08 12:42:28 UTC
oVirt Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Jiri Belka 2015-10-08 10:41:47 UTC
Description of problem:

I had a VM running on my 3.6 engine env (including RHEL7 hosts with 3.6 vdsm). I needed to test something so I modified this VM settings and changed cluster to another one with 3.5 cluster level and got this warning:

--->%---
	
Operation Canceled
Error while executing action:

jb-bz1:

    Cannot edit VM Cluster. Selected display type is not supported by the operating system.

---<%---

What is 'display type' in this context? There's no word 'display' in VM Settings/Console; this error causes big confusion! I have no idea what's wrong, SPICE is supported on 3.5 cluster and RHEL6 64bit OS type.

Changing QXL to Cirrus causes switch to VNC (not acceptable, 3.5 supports SPICE). Only SPICE is acceptable for me for this VM and I can't have SPICE for this VM, this is dumb. I can't even change to VNC!

--->%---
2015-10-08 12:40:09,115 DEBUG [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] Found permission '00000019-0019-0019-0019-000000000080' for user when running 'ChangeVMCluster',
 on 'VM' with id 'cb7315e0-e835-46f0-8088-fcf0858f04ca'
2015-10-08 12:40:09,117 DEBUG [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] Found permission '00000019-0019-0019-0019-000000000080' for user when running 'ChangeVMCluster',
 on 'Cluster' with id '4cd11758-7f8a-4e46-8c13-f58756c29f62'
2015-10-08 12:40:09,147 WARN  [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] CanDoAction of action 'ChangeVMCluster' failed for user admin@internal. Reasons: VAR__ACTION__UP
DATE,VAR__TYPE__VM__CLUSTER,ACTION_TYPE_FAILED_ILLEGAL_VM_DISPLAY_TYPE_IS_NOT_SUPPORTED_BY_OS
---<%---

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0-0.18.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. 3.6 engine, 3.6 cluster, 3.6 host (RHEL7)
2. install RHEL6 64bit VM with _SPICE_
3. 3.5 cluster, 3.5 host/vdsm (RHEL6)
4. edit the installed VM settings while done and switch cluster to the 3.5 one

Actual results:
-     Cannot edit VM Cluster. Selected display type is not supported by the operating system.
- cannot get SPICE for this VM

Expected results:
should work, we support SPICE for ages

Additional info:

Comment 1 Jiri Belka 2015-10-08 12:42:28 UTC
Bad bad bugzilla, again I saw an error but the BZ got already submitted in the background.

*** This bug has been marked as a duplicate of bug 1269843 ***


Note You need to log in before you can comment on or make changes to this bug.