Bug 1269848 - [RFE] access to engine vm console should be through vdsm
[RFE] access to engine vm console should be through vdsm
Status: CLOSED WONTFIX
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: UX (Show other bugs)
2.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Ido Rosenzwig
meital avital
: FutureFeature
: 1269850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 07:00 EDT by Yedidyah Bar David
Modified: 2018-02-15 07:01 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-15 07:01:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2015-10-08 07:00:28 EDT
Description of problem:

Following bug 1215436 and a discussion with Alon, we should tell users to use
vdsm tools to access the console. If vdsm does not yet provide such tools
(didn't check), we should open a dependent bug there.
Comment 1 Simone Tiraboschi 2015-11-19 11:24:49 EST
*** Bug 1269850 has been marked as a duplicate of this bug. ***
Comment 2 Simone Tiraboschi 2015-11-23 04:57:26 EST
After a brief discussion with Didi, he is basically asking to:
1. add another option to vdsClient (or a dedicated new tool) to actually act as a wrapper of socat letting the user connect to the VM using that instead of directly using socat
2. from hosted-engine-setup just print: 'use vdsClient --connectVMConsole <vmname>' per something similar hiding all the connection details.
Probably we could also use the same command with an additional option to let the user choose a textual or graphical connection.

The benefit of this is that we move all the connection handling details in VDSM and we completely decouple hosted-engine-setup on this side: any new parameter or connection strategy will be handled on VDSM side only.
Comment 3 Ido Rosenzwig 2018-02-15 07:01:31 EST
VDSM does not have a console feature we can use, therefore closing the bug.

Note You need to log in before you can comment on or make changes to this bug.