Bug 1269864 - RHEL7.2:Samba Epoch: Samba update fails with dependency error for libtalloc-devel and other libraries when testing upgrade from rhel7.2 ISO repo
RHEL7.2:Samba Epoch: Samba update fails with dependency error for libtalloc-d...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rhs-smb@redhat.com
storage-qa-internal@redhat.com
: ZStream
: 1271190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 07:33 EDT by surabhi
Modified: 2015-11-19 07:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:55:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2015-10-08 07:33:53 EDT
Description of problem:
************************************
Yum update for samba with (EPOCH version)fails with dependency errors for libtalloc, libtevent and libtdb when RHEL7.2 ISO repo and samba-epoch repo is added.

The issue is as follows:
*****************************
Install RHGS3.1 ISO
Subscribe to Live channels for RHGS and samba
Yum install all (samba packages)
Yum update
Add RHEL7.2 ISO repo
Add samba Epoch repo
Yum update

The update fails with following error:

Error: Package: libtalloc-devel-2.1.1-4.el7rhgs.x86_64 (@rh-gluster-3-for-rhel-7-server-rpms)
           Requires: libtalloc = 2.1.1-4.el7rhgs
           Removing: libtalloc-2.1.1-4.el7rhgs.x86_64 (@anaconda/3.1.1)
               libtalloc = 2.1.1-4.el7rhgs
           Updated By: libtalloc-2.1.2-1.el7.x86_64 (rhel-server)
               libtalloc = 2.1.2-1.el7
           Available: libtalloc-2.0.8-4.el7.i686 (rhel-7-server-rpms)
               libtalloc = 2.0.8-4.el7
           Available: libtalloc-2.1.1-1.el7.i686 (rhel-7-server-rpms)
               libtalloc = 2.1.1-1.el7
Error: Package: libtevent-devel-0.9.23-1.el7rhgs.x86_64 (@rh-gluster-3-for-rhel-7-server-rpms)
           Requires: libtevent(x86-64) = 0.9.23-1.el7rhgs
           Removing: libtevent-0.9.23-1.el7rhgs.x86_64 (@anaconda/3.1.1)
               libtevent(x86-64) = 0.9.23-1.el7rhgs
           Updated By: libtevent-0.9.25-1.el7.x86_64 (rhel-server)
               libtevent(x86-64) = 0.9.25-1.el7
           Available: libtevent-0.9.18-6.el7.x86_64 (rhel-7-server-rpms)
               libtevent(x86-64) = 0.9.18-6.el7
           Available: libtevent-0.9.21-3.el7.x86_64 (rhel-7-server-rpms)
               libtevent(x86-64) = 0.9.21-3.el7
Error: Package: libtdb-devel-1.3.4-1.el7rhgs.x86_64 (@rh-gluster-3-for-rhel-7-server-rpms)
           Requires: libtdb = 1.3.4-1.el7rhgs
           Removing: libtdb-1.3.4-1.el7rhgs.x86_64 (@anaconda/3.1.1)
               libtdb = 1.3.4-1.el7rhgs
           Updated By: libtdb-1.3.6-2.el7.x86_64 (rhel-server)
               libtdb = 1.3.6-2.el7
           Available: libtdb-1.2.12-3.el7.i686 (rhel-7-server-rpms)
               libtdb = 1.2.12-3.el7
           Available: libtdb-1.3.0-1.el7.i686 (rhel-7-server-rpms)
               libtdb = 1.3.0-1.el7

************************************************************************

The issue here is when samba-devel pkg is installed it installs
libtalloc-devel,libtevent-devel and libtdb-devel packages as dependencies.
Now when we add RHEL7.2 ISO repo and samba epoch repo, it tries to update samba-devel rhgs package which would update libtalloc-devel and libtalloc package as well, But the libtalloc-devel package is available in RHEL-optional channel so the update would fail as the optional channel is not available.

As rhgs channel ships all these libraries and the devel pkgs as well , we have these dependencies :

As discussed with Rejy we may have two solutions for this:

1. If we don't have a necessity to build these libraries in rhgs we can have 
multi-product-mapping in errata which means the libraries mentioned above , when get tagged to RHEL-optional channel will also get tagged to rhgs channel and we will have the latest version of devel packages as shipped by RHEL.

2. Rebuild all the libraries , epoch it and release it in rhgs channel.

****************************************************************


Version-Release number of selected component (if applicable):
Samba-epoch build

How reproducible:
Always

Steps to Reproduce:

Install RHGS3.1 ISO
Subscribe to Live channels for RHGS and samba
Yum install all (samba packages)
Yum update
Add RHEL7.2 ISO repo
Add samba Epoch repo
Yum update


Actual results:
Yum update fails

Expected results:
Yum update should not fail. Details explained in description.

Additional info:
The issue is only with the devel pkgs of libraries.If samba-devel is not installed then the update works fine for epoch samba version and also RHEL libraries gets updated without any dependency.
Comment 2 Guenther Deschner 2015-10-13 07:05:13 EDT
*** Bug 1271190 has been marked as a duplicate of this bug. ***
Comment 5 surabhi 2015-11-13 06:12:25 EST
With latest Samba packages and libraries added to samba channel, the update works fine and there are no dependency issues with libraries.

Steps to verify :
Install RHGS3.1 ISO
Subscribe to Live channels for RHGS and samba
Yum install all (samba packages)
Yum update
Add RHEL7.2 ISO repo
Add samba repo
Yum update


samba-client-libs-4.2.4-6.el7rhgs.x86_64
samba-dc-libs-4.2.4-6.el7rhgs.x86_64
samba-test-devel-4.2.4-6.el7rhgs.x86_64
samba-common-tools-4.2.4-6.el7rhgs.x86_64
samba-winbind-krb5-locator-4.2.4-6.el7rhgs.x86_64
samba-pidl-4.2.4-6.el7rhgs.noarch
samba-common-libs-4.2.4-6.el7rhgs.x86_64
samba-winbind-4.2.4-6.el7rhgs.x86_64
samba-dc-4.2.4-6.el7rhgs.x86_64
samba-vfs-glusterfs-4.2.4-6.el7rhgs.x86_64
samba-libs-4.2.4-6.el7rhgs.x86_64
samba-test-libs-4.2.4-6.el7rhgs.x86_64
samba-winbind-modules-4.2.4-6.el7rhgs.x86_64
samba-test-4.2.4-6.el7rhgs.x86_64
samba-devel-4.2.4-6.el7rhgs.x86_64
samba-4.2.4-6.el7rhgs.x86_64
samba-winbind-clients-4.2.4-6.el7rhgs.x86_64
samba-common-4.2.4-6.el7rhgs.noarch
samba-python-4.2.4-6.el7rhgs.x86_64
samba-client-4.2.4-6.el7rhgs.x86_64
[root@localhost ~]# rpm -qa | grep ctdb
ctdb-4.2.4-6.el7rhgs.x86_64


Marking the BZ verified.
Comment 7 errata-xmlrpc 2015-11-19 07:55:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2467.html

Note You need to log in before you can comment on or make changes to this bug.