Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1269909 - RFE: Implement dump-guest-memory in qemu-system-aarch64
Summary: RFE: Implement dump-guest-memory in qemu-system-aarch64
Keywords:
Status: CLOSED DUPLICATE of bug 1299867
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andrew Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1173755
TreeView+ depends on / blocked
 
Reported: 2015-10-08 13:16 UTC by Richard W.M. Jones
Modified: 2016-01-21 14:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-21 14:51:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Richard W.M. Jones 2015-10-08 13:16:18 UTC
Description of problem:

It's not possible to use the 'virsh dump --memory-only' option on
aarch64 at the moment.  It seems to rely on a qemu feature which is
not implemented (even upstream) on aarch64:

$ virsh dump --memory-only guestfs-b1rs92hpq4izkpvi /tmp/guestfs-b1rs92hpq4izkpvi.core
error: Failed to core dump domain guestfs-b1rs92hpq4izkpvi to
/tmp/guestfs-b1rs92hpq4izkpvi.core
error: internal error: unable to execute QEMU command 'dump-guest-memory': this
feature or command is not currently supported

It would be nice to have this on aarch64, since it's the recommended
way to collect a debugging core dump for Linux guest kernels which
have crashed.  (An alternative is to use kdump in the guest, but that
requires prior setup).

Version-Release number of selected component (if applicable):

I tested this in Rawhide:
qemu-2.4.0-2.fc24.aarch64

IIUC, the problem is that the function 'cpu_get_dump_info' is not
implemented for aarch64 (only for x86, ppc and s390x so far).

Comment 1 Andrew Jones 2016-01-21 14:51:47 UTC

*** This bug has been marked as a duplicate of bug 1299867 ***


Note You need to log in before you can comment on or make changes to this bug.