Bug 1299867 - aarch64: backport dump-guest-memory series
aarch64: backport dump-guest-memory series
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.3
aarch64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andrew Jones
Virtualization Bugs
: OtherQA
: 1269909 (view as bug list)
Depends On:
Blocks: 1173755
  Show dependency treegraph
 
Reported: 2016-01-19 07:47 EST by Andrew Jones
Modified: 2016-06-14 08:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-14 08:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2016-01-19 07:47:44 EST
Backport the following commits in order to enable 'virsh dump' support on AArch64.

f1cd483004da3 qapi-schema: dump-guest-memory: Improve text
b09afd58e4cb6 dump: qemunotes aren't commonly needed
8161befdd15dd dump: allow target to set the page size
b6e05aa473b52 dump: allow target to set the physical base
da2b91409ffe3 target-arm: support QMP dump-guest-memory
bada8e4470a4f target-arm: dump-guest-memory: add prfpreg notes for aarch64
7d68e47f1280f elf: add arm note types
ade0d0c0d3a04 target-arm: dump-guest-memory: add vfp notes for arm
Comment 1 Andrew Jones 2016-01-19 08:06:40 EST
Note to QE: testing for this bug must be done with an upstream crash utility, or a downstream crash utility that includes the commits listed in bug 1299873
Comment 2 Andrew Jones 2016-01-21 09:51:47 EST
*** Bug 1269909 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Jones 2016-04-26 09:02:27 EDT
We'll get these patches with our 2.6 rebase.
Comment 4 Andrew Jones 2016-06-14 08:49:19 EDT
(In reply to Andrew Jones from comment #3)
> We'll get these patches with our 2.6 rebase.

Got 'em. They work.

Note You need to log in before you can comment on or make changes to this bug.