Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1270095 - [abrt] yumex-dnf: status.py:130:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
Summary: [abrt] yumex-dnf: status.py:130:handle_dbus_signals:AttributeError: 'NoneType...
Keywords:
Status: CLOSED DUPLICATE of bug 1269400
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:45ef9864873904ecb6c5630c480...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-09 01:10 UTC by Dan Book
Modified: 2016-01-25 11:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-18 11:31:30 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (869 bytes, text/plain)
2015-10-09 01:10 UTC, Dan Book
no flags Details
File: environ (1.33 KB, text/plain)
2015-10-09 01:10 UTC, Dan Book
no flags Details

Description Dan Book 2015-10-09 01:10:02 UTC
Description of problem:
Started yumex-dnf, clicked status icon

Version-Release number of selected component:
yumex-dnf-4.1.3-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.2.2-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
status.py:130:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 71, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 120, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 130, in handle_dbus_signals
    self.app.win.on_status_icon_clicked()
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
args: (2615,)
self: <yumex.status.StatusIcon object at 0x7f1d8471c4a8>
proxy: <DBusProxy object at 0x7f1d8471d288 (GDBusProxy at 0x55c8a17c5890)>
signal: 'IconClickSignal'
run_pid: 2615
sender: ':1.68'

Potential duplicate: bug 1229957

Comment 1 Dan Book 2015-10-09 01:10:05 UTC
Created attachment 1081149 [details]
File: backtrace

Comment 2 Dan Book 2015-10-09 01:10:06 UTC
Created attachment 1081150 [details]
File: environ

Comment 3 Tim Lauridsen 2015-11-18 11:31:30 UTC

*** This bug has been marked as a duplicate of bug 1269400 ***


Note You need to log in before you can comment on or make changes to this bug.