Bug 1269400 - [abrt] yumex-dnf: status.py:137:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
[abrt] yumex-dnf: status.py:137:handle_dbus_signals:AttributeError: 'NoneType...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c807b2b199b7af0280480059caa...
:
: 1270095 1270609 1271236 1277714 1312851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 04:31 EDT by Erwan GEORGET
Modified: 2016-03-22 08:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: yumex-dnf-4.1.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 15:23:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (870 bytes, text/plain)
2015-10-07 04:31 EDT, Erwan GEORGET
no flags Details
File: environ (1.51 KB, text/plain)
2015-10-07 04:31 EDT, Erwan GEORGET
no flags Details

  None (edit)
Description Erwan GEORGET 2015-10-07 04:31:15 EDT
Version-Release number of selected component:
yumex-dnf-4.1.4-1.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.2.2-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
status.py:137:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 73, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 127, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 137, in handle_dbus_signals
    self.app.win.on_status_icon_clicked()
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
signal: 'IconClickSignal'
run_pid: 5204
args: (5204,)
sender: ':1.182'
proxy: <DBusProxy object at 0x7f848817e870 (GDBusProxy at 0x55e3859f93e0)>
self: <yumex.status.StatusIcon object at 0x7f848817fa90>
Comment 1 Erwan GEORGET 2015-10-07 04:31:22 EDT
Created attachment 1080545 [details]
File: backtrace
Comment 2 Erwan GEORGET 2015-10-07 04:31:26 EDT
Created attachment 1080546 [details]
File: environ
Comment 3 Tim Lauridsen 2015-11-18 06:29:35 EST
added some extra checks upstream to avoid this traceback
https://github.com/timlau/yumex-dnf/commit/ec497cd53cd7d137fc21543d5af8eb26f2a1b34a
Comment 4 Tim Lauridsen 2015-11-18 06:31:30 EST
*** Bug 1270095 has been marked as a duplicate of this bug. ***
Comment 5 Tim Lauridsen 2015-11-18 06:32:06 EST
*** Bug 1270609 has been marked as a duplicate of this bug. ***
Comment 6 Tim Lauridsen 2015-11-18 06:32:54 EST
*** Bug 1271236 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2015-11-18 11:47:41 EST
dnfdaemon-0.3.11-1.fc23 yumex-dnf-4.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 8 Fedora Update System 2015-11-19 10:26:20 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 9 Fedora Update System 2015-11-19 11:54:58 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 10 Fedora Update System 2015-11-20 03:04:09 EST
dnfdaemon-0.3.11-1.fc22 yumex-dnf-4.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3
Comment 11 Tim Lauridsen 2015-11-20 03:21:23 EST
*** Bug 1277714 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2015-11-21 12:52:49 EST
dnfdaemon-0.3.11-1.fc22, yumex-dnf-4.1.5-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3
Comment 13 Fedora Update System 2015-11-28 15:23:00 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-03-17 17:21:41 EDT
dnfdaemon-0.3.11-1.fc22, yumex-dnf-4.1.5-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Rafal Luzynski 2016-03-22 08:59:24 EDT
*** Bug 1312851 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.