Bug 1270139 - [F22] engine-setup doesn't configure version locking for the new dnf packager provided by OTOPI
[F22] engine-setup doesn't configure version locking for the new dnf packager...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.0-rc2
: 3.6.0
Assigned To: Sandro Bonazzola
Petr Kubica
integration
:
Depends On: 1213594 1271623
Blocks: 1162508
  Show dependency treegraph
 
Reported: 2015-10-09 01:36 EDT by Sandro Bonazzola
Modified: 2015-11-27 02:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:54:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
bmcclain: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47146 master MERGED packaging: setup: support dnf version locking Never
oVirt gerrit 47218 ovirt-engine-3.6 MERGED packaging: setup: support dnf version locking Never
oVirt gerrit 47220 ovirt-engine-3.6.0 MERGED packaging: setup: support dnf version locking Never
oVirt gerrit 47318 master MERGED packaging: spec: fix dnf dependency Never
oVirt gerrit 47320 ovirt-engine-3.6 MERGED packaging: spec: fix dnf dependency Never
oVirt gerrit 47321 ovirt-engine-3.6.0 MERGED packaging: spec: fix dnf dependency Never

  None (edit)
Description Sandro Bonazzola 2015-10-09 01:36:43 EDT
Description of problem:
recent otopi 1.4.0 introduced dnf packager support.
In this condition, version lock plugin which is configured for yum is not working in dnf since dnf plugin uses different configuration files.

See http://dnf-plugins-extras.readthedocs.org/en/latest/versionlock.html
for reference.

Version-Release number of selected component (if applicable):
otopi-1.4.0-0.0.master.20151001075130.git850663a.fc22.noarch


How reproducible:
100%

Steps to Reproduce:
1. install ovirt-engine on F22 with dnf and recent otopi
2. yum update to a newer build
3. all the package are upgraded

Actual results:


Expected results:


Additional info:
Comment 1 Alon Bar-Lev 2015-10-14 07:21:24 EDT
follow spec, not sure I understand why the following remains not for rhel only (or older fedora):

Requires:       yum-plugin-versionlock

%package setup-plugin-ovirt-engine-common
Requires:       yum

also unsure why there is no dnf alternative for:

%postun
if [ "$1" -eq 0 ]; then
        rm -rf "%{engine_cache}"
        rm -rf "%{engine_pki}"

        if [ -f "%{_sysconfdir}/yum/pluginconf.d/versionlock.list" ]; then
                sed -i '/%{name}/d' "%{_sysconfdir}/yum/pluginconf.d/versionlock.list"
        fi
fi

as the dnf version is at /etc/dnf/plugins/versionlock.list
Comment 2 Petr Kubica 2015-11-26 10:41:20 EST
Verified in ovirt-engine-3.6.1-1.fc22
Comment 3 Sandro Bonazzola 2015-11-27 02:54:37 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.