Bug 1270333 - [RFE] Add internal versioning system to OSP director
[RFE] Add internal versioning system to OSP director
Status: CLOSED DUPLICATE of bug 1296946
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 12:36 EDT by jliberma@redhat.com
Modified: 2016-09-26 23:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 23:40:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2015-10-09 12:36:38 EDT
Description of problem:

Add an internal versioning system to OSP director. 



Additional info:

Reproducible OSP director configuration relies on many properly formatted text files. (JSON, YAML, Heat templates, etc.) Getting all of the files right is a time consuming and error prone process. Small changes in file syntax between releases complicates matters.

We already have many validators to ensure the files are properly formatted. We should add a facility for saving and version control on the undercloud. The same facility to integrate with an external versioning system.
Comment 2 Emilien Macchi 2015-12-01 16:16:43 EST
One solution would be to create a custom fact in puppet-tripleo. That way, we could use this fact from Puppet manifests in TripleO Heat templates.
Comment 3 jliberma@redhat.com 2016-01-08 09:15:39 EST
Integration with something like git would be nice so we could pull down updates from a central repository.
Comment 6 Mike Burns 2016-04-07 16:54:03 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Jaromir Coufal 2016-09-26 23:40:31 EDT

*** This bug has been marked as a duplicate of bug 1296946 ***

Note You need to log in before you can comment on or make changes to this bug.