This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1296946 - [RFE] Add version/release to OSP-director similar to redhat-release
[RFE] Add version/release to OSP-director similar to redhat-release
Status: CLOSED DUPLICATE of bug 1317669
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
low Severity unspecified
: ga
: 11.0 (Ocata)
Assigned To: Angus Thomas
Shai Revivo
: FutureFeature, Triaged
: 1270333 1295512 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 09:16 EST by jliberma@redhat.com
Modified: 2017-01-04 11:48 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-04 11:48:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2016-01-08 09:16:51 EST
Description of problem:

There are various problems introduced by changes between OSP director versions: template mismatches, upgrading/updating between versions, etc.

Please add a file or command that shows the current version of OSP director similar to redhat-release

Additional info:

Related BZs:
1) https://bugzilla.redhat.com/show_bug.cgi?id=1295512 Documentation: Need to specify how to check version number [DOC]
2) https://bugzilla.redhat.com/show_bug.cgi?id=1270333 Add internal versioning system to OSP director
Comment 6 Jaromir Coufal 2016-09-26 23:40:31 EDT
*** Bug 1270333 has been marked as a duplicate of this bug. ***
Comment 7 Jaromir Coufal 2016-09-26 23:40:38 EDT
*** Bug 1295512 has been marked as a duplicate of this bug. ***
Comment 9 Mike Burns 2017-01-04 11:48:03 EST
rhosp-release is installed by default by director in the overcloud on upgrade from OSP 9 to 10.  It's also in all images starting with OSP 10.

*** This bug has been marked as a duplicate of bug 1317669 ***

Note You need to log in before you can comment on or make changes to this bug.