Bug 1270346 - XSD Additional review
XSD Additional review
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Antti Andreimann
Fedora Extras Quality Assurance
https://fedorahosted.org/fesco/ticket...
:
Depends On: 1270978
Blocks: 1098622
  Show dependency treegraph
 
Reported: 2015-10-09 13:45 EDT by Antonio Trande
Modified: 2015-11-23 15:57 EST (History)
3 users (show)

See Also:
Fixed In Version: xsd-4.0.0-10.fc23 xsd-4.0.0-10.fc21 xsd-4.0.0-10.fc22 xsd-4.0.0-10.el7 xsd-4.0.0-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 19:22:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio Trande 2015-10-09 13:45:57 EDT
Description of problem:

This is the SPEC file that i have updated for xsd:
https://sagitter.fedorapeople.org/xsd/xsd.spec

Changes:

- Used %%license tag
- libcutl libraries unbundled
- Header files packaged apart
- Made tests

Unfortunately, it does not build in EPEL5 because of missing xerces-c libraries.

Tests passed on Fedora, but in EPEL6 there is an incomprensive (for me) error: http://fpaste.org/276911/


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package does not use a name that already exists.
  Note: A package with this name already exists. Please check
  https://admin.fedoraproject.org/pkgdb/acls/name/xsd
  See:
  https://fedoraproject.org/wiki/Packaging/NamingGuidelines#Conflicting_Package_Names


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated". 461 files have unknown license.
     Detailed output of licensecheck in
     /home/sagitter/rpmbuild/SRPMS/xsd/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[-]: If the package is under multiple licenses, the licensing breakdown
     must be documented in the spec.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 122880 bytes in 6 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[!]: Uses parallel make %{?_smp_mflags} macro.
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in xsd-doc
     , xsd-devel
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.


Rpmlint
-------
Checking: xsd-4.0.0-7.fc24.i686.rpm
          xsd-doc-4.0.0-7.fc24.noarch.rpm
          xsd-devel-4.0.0-7.fc24.noarch.rpm
          xsd-4.0.0-7.fc24.src.rpm
4 packages and 0 specfiles checked; 0 errors, 0 warnings.




Rpmlint (debuginfo)
-------------------
Checking: xsd-debuginfo-4.0.0-7.fc24.i686.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
4 packages and 0 specfiles checked; 0 errors, 0 warnings.



Requires
--------
xsd-devel (rpmlib, GLIBC filtered):
    xerces-c-devel

xsd (rpmlib, GLIBC filtered):
    libc.so.6
    libcutl-1.9.so
    libgcc_s.so.1
    libgcc_s.so.1(GCC_3.0)
    libm.so.6
    libstdc++.so.6
    libstdc++.so.6(CXXABI_1.3)
    libxerces-c-3.1.so
    rtld(GNU_HASH)

xsd-doc (rpmlib, GLIBC filtered):



Provides
--------
xsd-devel:
    xsd-devel

xsd:
    xsd
    xsd(x86-32)

xsd-doc:
    xsd-doc



Source checksums
----------------
http://www.codesynthesis.com/download/xsd/4.0/xsd-4.0.0+dep.tar.bz2 :
  CHECKSUM(SHA256) this package     : eca52a9c8f52cdbe2ae4e364e4a909503493a0d51ea388fc6c9734565a859817
  CHECKSUM(SHA256) upstream package : eca52a9c8f52cdbe2ae4e364e4a909503493a0d51ea388fc6c9734565a859817


Generated by fedora-review 0.6.0 (3c5c9d7) last change: 2015-05-20
Command line :/usr/bin/fedora-review -m fedora-rawhide-i386 -rn xsd-4.0.0-7.fc22.src.rpm
Buildroot used: fedora-rawhide-i386
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6
Comment 1 Antonio Trande 2015-10-09 13:55:32 EDT
Errata corrige:

>Tests passed on Fedora, but in EPEL6 there is an incomprensive (for me) error: >http://fpaste.org/276911/

Tests passed on Fedora, but in EPEL6 there is an unknown (for me) error: http://fpaste.org/276911/
Comment 2 Antonio Trande 2015-10-12 15:29:12 EDT
> Tests passed on Fedora, but in EPEL6 there is an unknown (for me) error:
> http://fpaste.org/276911/

Test failures seem due to xerces-c-3.0.1; see http://codesynthesis.com/pipermail/xsd-users/2015-October/004695.html.

I'm going to rebuild 'xsd' with this new spec: https://sagitter.fedorapeople.org/xsd/xsd.spec
Comment 3 Kalev Lember 2015-10-12 15:48:34 EDT
Why are you splitting headers out to a separate subpackage? I would say that they should stay in the main package for two reasons:

1) xsd is a compiler and as such, it doesn't make much sense to use it without headers. Similar to gcc, you don't see headers split out there either.

2) Existing packages in Fedora are relying on the xsd package to pull in the whole thing, and splitting out the headers would make them FTBFS
Comment 4 Antonio Trande 2015-10-12 15:55:48 EDT
(In reply to Kalev Lember from comment #3)
> Why are you splitting headers out to a separate subpackage? I would say that
> they should stay in the main package for two reasons:
> 
> 1) xsd is a compiler and as such, it doesn't make much sense to use it
> without headers. Similar to gcc, you don't see headers split out there
> either.
> 
> 2) Existing packages in Fedora are relying on the xsd package to pull in the
> whole thing, and splitting out the headers would make them FTBFS

Thank you very much for your correction.
I'm fixing my mistake.
Comment 5 Kalev Lember 2015-10-12 15:57:02 EDT
Thanks!
Comment 6 Fedora Update System 2015-11-06 06:22:43 EST
xsd-4.0.0-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1514f40d88
Comment 7 Fedora Update System 2015-11-06 06:22:43 EST
xsd-4.0.0-10.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7172d2b48e
Comment 8 Fedora Update System 2015-11-06 06:22:52 EST
xsd-4.0.0-10.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-d52069f036
Comment 9 Fedora Update System 2015-11-06 06:22:52 EST
xsd-4.0.0-10.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8a5a451bda
Comment 10 Fedora Update System 2015-11-06 06:23:00 EST
xsd-4.0.0-10.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0721e2ecb5
Comment 11 Fedora Update System 2015-11-08 06:22:40 EST
xsd-4.0.0-10.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xsd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0721e2ecb5
Comment 12 Fedora Update System 2015-11-08 07:27:03 EST
xsd-4.0.0-10.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xsd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-d52069f036
Comment 13 Fedora Update System 2015-11-08 08:24:51 EST
xsd-4.0.0-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xsd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1514f40d88
Comment 14 Fedora Update System 2015-11-08 13:48:05 EST
xsd-4.0.0-10.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update xsd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8a5a451bda
Comment 15 Fedora Update System 2015-11-08 13:50:02 EST
xsd-4.0.0-10.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update xsd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7172d2b48e
Comment 16 Fedora Update System 2015-11-15 19:22:23 EST
xsd-4.0.0-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-11-15 22:21:09 EST
xsd-4.0.0-10.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-11-15 22:22:12 EST
xsd-4.0.0-10.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-11-23 15:05:52 EST
xsd-4.0.0-10.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2015-11-23 15:57:22 EST
xsd-4.0.0-10.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.