Bug 127058 - immodule for qt
immodule for qt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
http://immodule-qt.freedesktop.org/
: FutureFeature, i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-07-01 02:29 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-01 05:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2004-07-01 02:29:18 EDT
Description of problem:
Currently qt3 does not have any im module feature like gtk+2 and
locked to support XIM only. Fortunately there is a group of developer
which is developing this feature outside of trolltech.

Additional info:
They are cooperating with Trolltech however because it is a feature
addon so they would not able to add it into Qt 3.3.x release due to
their bugfix-only policy for minor version releases. 

This is essential patch to plug in other input method system (such as
IIIMF)
Comment 2 Ngo Than 2004-07-01 04:33:59 EDT
Leon, i will add this patch in next rebuild. Did you already test this
patch if this works?
Comment 3 Rex Dieter 2004-08-16 11:46:30 EDT
For me, qt built with this patch seems to break the kde system tray
and taskbar (they appear blank when first logging in).  Though,
restarting these applets makes items appear again.

I've tried rebuilding kdelibs/kdebase against the new qt in case bc
was a problem, but I saw no change in behavior.

Only by rebuilding qt without the immodules patch made the kde system
tray and taskbar properly functional again.
Comment 4 Leon Ho 2004-08-16 20:52:38 EDT
I have tested in rawhide installation and seems the taskbar and
systray are okay (I can see RHN applet, and i can see running tasks).

Any specific environment are you running in? Is it a refresh installation?

It would be great if you can create a new bug regarding this problem
(pls cc: me). Thanks.
Comment 5 Rex Dieter 2004-08-17 12:27:50 EDT
I'll keep investigating, and open a new report, thanks.
Comment 6 Rex Dieter 2004-09-10 15:32:57 EDT
FYI, see bug #132304 for details about the problem I was having with
immodule.  The "Application Launcher" kicker/panel applet appears to
be to blame.

Note You need to log in before you can comment on or make changes to this bug.