Bug 132304 - immodule -> taskbar, system tray blank (application launcher applet)
immodule -> taskbar, system tray blank (application launcher applet)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 15:16 EDT by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-06 15:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X patch (497 bytes, patch)
2004-09-13 09:18 EDT, Rex Dieter
no flags Details | Diff
qt patch (695 bytes, patch)
2004-09-13 09:18 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2004-09-10 15:16:14 EDT
I've tried rebuilding qt with the included immodule patch (bug
#127058) on fc1,fc2 and rhel3, and For me, qt built with this patch
seems to break the kde(3.3.0) system tray and taskbar.  The symptom is
that they both initially appear blank when first logging in (though
the root user seems unaffected).  Restarting these applets makes items
appear again.

I've tried rebuilding kdelibs/kdebase against the new qt in case bc
was a problem, but I saw no change in behavior.

Only by rebuilding qt without the immodules patch made the kde system
tray and taskbar properly functional again.
Comment 1 Rex Dieter 2004-09-10 15:18:24 EDT
Looks like an interaction with kdebase's "Application Launcher" kicker
applet.  When I remove this applet from my kicker/panel, the problem
goes away.  

Wierd part, once I remove it, I can't add it back to stay.  The applet
will stay in the panel for the current session, but upon 
logout/login, it's gone (and I have to add/run it manually again).
Comment 2 Rex Dieter 2004-09-13 09:17:10 EDT
Appears related to kde bug
http://bugs.kde.org/show_bug.cgi?id=12620

I'll attach (X and qt) patches posted to kde-packagers
Comment 3 Rex Dieter 2004-09-13 09:18:07 EDT
Created attachment 103783 [details]
X patch
Comment 4 Rex Dieter 2004-09-13 09:18:37 EDT
Created attachment 103784 [details]
qt patch
Comment 5 Rex Dieter 2004-09-13 09:19:55 EDT
Commentatary posted to kde-packagers regarding patches:
----------------------------
Hello,

to all packagers who also provide Qt packages and use the immodule
patch: Due to a bug in Xlib, the patch causes bug #12620 and its
various duplicates (taskbar, pager, window list etc. stop working
after a short time). Please apply the attached Xlib patch to your X
packages if you can, or apply the attached Qt patch which works around
the problem.

-- Lubos Lunak KDE Developer 
Comment 6 Ngo Than 2004-09-13 11:58:38 EDT
Dieter, i already seen the patches fron Lubos Lunak sending to
kde-packger by weekend ;-) i will add qt patch in next qt rebuild.
Many thanks for your infos.
Comment 7 Rex Dieter 2004-09-13 12:00:53 EDT
Do you know if the X patch will be included in the xorg packages too?
Comment 8 Ngo Than 2004-09-13 12:07:47 EDT
i reassign it to xorg-x11
Comment 9 Kristian Høgsberg 2004-09-16 15:53:20 EDT
Egbert applied the Xlib patch to xorg-x11 HEAD, we should make sure
it's either in a 6.8.* release and ship that or patch it in the RPM.
Comment 10 Kristian Høgsberg 2004-12-12 12:36:49 EST
The patch will be in the 6.8.2 release which we will ship as an FC3
update when it comes out.
Comment 11 Rex Dieter 2005-08-06 15:28:52 EDT
xorg-6.8.2 errata released, thanks.

Note You need to log in before you can comment on or make changes to this bug.