Bug 1270609 - [abrt] yumex-dnf: status.py:137:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
[abrt] yumex-dnf: status.py:137:handle_dbus_signals:AttributeError: 'NoneType...
Status: CLOSED DUPLICATE of bug 1269400
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c807b2b199b7af0280480059caa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 16:22 EDT by Christian Stadelmann
Modified: 2015-12-04 22:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 06:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (867 bytes, text/plain)
2015-10-11 16:22 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-10-11 16:22:42 EDT
Description of problem:
I double-clicked on the status icon.

Version-Release number of selected component:
yumex-dnf-4.1.4-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
status.py:137:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 73, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 127, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 137, in handle_dbus_signals
    self.app.win.on_status_icon_clicked()
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
signal: 'IconClickSignal'
self: <yumex.status.StatusIcon object at 0x7f7158014f28>
proxy: <DBusProxy object at 0x7f7158013a20 (GDBusProxy at 0x130b1c0)>
run_pid: 24088
args: (24088,)
sender: ':1.138'

Potential duplicate: bug 1269400
Comment 1 Christian Stadelmann 2015-10-11 16:22:45 EDT
Created attachment 1081806 [details]
File: backtrace
Comment 2 Tim Lauridsen 2015-11-18 06:32:06 EST

*** This bug has been marked as a duplicate of bug 1269400 ***

Note You need to log in before you can comment on or make changes to this bug.