Bug 1270611 - Cannot import VM. Selected display type is not supported by the operating system
Cannot import VM. Selected display type is not supported by the operating system
Status: CLOSED DUPLICATE of bug 1253263
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0.1
All Linux
unspecified Severity medium (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Michal Skrivanek
Ilanit Stein
virt
:
Depends On:
Blocks: RHEV3.6PPC
  Show dependency treegraph
 
Reported: 2015-10-11 16:51 EDT by Christopher Pereira
Modified: 2016-03-14 05:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 04:01:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Christopher Pereira 2015-10-11 16:51:30 EDT
When importing VMs from a StorageDomain you may get a "Cannot import VM. Selected display type is not supported by the operating system" error.

Workarround is to:
- Detach Storage Domain
- Find OVF files on Storage Domain: find|grep meta|xargs -i_ grep OVF _ -l
- Edit this OVF volume files and change their <DefaultDisplayType> to 1 (or a supported value)
- Reattach Storage Domain so OVF_STORE files are re-read.

Maybe this patch fixes this problem (not sure, I'm on 3.6-rc1):
https://gerrit.ovirt.org/#/c/46850/

Please add Marek Libra <mlibra@redhat.com>
Comment 1 Allon Mureinik 2015-10-12 06:24:33 EDT
Thanks for reporting this issue!

Moving to virt - display types are their domain.
Comment 2 Michal Skrivanek 2015-10-16 04:01:36 EDT
> Maybe this patch fixes this problem (not sure, I'm on 3.6-rc1):
> https://gerrit.ovirt.org/#/c/46850/

Yes, that's the same thing

*** This bug has been marked as a duplicate of bug 1253263 ***

Note You need to log in before you can comment on or make changes to this bug.