Bug 1270658 - [DOCS] [7.2] [Feature] Document an Atomic CLI Reference
[DOCS] [7.2] [Feature] Document an Atomic CLI Reference
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-RHEL-Atomic (Show other bugs)
7.1
Unspecified Unspecified
high Severity high
: rc
: 7.2
Assigned To: Yoana Ruseva
Vikram Goyal
Vikram Goyal
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 01:05 EDT by Vikram Goyal
Modified: 2015-11-19 09:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 09:10:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-10-12 01:05:48 EDT
As a customer I want documentation providing a reference to the complete AH CLI features and commands. At the moment, there is no one guide that provides all the commands and features for the CLI that can be used.

This will be a brand new guide.

Suggested name:

RHEL Atomic Host CLI Reference

Suggested contact:

Dan Walsh (for features)

This is targeted to be released with 7.2.
Comment 2 Yoana Ruseva 2015-10-30 08:20:58 EDT
Hello Daniel, is this a good text to start with? 

https://github.com/projectatomic/atomic

What are the most important features for 7.2?
Comment 3 Daniel Walsh 2015-10-30 11:16:31 EDT
Yes.

Atomic mount and atomic scan are the most important features for 7.2
Comment 4 Daniel Walsh 2015-10-30 11:17:04 EDT
Brent do you have any write up on these features?
Comment 12 Yoana Ruseva 2015-11-10 11:48:00 EST
Hi, here is a draft of the document:

https://gitlab.cee.redhat.com/rhel-atomic-host-documentation/atomic-host-content/blob/atomic-CLI/atomic_cli/atomic_cli.adoc

Since it's a reference document, I used the man pages extensively, but tried to add some more info wherever possible. For the finer details and options, I still referred to the man pages though. Any ideas of how to make it more useful are welcome. (I found the man pages pretty useful themselves)

1) where can people find the atomic manual pages? rpm-ostree is available with the rhel-tools container, but atomic isn't

2) can I have examples for atomic mount? what is the use case for it? Current text is same as the manual page

3) if the install label is not there, what does atomic install do?

P.S. Just found this blog post - http://rhelblog.redhat.com/2015/09/23/recent-updates-to-the-atomic-cli/ so I will expand the explanation of install with the expamples there.

Any sort of feedback is welcome.
Comment 14 Brent Baude 2015-11-10 14:25:14 EST
1) I have filed https://bugzilla.redhat.com/show_bug.cgi?id=1280031 to have atomic included into the rhel-tools image.

2) I believe the atomic mount was developed to allow users to inspect the contents of an image or container's filesystem.  This could be handy to check anything from configuration files to accessing the rpmdb "inside" the docker object.

3) As of today, it dropped me into a sh prompt within the image/container namespace.  I think this is a bug but will need Dan Walsh to confirm.  IMHO, if no LABEL=INSTALL is present, then atomic install should fail gracefully with a message like "No run label found; no action taken"

@dwalsh, I wasn't helping with atomic code when install was implemented so your perspective here is key. If you prefer the alternative from above, I think that is a quick fix I can do and turn around quickly.
Comment 18 Yoana Ruseva 2015-11-12 15:53:23 EST
Brent, thanks for the feedback. I have edited atomic install and run and other minor things.

I like the example for /etc/rsyslog.conf but I saw it in the RUN label. Are there any similar examples handy?

about fetch-cve=True in /etc/oscapd.conf, does it take precedence over the command line?

https://access.qa.redhat.com/documentation/en/red-hat-enterprise-linux-atomic-host/version-7/cli-reference/
Comment 20 Yoana Ruseva 2015-11-17 06:59:33 EST
New version available here:

https://access.qa.redhat.com/documentation/en/red-hat-enterprise-linux-atomic-host/version-7/cli-reference/

Explained "atomic install" in more details.

In the meantime, "atomic migrate" was included

https://github.com/projectatomic/atomic/blob/master/docs/atomic-migrate.1.md

Brent, is the current text OK to be published as it is?

Vikram, given that Atomic CLI is changing realtime, shall we keep this BZ open and publish asynchronously?
Comment 23 Yoana Ruseva 2015-11-19 09:10:52 EST
The Reference Guide has been published:

https://access.redhat.com/documentation/en/red-hat-enterprise-linux-atomic-host/7/cli-reference/cli-reference

Closing the Bug.

Note You need to log in before you can comment on or make changes to this bug.