Bug 1270663 - Failure to install: systemd-219-13.fc22.x86_64 was supposed to be installed but is not!
Failure to install: systemd-219-13.fc22.x86_64 was supposed to be installed b...
Status: CLOSED DUPLICATE of bug 1268883
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 01:31 EDT by Stef Walter
Modified: 2015-10-23 06:53 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 06:53:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DNF command output (78.17 KB, text/plain)
2015-10-12 01:33 EDT, Stef Walter
no flags Details
dnf.log (71.58 KB, text/plain)
2015-10-12 01:47 EDT, Stef Walter
no flags Details
dnf.rpm.log (34.26 KB, text/plain)
2015-10-12 01:47 EDT, Stef Walter
no flags Details
dnf.librepo.log (208.54 KB, text/plain)
2015-10-12 01:47 EDT, Stef Walter
no flags Details
hawkey.log (1.12 KB, text/plain)
2015-10-12 01:48 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2015-10-12 01:31:03 EDT
Description of problem:

This command fails in Fedora 23:

sudo dnf -y --releasever=22 --nogpg --installroot=/data/src/blah --disablerepo='*' --enablerepo=fedora install systemd passwd dnf fedora-release vim-minimal

This sort of command is used heavily by mock. It is also documented on the systemd-nspawn page.

Version-Release number of selected component (if applicable):

dnf-1.1.2-4.fc23.noarch
rpm-4.13.0-0.rc1.3.fc23.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Run above command

Actual results:

RPMs fail to install, warnings are printed, including:

systemd-219-13.fc22.x86_64 was supposed to be installed but is not!

error: %prein(systemd-219-13.fc22.x86_64) scriptlet failed, exit status 126
Error in PREIN scriptlet in rpm package systemd
Error in PREIN scriptlet in rpm package systemd
error: systemd-219-13.fc22.x86_64: install failed

Expected results:

No failures
Comment 1 Stef Walter 2015-10-12 01:33 EDT
Created attachment 1081864 [details]
DNF command output

DNF command output, including:

...
warning: %posttrans(fedora-release-22-1.noarch) scriptlet failed, exit status 126
Non-fatal POSTTRANS scriptlet failure in rpm package fedora-release
Non-fatal POSTTRANS scriptlet failure in rpm package fedora-release
warning: %posttrans(filesystem-3.2-32.fc22.x86_64) scriptlet failed, exit status 126
Non-fatal POSTTRANS scriptlet failure in rpm package filesystem
Non-fatal POSTTRANS scriptlet failure in rpm package filesystem
warning: %posttrans(shared-mime-info-1.4-2.fc22.x86_64) scriptlet failed, exit status 126
Non-fatal POSTTRANS scriptlet failure in rpm package shared-mime-info
Non-fatal POSTTRANS scriptlet failure in rpm package shared-mime-info
warning: %posttrans(nss-3.18.0-1.fc22.x86_64) scriptlet failed, exit status 126
Non-fatal POSTTRANS scriptlet failure in rpm package nss
Non-fatal POSTTRANS scriptlet failure in rpm package nss
warning: %posttrans(rpm-4.12.0.1-9.fc22.x86_64) scriptlet failed, exit status 126
Non-fatal POSTTRANS scriptlet failure in rpm package rpm
Non-fatal POSTTRANS scriptlet failure in rpm package rpm
...
coreutils-8.23-9.fc22.x86_64 was supposed to be installed but is not!
...
ca-certificates-2015.2.4-1.0.fc22.noarch was supposed to be installed but is not!
...
pinentry-0.9.1-1.fc22.x86_64 was supposed to be installed but is not!
...
systemd-219-13.fc22.x86_64 was supposed to be installed but is not!
...
dbus-1:1.8.16-1.fc22.x86_64 was supposed to be installed but is not!
...
libutempter-1.1.6-6.fc22.x86_64 was supposed to be installed but is not!

Failed:
  ca-certificates.noarch 2015.2.4-1.0.fc22    coreutils.x86_64 8.23-9.fc22      
  dbus.x86_64 1:1.8.16-1.fc22                 libutempter.x86_64 1.1.6-6.fc22   
  pinentry.x86_64 0.9.1-1.fc22                systemd.x86_64 219-13.fc22
Comment 2 Stef Walter 2015-10-12 01:35:13 EDT
Tried with selinux both enforcing and permissive.
Comment 3 Stef Walter 2015-10-12 01:47 EDT
Created attachment 1081866 [details]
dnf.log
Comment 4 Stef Walter 2015-10-12 01:47 EDT
Created attachment 1081867 [details]
dnf.rpm.log
Comment 5 Stef Walter 2015-10-12 01:47 EDT
Created attachment 1081868 [details]
dnf.librepo.log
Comment 6 Stef Walter 2015-10-12 01:48 EDT
Created attachment 1081869 [details]
hawkey.log
Comment 7 Stef Walter 2015-10-13 08:32:49 EDT
This blocks Cockpit development on Fedora 23
Comment 8 Fedora Blocker Bugs Application 2015-10-13 08:40:53 EDT
Proposed as a Freeze Exception for 23-final by Fedora user stefw using the blocker tracking app because:

 This bug prevents development using mock. It prevents teams like the Cockpit team from finishing up delivery of software for Fedora 23.
Comment 9 Honza Silhan 2015-10-13 11:17:09 EDT
as DNF reported, the installation of these packages failed:
  ca-certificates.noarch 2015.2.4-1.0.fc22    coreutils.x86_64 8.23-9.fc22      
  dbus.x86_64 1:1.8.16-1.fc22                 libutempter.x86_64 1.1.6-6.fc22   
  pinentry.x86_64 0.9.1-1.fc22                systemd.x86_64 219-13.fc22

Looking at dnf.rpm.log: The scriplets of most of the packages were not executed and thats probably the cause of the problem. Reassigning...

Possible dup of bug 1262953
Comment 10 Ľuboš Kardoš 2015-10-13 14:33:14 EDT
It seems to be already fixed in rpm-4.13.0-0.rc1.4.fc23 because I am able to reproduce this with rpm-4.13.0-0.rc1.3.fc23 but not with rpm-4.13.0-0.rc1.4.fc23.

Can you confirm that it is fixed?
Comment 11 Adam Williamson 2015-10-15 17:36:53 EDT
Discussed at 2015-10-15 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-15/f23-blocker-review.2015-10-15-20.11.log.txt . There doesn't seem to be a clear explanation of why this needs a freeze exception: i.e., why does the fix need to be in the frozen release tree and images - wouldn't just having it in the updates repository be sufficient?

If there's a reason this can benefit from a freeze exception, please explain. Thanks!
Comment 12 Stef Walter 2015-10-16 03:31:31 EDT
Somehow my response was not recorded by bugzilla. It appears that with rpm-4.13.0-0.rc1.4.fc23 does in fact fix this issue.
Comment 13 Stef Walter 2015-10-16 03:37:11 EDT
> If there's a reason this can benefit from a freeze exception, please explain. Thanks!

The reasoning: In my opinion RPM bugs should be fixed before release, because RPM will be heavily used by people upgrading to the new release. RPM should be rock solid at release time.
Comment 14 Adam Williamson 2015-10-19 16:09:37 EDT
Discussed at 2015-10-19 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . There is still no convincing rationale for breaking the freeze for this. Note that upgrades are performed with the RPM (and dnf and so on) from the *source* release, not the target: when you upgrade from F22 to F23, F22's rpm is used, not F23's.
Comment 15 Florian Festi 2015-10-23 06:53:30 EDT
As there is a bug already ON_QA: Closing as duplicate

*** This bug has been marked as a duplicate of bug 1268883 ***

Note You need to log in before you can comment on or make changes to this bug.