Bug 1270676 - koan incorrectly parses s390x kernel command-line parameters whose value contains "=" sign
koan incorrectly parses s390x kernel command-line parameters whose value cont...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Lukáš Hellebrandt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 02:21 EDT by Jan Hutař
Modified: 2015-12-10 08:22 EST (History)
3 users (show)

See Also:
Fixed In Version: cobbler-2.0.7-65
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 08:22:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-10-12 02:21:24 EDT
Description of problem:
koan incorrectly parses s390x kernel command-line parameters whose value contains "equals" sign and creates invalid entry in /etc/zipl.conf.


Version-Release number of selected component (if applicable):
koan-2.0.7-54.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Create KS profile with "Kernel Options" containing something like:
   rd.znet=qeth,0.0.8000,0.0.8001,0.0.8002,layer2=1,portname=...,portno=0
2. Attempt to reprovision a system and before system goes down, check
   content of /etc/zipl.conf


Actual results:
On "parameters" line, item "rd.znet" is truncated to "qeth,0.0.8000,0.0.8001,0.0.8002,layer2" (notice that it is truncated on first "=" sign appearance)


Expected results:
Should not be truncated because that option seems to be required for RHEL7 provisioning.


Additional info:
This was found by jdobes when working on bug 1199214
Comment 5 Lukáš Hellebrandt 2015-11-10 07:00:38 EST
Verified with koan-2.0.7-65 on s390x client with RHEL7.

Only works for sat5.7; in sat5.6, it is impossible to even fill the fields with some s390x parameters which is a separate bug.

1) Install koan-2.0.7-65 on the client
2) Register the system to a satellite
3) Assign a system a provisioning entitlement
4) Create a s390x kickstart (in my case RHEL7.1)
5) Set kernel options field to the correct parameters, including some with a "=" symbol in value.
6) Schedule a kickstart to the client
7) On client, run "rhn_check -vv && shutdown -c && vim /etc/zipl.conf" and confirm the parameters (particularly the one with "=") were parsed correctly (no part of the value is missing)
8) Reboot the client and verify it kickstarted properly
Comment 8 errata-xmlrpc 2015-12-10 08:22:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2614.html

Note You need to log in before you can comment on or make changes to this bug.