Bug 1270775 - Traceback "TypeError: _execute_child_v276() got an unexpected keyword argument 'restore_sigpipe'"
Traceback "TypeError: _execute_child_v276() got an unexpected keyword argumen...
Status: CLOSED DUPLICATE of bug 1267843
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Sahina Bose
RHS-C QE
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 07:24 EDT by zguo
Modified: 2015-12-24 05:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 05:51:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zguo 2015-10-12 07:24:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):

RHEL-7.2-20151008.0 Server x86_64
[root@hp-ms-01-c12 ~]# cat /etc/system-release
Red Hat Enterprise Linux Server release 7.2 Beta (Maipo)
[root@hp-ms-01-c12 ~]# uname -r
3.10.0-322.el7.x86_64

[root@hp-ms-01-c12 ~]# rpm -qa |grep gluster
glusterfs-fuse-3.7.1-16.el7rhgs.x86_64
glusterfs-client-xlators-3.7.1-16.el7rhgs.x86_64
gluster-nagios-common-0.2.2-1.el7rhgs.noarch
gluster-nagios-addons-0.2.5-1.el7rhgs.x86_64
glusterfs-api-3.7.1-16.el7rhgs.x86_64
glusterfs-cli-3.7.1-16.el7rhgs.x86_64
glusterfs-rdma-3.7.1-16.el7rhgs.x86_64
glusterfs-server-3.7.1-16.el7rhgs.x86_64
glusterfs-libs-3.7.1-16.el7rhgs.x86_64
glusterfs-3.7.1-16.el7rhgs.x86_64
glusterfs-geo-replication-3.7.1-16.el7rhgs.x86_64
python-gluster-3.7.1-16.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Provision the server 
2. yum install redhat-storage-server
3.

Actual results:
Installing : vdsm-4.16.20-1.3.el7rhgs.x86_64                                                        279/283
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 219, in main
    return tool_command[cmd]["command"](*args)
  File "/usr/lib/python2.7/site-packages/vdsm/tool/__init__.py", line 37, in wrapper
    func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/vdsm/tool/configurator.py", line 74, in configure
    if service.service_status(s, False) == 0:
  File "/usr/lib/python2.7/site-packages/vdsm/tool/service.py", line 417, in service_status
    return _runAlts(_srvStatusAlts, srvName)
  File "/usr/lib/python2.7/site-packages/vdsm/tool/service.py", line 350, in _runAlts
    rc, out, err = alt(srv, *args, **kwarg)
  File "/usr/lib/python2.7/site-packages/vdsm/tool/service.py", line 110, in wrapper
    rc, out, err = execCmd(cmd, raw=False)
  File "/usr/lib/python2.7/site-packages/vdsm/tool/service.py", line 36, in execCmd
    return _execCmd(argv, raw=raw, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/vdsm/utils.py", line 742, in execCmd
    deathSignal=deathSignal, childUmask=childUmask)
  File "/usr/lib64/python2.7/site-packages/cpopen/__init__.py", line 51, in __init__
    stderr=PIPE)
  File "/usr/lib64/python2.7/subprocess.py", line 712, in __init__
    restore_sigpipe=restore_sigpipe)
TypeError: _execute_child_v276() got an unexpected keyword argument 'restore_sigpipe'
  Installing : vdsm-gluster-4.16.20-1.3.el7rhgs.noarch                                                280/283

Expected results:

No this traceback error


Additional info:
Comment 3 Sahina Bose 2015-12-24 05:51:15 EST
This was due to the rebased python version in 7.2 which has been fixed in 7.2 GA.

Closing this duplicate of an existing bug on this issue

*** This bug has been marked as a duplicate of bug 1267843 ***

Note You need to log in before you can comment on or make changes to this bug.