Bug 1270855 - scoped_search - err 500 on searching on invalid field
Summary: scoped_search - err 500 on searching on invalid field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: All
unspecified
medium vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-12 14:11 UTC by Roman Plevka
Modified: 2019-09-26 16:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:57:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12140 None None None 2016-03-29 19:44:55 UTC
Foreman Issue Tracker 13952 None None None 2016-03-29 19:44:12 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Roman Plevka 2015-10-12 14:11:17 UTC
Description of problem:
Applies to all katello entities:
on sending a query which uses a non-existing field, server returns error 500, but the GUI does not handle this error.
This results in 'dead' search form.

Request url:
https://<fqdn>/katello/api/v2/content_views?nondefault=true&organization_id=3&page=1&search=foo+%3D+bar&sort_by=name&sort_order=ASC

Response:
displayMessage:"Field 'foo' not recognized for searching!"
errors:Array:
 0:"Field 'foo' not recognized for searching!"

Version-Release number of selected component (if applicable):
katello-2.4.0-6.nightly.el7.noarch
tfm-rubygem-scoped_search-3.2.2-2.el7.noarch

How reproducible:
every time on all katello entities

Steps to Reproduce:
1. go to a katello entity page (e.g. Content Views)
2. input the seaerch query with invalid field name - e.g. foo = bar
3. Hit search
4. No response on GUI (Error in the captured repsonse headers)

Actual results:
the error is not being handled by UI, renders the form unusable.

Expected results:
Notification is shown or some default behavior takes place.

Additional info:

Comment 1 Roman Plevka 2015-10-12 14:13:57 UTC
Created redmine issue http://projects.theforeman.org/issues/12140 from this bug

Comment 3 Bryan Kearney 2015-12-17 19:04:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12140 has been closed

Comment 4 John Mitsch 2016-02-22 16:15:31 UTC
Moving this back to NEW as the issue status was changed back (it is still a bug upstream) http://projects.theforeman.org/issues/12140

Comment 5 John Mitsch 2016-03-02 20:03:46 UTC
This was fixed upstream https://github.com/Katello/katello/pull/5819

Comment 6 Roman Plevka 2016-03-25 23:15:42 UTC
Ok, this is working pretty nice now, but it still generates the empty suggestion instead showing the error in the suggestion box just like Foreman does.

I'm putting this to FAILEDQA. If you think this should be reported as a standalone bug, let me know and I'll put this one to VERIFIED

Comment 8 John Mitsch 2016-03-28 12:48:15 UTC
(In reply to Roman Plevka from comment #6)
> Ok, this is working pretty nice now, but it still generates the empty
> suggestion instead showing the error in the suggestion box just like Foreman
> does.
> 
> I'm putting this to FAILEDQA. If you think this should be reported as a
> standalone bug, let me know and I'll put this one to VERIFIED

+1 to a standalone bug for the empty suggestion box, I actually have opened up an upstream bug here for this issue and can clone it to BZ. http://projects.theforeman.org/issues/13118

Comment 10 Roman Plevka 2016-04-11 08:13:43 UTC
VERIFIED

putting this bug to verified as the other issue now has its own BZ #1322088

Comment 12 errata-xmlrpc 2016-07-27 08:57:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.