This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1271006 - Unable to import errata for Fedora 22 Updates
Unable to import errata for Fedora 22 Updates
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.4
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiří Dostál
Red Hat Satellite QA List
:
: 1276523 (view as bug list)
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2015-10-12 17:39 EDT by max
Modified: 2017-09-28 14:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 04:14:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description max 2015-10-12 17:39:20 EDT
Description of problem:
On repo-sync of Fedora 22 updates channel, errata is detected but not imported. sync log in Additional info.

Version-Release number of selected component (if applicable):
Spacewalk 2.4 on Fedora 22, x86_64

How reproducible:
Can reproduce on both fresh installs and multiple synchronizations

Steps to Reproduce:
1. Add fedora 22 channels via spacewalk-utils/common-channels
2. Synchronize Fedora 22 Updates repo

Actual results:
Log indicates errata is detected but is not imported

Expected results:
Errata is detected and imported

Additional info:
Sync log as follows:
Sync started: Mon Oct 12 17:11:41 2015
['/usr/bin/spacewalk-repo-sync', '--channel', 'fedora22-x86_64-updates', '--type', 'yum']
Repo URL: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f22&arch=x86_64
Packages in repo:             15691
No new packages to sync.
Repo https://mirrors.fedoraproject.org/metalink?repo=updates-released-f22&arch=x86_64 has comps file comps.xml.
Repo https://mirrors.fedoraproject.org/metalink?repo=updates-released-f22&arch=x86_64 has 2372 errata.
ERROR: 'NoneType' object has no attribute 'isdigit'
Sync completed.
Total time: 0:07:27
Comment 1 Jiří Dostál 2015-10-29 11:37:08 EDT
Hello,

I have successfully reproduced your problem and you are right, it does not import due to missing "issue date" in one item. I'm afraid that we are not able to help you with this issue, because it's Fedora 22 Updates repo 'bug'. You will make it working once the missing item is full-filled. 

I'd suggest you writing a ticket/bug report on 'Fedora 22 Updates'. At the time they provide the update it should be possible to do import without any problems.

Regards,
Jiri
Comment 2 Jiří Dostál 2015-11-23 11:23:06 EST
I've created a ticket on Fedora infrastructure. Check status on "https://fedorahosted.org/fedora-infrastructure/ticket/4983"
Comment 3 Tomas Lestach 2016-01-11 04:04:45 EST
*** Bug 1276523 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Lestach 2016-02-16 08:22:15 EST
According to https://github.com/fedora-infra/bodhi/issues/718 the issue have been fixed in fc22 repository metadata. Would you, please, confirm, you can successfully sync fc22 repository?
Comment 5 max 2016-02-16 12:24:42 EST
Apologies for the long delay in reply; I can confirm the issue is resolved.
Comment 6 Tomas Lestach 2016-02-17 04:14:39 EST
(In reply to max from comment #5)
> I can confirm the issue is resolved.

Thank you. I'm closing the bug as CURRENTRELEASE.
Comment 7 Eric Herget 2017-09-28 14:10:19 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.