Bug 127102 - sa-exim code placed wrong in spec file
sa-exim code placed wrong in spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
: 127632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-01 17:21 EDT by Dan Egli
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 10:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec that I used to generate the corrected EXIM binary (18.24 KB, text/plain)
2004-07-01 18:05 EDT, Dan Egli
no flags Details
Makefile that works correctly for sa-exim (generated by RPM Build procedure) (3.27 KB, text/plain)
2004-07-01 18:08 EDT, Dan Egli
no flags Details

  None (edit)
Description Dan Egli 2004-07-01 17:21:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
in the RPM produced by RedHat/Fedora, you create the Makefile from
src/EDITME, and Then apply the sa-exim patch. That invalidates the
patch because it modifies src/EDITME. The result is that setting the
paramater to load the sa-exim-4.0.so file results in an unknown
paramater error from exim.

The fix is to apply the patch, THEN copy the src/EDITME. An updated
spec file as well as my src/EDITME are attached to this bug. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build the exim RPM (or just install the one from Fedora)
2. edit your /etc/exim/exim.conf file to include the line:
local_scan_path = /usr/libexec/exim/sa-exim.so
 
3. exim -bV
    

Actual Results:  Contains exiscan-acl patch revision 20 (c) Tom
Kistner [http://duncanthrax.net/exiscan/]
2004-07-01 15:20:41 Exim configuration error in line 238 of
/etc/exim/exim.conf2:
  main option "local_scan_path" unknown


Expected Results:  Contains exiscan-acl patch revision 20 (c) Tom
Kistner [http://duncanthrax.net/exiscan/]
Configuration file is /etc/exim/exim.conf




Additional info:

see the attachments
Comment 1 Dan Egli 2004-07-01 18:05:41 EDT
Created attachment 101574 [details]
Spec that I used to generate the corrected EXIM binary
Comment 2 Dan Egli 2004-07-01 18:08:03 EDT
Created attachment 101575 [details]
Makefile that works correctly for sa-exim (generated by RPM Build procedure)
Comment 3 Thomas Woerner 2004-07-02 10:23:55 EDT
Fixed in rawhide in package exim-4.34-3 or newer.
Comment 4 G Limberg 2004-07-11 16:19:45 EDT
*** Bug 127632 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.