Bug 127632 - sa-exim cannot be run with exim-4.33-2 package
sa-exim cannot be run with exim-4.33-2 package
Status: CLOSED DUPLICATE of bug 127102
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 14:33 EDT by G Limberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G Limberg 2004-07-11 14:33:13 EDT
Description of problem:

FC2 comes with the sa-exim configuration for local_scan, however
DLOPEN_LOCAL_SCAN, and LOCAL_SCAN_HAS_OPTIONS are not enabled in the
build. It seems to be a problem in the srpm distribution as well.  the
patch that is supposed to enable the local scan options modifies
src/EDITME to include the local scan options, but that file doesnt
seem to be used at any other point in the build process.
Local/Makefile and build-Linux-i386/Makefile do not contain the
options to enable local scan for sa-exim.

Version-Release number of selected component (if applicable):
exim-4.33-2

How reproducible:


Steps to Reproduce:
1. add 'local_scan_path = /usr/libexec/exim/sa-exim.so' to the
exim.conf file to enable sa-exim and you get "2004-07-11 14:32:39 Exim
configuration error in line 648 of /etc/exim/exim.conf:
  local_scan() options not supported: (LOCAL_SCAN_HAS_OPTIONS not
defined in Local/Makefile)"

2. same error happens when building the rpm from source.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 G Limberg 2004-07-11 16:19:44 EDT

*** This bug has been marked as a duplicate of 127102 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.