Bug 1271072 - [RFE] Add squashfs support to image-build
[RFE] Add squashfs support to image-build
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike McLean
Fedora Extras Quality Assurance
:
Depends On: 1282496
Blocks: 1260746
  Show dependency treegraph
 
Reported: 2015-10-13 02:31 EDT by Fabian Deutsch
Modified: 2016-06-13 20:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-13 20:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2015-10-13 02:31:46 EDT
Description of problem:
It would be very convenient if image-build could output liveimg compatible squashfs images (calling it squashfs-liveimg probably makes sense), because they could be used for installations and for stateless boots.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Fabian Deutsch 2015-10-13 02:32:07 EDT
It would just be a small wrapper around the raw image.
Comment 2 Fabian Deutsch 2015-11-11 05:51:06 EST
Patches are here:
https://github.com/fabiand/koji/compare/master...liveimg
Comment 3 Fabian Deutsch 2015-11-17 02:14:03 EST
It's probably much better to implement this functionality in lmc, then the feature can also be used locally on a dev box.
Comment 4 Fedora Admin XMLRPC Client 2016-03-10 09:45:41 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Mike McCune 2016-03-28 19:06:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Fabian Deutsch 2016-06-09 06:50:17 EDT
Does someone know if this was merged in upstream?
Comment 7 Mike McLean 2016-06-09 11:54:36 EDT
Yes, merged upstream a while ago.
https://pagure.io/koji/pull-request/53
Comment 8 Mike McLean 2016-06-13 20:14:11 EDT
Current Fedora build appears to have the changes too. Closing this.

Note You need to log in before you can comment on or make changes to this bug.