Bug 1282496 - lmc should support liveimg squashfs creation
lmc should support liveimg squashfs creation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ovirt-node-ng 1271072
  Show dependency treegraph
 
Reported: 2015-11-16 10:30 EST by Fabian Deutsch
Modified: 2015-12-01 02:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 02:55:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2015-11-16 10:30:42 EST
Description of problem:
It would be nice if lmc could support the creation of liveimg compatible squashfs images.

This should be quite easy, because it only requires lmc to wrap the fs image in a squashfs.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Brian Lane 2015-11-16 14:54:36 EST
The reason why I haven't done this is because it's really easy to put a resulting fsimage file into a directory and run mksquashfs on it. In order to support it the user would have to also pass a directory name or tree since not everyone is going to want to use the same layout.
Comment 2 Fabian Deutsch 2015-11-17 01:08:52 EST
(In reply to Brian Lane from comment #1)
> The reason why I haven't done this is because it's really easy to put a
> resulting fsimage file into a directory and run mksquashfs on it.

Right, I agree that it's a quite simple process, however, it would be very convenient to have a one-step process to generate this squashfs (which can be used by anaconda and dracut alike [as you know]), without the manual intervention step.

> In order
> to support it the user would have to also pass a directory name or tree
> since not everyone is going to want to use the same layout.

Hm. At least dracut isn't to flexible about the location of the image IIRC it is squashfs-root/LiveOS/*.img which it is looking for.

Let me note that I don't think of a generic wrap-in-squashfs mode, rather the specific squashfs image to be consumable by anaconda and dracut.
Comment 4 Fabian Deutsch 2015-12-01 02:55:44 EST
It is already supported using the --make-pxe-boot switch

Note You need to log in before you can comment on or make changes to this bug.