Bug 1271178 - rm -rf on /run/gluster/vol/<directory name>/ is not showing quota output header for other quota limit applied directories
rm -rf on /run/gluster/vol/<directory name>/ is not showing quota output head...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Manikandan
Anil Shah
: ZStream
Depends On: 1269375 1271490
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-10-13 06:40 EDT by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-5
Doc Type: Bug Fix
Doc Text:
Previously, when an rm -rf was performed on /<mount point>/<directory with quota limit set>, and 'gluster v quota <volname> list' command was issued, the quota output header was not shown. With this fix, the quota output header is displayed.
Story Points: ---
Clone Of: 1269375
Environment:
Last Closed: 2016-03-01 00:38:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-10-13 06:40:18 EDT
+++ This bug was initially created as a clone of Bug #1269375 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create some directories under the mount point and set limits.
2. Remove one directory by issuing rm -rf /run/gluster/vol/dir/
3. Issue gluster v quota vol list/list-objects

Actual results:
gluster v quota vol list/list-objects should show quota output header and then the list. But it plainly shows the list without a header.
/test                                     5.0MB     80%(4.0MB)   0Bytes   5.0MB              No                   No



Expected results:

                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/test                                     5.0MB     80%(4.0MB)   0Bytes   5.0MB              No                   No




Additional info:

--- Additional comment from Vijay Bellur on 2015-10-13 05:09:34 EDT ---

REVIEW: http://review.gluster.org/12345 (cli/quota : rm -rf on /<mountpoint>/<dir> is not showing quota header) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 6 nchilaka 2015-10-15 05:17:45 EDT
gave ack, as the merge failed without ack and tiering code merge was getting affected without this merge
Comment 11 Manikandan 2015-10-16 02:23:58 EDT
Upstream patch: http://review.gluster.org/12345
Release-3.7 : http://review.gluster.org/12356
Comment 13 Anil Shah 2015-11-12 05:53:49 EST
Bug verified on build glusterfs-3.7.5-6.el7rhgs.x86_64.
Comment 15 errata-xmlrpc 2016-03-01 00:38:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.