Bug 1271490 - rm -rf on /run/gluster/vol/<directory name>/ is not showing quota output header for other quota limit applied directories
rm -rf on /run/gluster/vol/<directory name>/ is not showing quota output head...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
:
Depends On: 1269375
Blocks: 1271178 glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-10-14 03:14 EDT by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269375
Environment:
Last Closed: 2015-11-17 01:00:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-10-14 03:14:04 EDT
+++ This bug was initially created as a clone of Bug #1269375 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create some directories under the mount point and set limits.
2. Remove one directory by issuing rm -rf /run/gluster/vol/dir/
3. Issue gluster v quota vol list/list-objects

Actual results:
gluster v quota vol list/list-objects should show quota output header and then the list. But it plainly shows the list without a header.
/test                                     5.0MB     80%(4.0MB)   0Bytes   5.0MB              No                   No



Expected results:

                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/test                                     5.0MB     80%(4.0MB)   0Bytes   5.0MB              No                   No




Additional info:

--- Additional comment from Vijay Bellur on 2015-10-13 05:09:34 EDT ---

REVIEW: http://review.gluster.org/12345 (cli/quota : rm -rf on /<mountpoint>/<dir> is not showing quota header) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-14 03:07:38 EDT ---

COMMIT: http://review.gluster.org/12345 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 00eeb153f4ea473c6636147f6c72c04336128198
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Oct 13 14:28:03 2015 +0530

    cli/quota : rm -rf on /<mountpoint>/<dir> is not showing quota header
    
    Currently, when 'gluster v quota <VOLNAME> list' command is issued
    after an rm -rf on /run/gluster/vol/<directory>, quota output header is
    not shown. It is because the list_count was properly calculated with
    'gluster v quota <VOLNAME> remove /path' and not with an rm -rf. The patch
    fixes this issue.
    
    Change-Id: I5266a8b0b9322b7db1b9e1d6b0327065931f4bcb
    BUG: 1269375
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12345
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 1 Vijay Bellur 2015-10-14 03:21:13 EDT
REVIEW: http://review.gluster.org/12356 (cli/quota : rm -rf on /<mountpoint>/<dir> is not showing quota header) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-10-15 02:42:50 EDT
COMMIT: http://review.gluster.org/12356 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 0f72aa8668a6d2da4cce9cd04296454f2bc99d58
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Oct 13 14:28:03 2015 +0530

    cli/quota : rm -rf on /<mountpoint>/<dir> is not showing quota header
    
    Currently, when 'gluster v quota <VOLNAME> list' command is issued
    after an rm -rf on /run/gluster/vol/<directory>, quota output header is
    not shown. It is because the list_count was properly calculated with
    'gluster v quota <VOLNAME> remove /path' and not with an rm -rf. The patch
    fixes this issue.
    
            Backport of http://review.gluster.org/#/c/12345/
    
    Cherry-picked from commit 00eeb153f4ea473c6636147f6c72c04336128198
    > Change-Id: I5266a8b0b9322b7db1b9e1d6b0327065931f4bcb
    > BUG: 1269375
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/12345
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Kaushal M <kaushal@redhat.com>
    
    Change-Id: I5266a8b0b9322b7db1b9e1d6b0327065931f4bcb
    BUG: 1271490
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12356
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 01:00:20 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.