Bug 1271215 - Migration scripts are not included in rpm package if egg_info is re-built from tarball
Migration scripts are not included in rpm package if egg_info is re-built fro...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
x86_64 Linux
urgent Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Jakub Libosvar
Toni Freger
: Triaged, ZStream
Depends On:
Blocks: 1270222 1271222
  Show dependency treegraph
 
Reported: 2015-10-13 07:53 EDT by Jakub Libosvar
Modified: 2016-04-26 12:53 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.1-12.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1271222 (view as bug list)
Environment:
Last Closed: 2015-12-21 11:59:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1505628 None None None Never
OpenStack gerrit 234152 None None None Never

  None (edit)
Description Jakub Libosvar 2015-10-13 07:53:26 EDT
Description of problem:
distutils contains only python files https://docs.python.org/2/distutils/sourcedist.html#manifest

neutron/db/migration/alembic_migrations/versions directory and its subdirectories don't have __init__.py because it's not an actual python package. When using "python setup.py egg_info", the SOURCE.txt file is generated by pbr based on git data. If package is built from e.g. tarball then pbr doesn't have access to git data and the whole versions directory is not packaged.

Version-Release number of selected component (if applicable):
openstack-neutron-2015.1.1-9.el7ost

How reproducible:
100%

Steps to Reproduce:
1. Install neutron rpm packages
2. Prepare database and fill connection string to neutron.conf
3. Run neutron-db-manage --config-file /etc/neutron/neutron.conf upgrade head


Actual results:
command fails due to missing versions in neutron package

Expected results:
DB is popupaleted 

Additional info:
Comment 3 Alexander Chuzhoy 2015-10-13 14:00:44 EDT
comment #2
Comment 12 Toni Freger 2015-11-16 04:13:57 EST
Steps to reproduce:

  1) Create a db schema in OSP6
  2) Migrate OSP6 to OSP7 latest puddle without any issue
Comment 13 Toni Freger 2015-11-25 06:51:00 EST
Verification steps performed on AIO via following tutorial - https://access.redhat.com/articles/1317243

From osp6 -openstack-neutron-2014.2.3-24.el7ost.src.rpm
To osp7 -openstack-neutron-2015.1.2-2.el7ost.noarch

Upgrade with one VM internal and external connectivity tested before and after upgrade. 
No issues were found
Comment 16 errata-xmlrpc 2015-12-21 11:59:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2652

Note You need to log in before you can comment on or make changes to this bug.