Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1271249 - tiering:compiler warning with gcc v5.1.1
Summary: tiering:compiler warning with gcc v5.1.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1226881
Blocks: 1229272 1231767 1260923 glusterfs-3.7.6
TreeView+ depends on / blocked
 
Reported: 2015-10-13 13:29 UTC by Mohammed Rafi KC
Modified: 2015-11-17 06:00 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226881
Environment:
Last Closed: 2015-11-17 06:00:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-10-13 13:29:19 UTC
+++ This bug was initially created as a clone of Bug #1226881 +++

Description of problem:

gcc v5.1.1 throws warning for calling a static function from a non-static inline function.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.compile with gcc v5.1.1
2.
3.

Actual results:

couple of compiler warning

Expected results:

should be free from compiler warning

Additional info:

--- Additional comment from Anand Avati on 2015-06-01 07:39:18 EDT ---

REVIEW: http://review.gluster.org/11032 (tiering:static function called from a non static inline function) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Mohammed Rafi KC on 2015-06-01 07:46:16 EDT ---



--- Additional comment from Anand Avati on 2015-06-02 01:30:00 EDT ---

REVIEW: http://review.gluster.org/11032 (tiering:static function called from a non static inline function) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-02 18:00:25 EDT ---

COMMIT: http://review.gluster.org/11032 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 3a94f4c52b56f08c326d3212ca5708e8daf8585b
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Jun 1 16:53:32 2015 +0530

    tiering:static function called from a non static inline function
    
    gcc v5.1.1 throws warning for calling a static function from a
    non-static inline function.
    
    
    <snippet from compiler warning>
      CC       tier.lo
    tier.c:610:15: warning: 'tier_migrate_using_query_file' is static but used in inline function 'tier_migrate_files_using_qfile' which is not static
             ret = tier_migrate_using_query_file ((void *)query_cbk_args);
                   ^
    tier.c:585:47: warning: 'tier_process_brick_cbk' is static but used in inline function 'tier_build_migration_qfile' which is not static
             ret = dict_foreach (args->brick_list, tier_process_brick_cbk,
                                                   ^
    tier.c:565:176: warning: 'demotion_qfile' is static but used in inline function 'tier_build_migration_qfile' which is not static
    tier.c:565:158: warning: 'promotion_qfile' is static but used in inline function 'tier_build_migration_qfile' which is not static
    tier.c:563:58: warning: 'demotion_qfile' is static but used in inline function 'tier_build_migration_qfile' which is not static
    tier.c:563:40: warning: 'promotion_qfile' is static but used in inline function 'tier_build_migration_qfile' which is not static
             ret = remove (GET_QFILE_PATH (is_promotion));
                                            ^
      CCLD     tier.la
    
    </snip>
    
    Change-Id: I46046feeb79ab4e2724b0ba6b02c9ec8b121ff4e
    BUG: 1226881
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11032
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Anoop C S <achiraya@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

--- Additional comment from Vijay Bellur on 2015-10-12 08:00:01 EDT ---

REVIEW: http://review.gluster.org/12342 (tier/shd: inline warning when compiled with gcc v.5) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-13 08:46:14 EDT ---

COMMIT: http://review.gluster.org/12342 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit fc8df80f157c148cf60500be14c1f6a9aeed8d7b
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Oct 12 17:22:20 2015 +0530

    tier/shd: inline warning when compiled with gcc v.5
    
    Change-Id: I487a26263d6e940eed364a831e99f9b8390bc96a
    BUG: 1226881
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12342
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Tested-by: Anoop C S <anoopcs@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 1 Vijay Bellur 2015-10-13 13:30:56 UTC
REVIEW: http://review.gluster.org/12352 (tier/shd: inline warning when compiled with gcc v.5) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Vijay Bellur 2015-10-14 02:47:12 UTC
COMMIT: http://review.gluster.org/12352 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 9fedd0a838bc98ae966085662385c6b9ea6ff0e9
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Oct 12 17:22:20 2015 +0530

    tier/shd: inline warning when compiled with gcc v.5
    
    back port of>
    >Change-Id: I487a26263d6e940eed364a831e99f9b8390bc96a
    >BUG: 1226881
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12342
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Anoop C S <anoopcs@redhat.com>
    >Tested-by: Anoop C S <anoopcs@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit fc8df80f157c148cf60500be14c1f6a9aeed8d7b)
    
    Change-Id: I03821a626ab08d20730ce3ea3f374178c899d369
    BUG: 1271249
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12352
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Raghavendra Talur 2015-11-17 06:00:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.