Bug 1271520 - Gnome does not install apps, F23 Final TC9 x86_64 Desktop
Gnome does not install apps, F23 Final TC9 x86_64 Desktop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 1244443 1247193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 04:17 EDT by joerg.lechner
Modified: 2015-11-02 06:18 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 16:11:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of trial to install Gimp (135.95 KB, image/png)
2015-10-14 04:17 EDT, joerg.lechner
no flags Details

  None (edit)
Description joerg.lechner 2015-10-14 04:17:56 EDT
Created attachment 1082728 [details]
screenshot of trial to install Gimp

Description of problem:
F23 Final TC9 x86_64 Desktop, Gnome refuses to install apps (i.e. Rapid Foto Downloader, Gimp, Xsane). dnf install of apps ok. See screenshot.

Version-Release number of selected component (if applicable):
version delivered with TC9

How reproducible:
always

Steps to Reproduce:
1. install F23 Final TC9 x86_64 Desktop, perform all updates
2. click on Gnome SW
3. try to install i.e Rapid Foto Downloader, Gimp, or Xsane

Actual results:
 Gnome refuses to install

Expected results:
 Gnome installs apps

Additional info:
Comment 1 joerg.lechner 2015-10-14 04:30:15 EDT
A possible reason is that Gnome SW tool seems to offer F22, F21 versions (if the display after the unsuccessful installation shows the correct version number)
Comment 2 joerg.lechner 2015-10-14 09:19:56 EDT
F22 problem - the same problem???
Installed F22, last build (publicly delivered version), to a 32GB usb flash medium. dnf su admin pw, ok. dnf update ok. Tried to install apps via the Gnome SW. Admin password requested,correct admin pw always rejected. Any idea? Coincident behaviour with the previous problems of F23 TC9 Gnome SW? Gnome SW F23 TC9 rejected installation of Gimp, Xsane etc.
Comment 3 joerg.lechner 2015-10-15 04:29:22 EDT
After update today 2015-10-15:

Aktualisiert:
  autocorr-en.noarch 1:5.0.3.1-1.fc23                                           
  dnf.noarch 1.1.3-1.fc23                                                       
  dnf-conf.noarch 1.1.3-1.fc23                                                  
  dnf-plugins-core.noarch 0.1.13-1.fc23                                         
  dnf-yum.noarch 1.1.3-1.fc23                                                   
  hawkey.x86_64 0.6.2-1.fc23                                                    
  ipcalc.x86_64 0.1.4-2.fc23                                                    
  libipt.x86_64 1.4.3-1.fc23                                                    
  libreoffice-calc.x86_64 1:5.0.3.1-1.fc23                                      
  libreoffice-core.x86_64 1:5.0.3.1-1.fc23                                      
  libreoffice-draw.x86_64 1:5.0.3.1-1.fc23                                      
  libreoffice-emailmerge.x86_64 1:5.0.3.1-1.fc23                                
  libreoffice-filters.x86_64 1:5.0.3.1-1.fc23                                   
  libreoffice-graphicfilter.x86_64 1:5.0.3.1-1.fc23                             
  libreoffice-impress.x86_64 1:5.0.3.1-1.fc23                                   
  libreoffice-math.x86_64 1:5.0.3.1-1.fc23                                      
  libreoffice-opensymbol-fonts.noarch 1:5.0.3.1-1.fc23                          
  libreoffice-pdfimport.x86_64 1:5.0.3.1-1.fc23                                 
  libreoffice-pyuno.x86_64 1:5.0.3.1-1.fc23                                     
  libreoffice-ure.x86_64 1:5.0.3.1-1.fc23                                       
  libreoffice-writer.x86_64 1:5.0.3.1-1.fc23                                    
  libreoffice-xsltfilter.x86_64 1:5.0.3.1-1.fc23                                
  libsolv.x86_64 0.6.14-2.fc23                                                  
  libv4l.x86_64 1.8.1-1.fc23                                                    
  netcf-libs.x86_64 0.2.8-3.fc23                                                
  python3-dnf.noarch 1.1.3-1.fc23                                               
  python3-dnf-plugins-core.noarch 0.1.13-1.fc23                                 
  python3-hawkey.x86_64 0.6.2-1.fc23                                            
  selinux-policy.noarch 3.13.1-151.fc23                                         
  selinux-policy-targeted.noarch 3.13.1-151.fc23                                
  webkitgtk4.x86_64 2.10.1-1.fc23                                               

Komplett!
[root@linux joerg]# 

The version numbers of the apps shown in Gnome SW are now xxxxxx.fc23 not any more xxxxx.fc22.
To proove I installed via Gnome SW successfully: Stellarium, Brasero, Rapid Photo Downloader, Xsane, Gparted.

Libre Office Base I could not install, installation refused even it has the fc23 version number. Libre Office problem?
Comment 4 Kalev Lember 2015-10-22 16:11:10 EDT
We had an issue with out of date metadata on the install media. Should be fixed in Fedora 23 RC2 and newer builds.
Comment 5 Kalev Lember 2015-11-01 15:56:33 EST
*** Bug 1244443 has been marked as a duplicate of this bug. ***
Comment 6 Kalev Lember 2015-11-01 16:02:53 EST
*** Bug 1247193 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.