Bug 1271661 - On satellite 6.1, 'Package search' functionality inside Content ->Products -> manage Packages for Third party repositories is not working
On satellite 6.1, 'Package search' functionality inside Content ->Products ->...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.1.1
All Linux
medium Severity medium (vote)
: GA
: --
Assigned To: satellite6-bugs
aruzicka
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 08:53 EDT by Komal
Modified: 2016-07-27 07:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:13:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1990193 None None None Never

  None (edit)
Description Komal 2015-10-14 08:53:30 EDT
Description of problem:

On satellite 6.1, 'Package search' functionality inside Content ->Products -> manage Packages for Third party repositories is not working

Testing Satellite 6.1.1 and could see a bug.

1. Added a HP software repo under Content->Products. When went there by clicking  on Repositories tab, then clicked on my repo called HP which is connected to this repo (http://downloads.linux.hp.com/repo/spp/rhel/7/x86_64/current/)

2. Then clicked 'Manage Packages' button on the right it lists 286 packages. Now to the problem. There is a search field where we should be able to search/filter for a package name. It is this one which does not work. 

3. If we write a search keyword and press ENTER key nothing happens, it just reload the package list. If instead clicked with mouse button on a magnifier button then it starts a search but find nothing even though we search for a keyword which exists in the package list.

Version-Release number of selected component (if applicable):
Satellite 6.1.1

How reproducible:
Always
Comment 2 Bryan Kearney 2015-12-10 17:12:05 EST
Clearing the flags to make sure it gets triaged.
Comment 3 Brad Buckingham 2016-04-28 14:22:30 EDT
In Satellite 6.2, the search interface for the content and subscription related aspects has been updated to utilize 'scoped_search'.

For example, on the page referenced by this bug (i.e Content->Products->[product] -> Repositories -> [repo] -> Manage Packages), the user may now click in to the 'search' input and be presented with options (e.g. name, version, arch...etc). Once an option is selected, the user is presented with more options (e.g. =, !=...etc) and the process continues.

E.g.

name=mypackage
arch=x86_64
...


Note: this bug is related to bug 1282889
Comment 5 aruzicka 2016-06-27 07:56:13 EDT
VERIFIED.
Satellite 6.2 GA 17.0
katello-3.0.0-8.el7sat.noarch

Followed instructions in #0, search field filters shown packages as expected.
Comment 6 Bryan Kearney 2016-07-27 07:13:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.