Bug 127175 - authconfig dialog box does not fit on 800x600 screen
authconfig dialog box does not fit on 800x600 screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
Brian Brock
:
: 122468 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-02 20:53 EDT by Barry K. Nathan
Modified: 2013-07-02 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 08:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
to test it, copy it to /usr/share/authconfig and launch authconfig-gtk (108.65 KB, text/plain)
2004-08-25 09:12 EDT, Jindrich Novy
no flags Details

  None (edit)
Description Barry K. Nathan 2004-07-02 20:53:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7)
Gecko/20040701 Firefox/0.9

Description of problem:
When I try to run authconfig-gtk on a computer with an 800x600 screen,
the dialog box is so tall that the OK and Cancel (I think that's what
they're called) buttons are offscreen and cannot be clicked using the
mouse or other pointing device. This makes it completely unusable on
this computer (this LCD's native resolution is 800x600 so increasing
the resolution isn't an option).

This is a regression (FC2 has this bug, FC1 doesn't). Unfortunately I
didn't find this during FC2-test, but oh well, better late than never...

Version-Release number of selected component (if applicable):
authconfig-gtk-4.6.3-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 or FC-devel on a computer with an 800x600 screen, or
use a computer with an 800x600 screen to ssh to an FC2 or FC-devel host.
2. Run system-config-authentication or authconfig-gtk.


Actual Results:  Dialog box does not fit on screen, so I cannot click
OK and save changes.

Expected Results:  Dialog box should fit on the screen, as it does on FC1.

Additional info:
Comment 1 Barry K. Nathan 2004-07-04 05:25:11 EDT
Running it like this is a (barely sufficient) workaround: 
LANG=ja_JP.UTF-8 authconfig-gtk 
 
Yes, this means you have to puzzle through the Japanese (or if you 
didn't click the Japanese checkbox at Fedora Core install time, then 
puzzle through some garbage), but OTOH the OK and Cancel buttons are 
actually onscreen and clickable... 
 
(Changing "Severity" from Normal to Low because I now have a 
workaround) 
Comment 2 Jindrich Novy 2004-08-25 09:10:10 EDT
Hi Barry,

the original interface was designed apparently for 1024x768+
resolutions. I do believe that there are plenty of people who need to
use authconfig-gtk in a lower resolution which is your case. I
modified the interface from single column design to multi-column and
tested it on 800x600 and worked fine for me. I also modified confusing
keyboard shortcuts. Adding attachment which allows you to test the new
interface.

greetings,
Jindrich
Comment 3 Jindrich Novy 2004-08-25 09:12:58 EDT
Created attachment 103068 [details]
to test it, copy it to /usr/share/authconfig and launch authconfig-gtk

Does it work for you?
Comment 4 Barry K. Nathan 2004-08-26 11:55:28 EDT
Things are a bit busy for me right now, so I probably won't be able to
test this until this weekend. (I'll test it earlier if I can however.)
Comment 5 Barry K. Nathan 2004-09-01 06:36:02 EDT
Ok, I've tried out the new interface, it seems to work with 800x600
resolution. Cool. (This is on FC2, not FC3-test or FC-devel. I'll
retest on FC-devel if you wish.)
Comment 6 Barry K. Nathan 2004-09-01 06:52:41 EDT
Wow, the new interface even works on 640x480! (You can drag the window
from side to side, and while you can't see the entire thing at once at
640x480, you can see well more than enough to get work done.)
Comment 7 Jindrich Novy 2004-09-01 08:23:32 EDT
Nice to head that, authconfig is coming with the new interface from
the version 4.6.5 which I'll make available in rawhide. The new
version of authconfig with enhanced interface and NIS configuration
should be available in the end of this week.

HTH, Jindrich
Comment 8 Jindrich Novy 2004-09-06 04:27:46 EDT
*** Bug 122468 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.