Bug 127178 - automount fails with NIS map entries specifying noquota
automount fails with NIS map entries specifying noquota
Status: CLOSED DUPLICATE of bug 122448
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-03 04:10 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-07-03 04:10:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.3)
Gecko/20030327

Description of problem:
I have just upgraded my system to Fedora Core 2 and am having
a problem with automount attempting to mount NFS filesystems
from Solaris servers.

The automounter is configured via an NIS map, i.e., it is being
run with the command

        /usr/sbin/automount --timeout=60 /home yp home.indirect

All entries in the NIS automount map home.indirect are of the form

        -intr,nosuid,hard,noquota somehostname:/export/somedirectory

This NIS map is being served by a Solaris NIS server over which I
have no control.

When I attempt to automount any such filesystem it fails with a message
written to /var/log/messages saying that noquota is not a valid option
for mounting an NFS file system.

This has always worked in the past for me. I still have a running RedHat
7.3 system that is using the same automount map and has no trouble
automounting these file systems, even with the noquota option in the
NIS automount map entries. If I try to manually mount an NFS filesystem
on that 7.3 machine with the noquota option specified, it fails with a
message that noquota is not supported for NFS, which makes me believe
that somehow the 7.3 automounting system is filtering out the noquota
option before performing the actual mount. It would seem that this
filtering no longer occurs in Fedora 2.

How can I fix this problem without changing the NIS map entries,
which I cannot do?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run automount using an NIS map that specifies noquota as
a mount option for its entries.

2. Attempt to use the automounter to mount a file system specified
by one of these entries.

    

Actual Results:  After the attempt, /var/log/messages will contain a
message
such as:

Jul  2 20:57:11 ctrobot automount[2626]: >> Unsupported nfs mount
option: noquota


Expected Results:  The filesystem should have been mounted.

Additional info:
Comment 1 Jeffrey Moyer 2004-07-06 06:36:56 EDT
The problem is that mount actually regressed, and did not support the
-s option (sloppy mounts).  See bug 122448.

*** This bug has been marked as a duplicate of 122448 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.