Bug 1271819 - ironic has no logrotate configuration [osp-7]
ironic has no logrotate configuration [osp-7]
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: async
: 7.0 (Kilo)
Assigned To: Lucas Alvares Gomes
Raviv Bar-Tal
: AutoVerified, ZStream
: 1280408 (view as bug list)
Depends On:
Blocks: 1352006
  Show dependency treegraph
 
Reported: 2015-10-14 15:43 EDT by James Slagle
Modified: 2016-08-18 10:11 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-ironic-2015.1.2-5.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1352006 (view as bug list)
Environment:
Last Closed: 2016-07-20 15:53:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add log rotate configuration OSP7 (1.65 KB, application/mbox)
2016-06-27 11:44 EDT, Lucas Alvares Gomes
no flags Details

  None (edit)
Description James Slagle 2015-10-14 15:43:37 EDT
ironic has no logrotate configuration, meaning that the logs can grow quite large. One should be included by default with the packaging. See the other openstack packages for examples. For instance, the config for heat looks like:

[root@instack ~]# cat /etc/logrotate.d/openstack-heat 
/var/log/heat/*.log {
    rotate 14
    size 10M
    missingok
    compress
    copytruncate
}
Comment 4 Irina Petrova 2016-06-24 03:45:55 EDT
Hey Lucas,

Any news on this? 

This bug has been targeted at OSP v7 and we're already looking at OSP 9/10. Any chance we're going to have logrotation by default in any of the aforementioned?


Best,
Irina
Comment 5 Lucas Alvares Gomes 2016-06-27 11:44 EDT
Created attachment 1172917 [details]
Add log rotate configuration OSP7
Comment 6 Lucas Alvares Gomes 2016-06-27 11:48:29 EDT
(In reply to Irina Petrova from comment #4)
> Hey Lucas,
> 
> Any news on this? 
> 

Hi Irina,

I can confirm there's no logrotate configuration for the openstack-ironic package in OSP7 [0], I've created a patch for it and I'm adding Lon to the need additional information form because I don't know how I can submit the change for OSP7.

I've also checked the openstack-ironic spec in RDO [1] and it already includes the logrotate configuration.


[0] http://pkgs.devel.redhat.com/cgit/rpms/openstack-ironic/tree/?h=rhos-7.0-rhel-7
[1] https://www.rdoproject.org/documentation/rdo-packaging/#distgit---where-the-spec-file-lives
Comment 7 Lucas Alvares Gomes 2016-06-27 11:50:27 EDT
As a note, we can apply the same patch (attached) for OSP8, it doesn't conflict.
Comment 8 Jan Buchta 2016-06-29 10:07:22 EDT
Hi. We seem to have 2 customers already facing the problem, I guess we need clear statement on when we can expect to have this done for 7 & 8.

Thank you.
Cheers
Jan
Comment 12 errata-xmlrpc 2016-07-20 15:53:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1468
Comment 13 Lucas Alvares Gomes 2016-08-18 10:11:59 EDT
*** Bug 1280408 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.