Bug 127193 - No application associated with rpm in default setup
No application associated with rpm in default setup
Status: CLOSED DUPLICATE of bug 124850
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-03 12:51 EDT by Toralf
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toralf 2004-07-03 12:51:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
There is no open action for rpm files in the default setup. I'd expect
system-install-packages to be associate with rpms, of course. In fact,
that application isn't even selectable in "Edit file type" dialog, or
in "Open with" menu for rpm files.

Version-Release number of selected component (if applicable):
1.2.12-1

How reproducible:
Always

Steps to Reproduce:
1. Double click an rpm file
2. Right-click on file
3. Select "Open With" in context menu
    

Actual Results:
1) Popup with the text:

There is no action associated with
"<whatever>.rpm"
appears. I clicking "Associate Application" in that box, "Edit file
type" box for MIME type "application/x-rpm" is displayed - but it has
an empty "Default action:" list

2, 3) "Open with" menu contains only "An Application..."

Expected Results:  system-install-packages is started.

system-install-packages or "Install Packages" also mentioned in "Open
with" menu and in "Edit file type" for "application/x-rpm"

Additional info:

I really don't understand why the app isn't at least mentioned in
context menu and "Edit file type", since 
/usr/share/application-registry/system-install-packages.applications
looks good to me.
Comment 1 Toralf 2004-07-03 13:09:26 EDT
The problem could be that I have /usr/share/gnome-vfs/gnome-vfs.keys
with a "shortlist" for rapplication/x-rpm that references
"redhat-install-packages", not "system-install-packages". I also
notice that gnome-mime-data, which installs this file, is still at
version 2.4.1 in the Fedora Core dist (where everything else GNOME is
version 2.6.0)
Comment 2 Toralf 2004-07-03 13:12:01 EDT
Right. I didn't notice earlier that this was registered already.
Sorry. Marking as duplicate...

*** This bug has been marked as a duplicate of 124850 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.