Bug 1271947 - 'ls' on client mount lists varying number of files while promotion/demotion
'ls' on client mount lists varying number of files while promotion/demotion
Status: CLOSED DUPLICATE of bug 1275998
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On:
Blocks: 1278384
  Show dependency treegraph
 
Reported: 2015-10-15 02:54 EDT by Bhaskarakiran
Modified: 2016-11-23 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278384 (view as bug list)
Environment:
Last Closed: 2015-11-24 08:21:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhaskarakiran 2015-10-15 02:54:08 EDT
Description of problem:
=======================

This is on NFS mount. Created 6x2 dist-rep volume and attached a rep-2 tier. Created 5000 files and stopped access from client side. While the promotions/demotions are happening, listing the files from client mount and every time it shows different number. 

[root@rhs-client17 5000]# ls file.* | wc -l
4997
[root@rhs-client17 5000]# ls file.* | wc -l
5000
[root@rhs-client17 5000]# ls file.* | wc -l
4995
[root@rhs-client17 5000]# ls file.* | wc -l
4999
[root@rhs-client17 5000]# ls file.* | wc -l
5001
[root@rhs-client17 5000]# ls file.* | wc -l
4997
[root@rhs-client17 5000]# ls file.* | wc -l
4980
[root@rhs-client17 5000]# ls file.* | wc -l
5000
[root@rhs-client17 5000]# ls file.* | wc -l
4992
[root@rhs-client17 5000]# ls file.* | wc -l
4999

Version-Release number of selected component (if applicable):
=============================================================
[root@transformers ~]# gluster --version
glusterfs 3.7.5 built on Oct 12 2015 01:12:54
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.

[root@transformers ~]# rpm -qa |grep glusterfs-server
glusterfs-server-3.7.5-0.18.git2def6bb.el7.centos.x86_64

How reproducible:
=================
100%

Steps to Reproduce:
===================
As in description.


Actual results:
===============
Varying number of files are listed from client


Expected results:
=================
Number of files created = listing same number


Additional info:
===============
sosreports will be copied to rhsqe.
Comment 1 Dan Lambright 2015-11-24 08:21:14 EST
This problem is tracked by bug 1281598.

*** This bug has been marked as a duplicate of bug 1275998 ***

Note You need to log in before you can comment on or make changes to this bug.