Bug 1281598 - Data Tiering: "ls" count taking link files and promote/demote files into consideration both on fuse and nfs mount
Data Tiering: "ls" count taking link files and promote/demote files into cons...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1275998
Blocks: 1283923
  Show dependency treegraph
 
Reported: 2015-11-12 16:34 EST by Dan Lambright
Modified: 2016-06-16 09:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275998
: 1283923 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-12 16:34:54 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: WIP readdirp to cold tier only) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-11-15 22:26:56 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-11-16 21:55:43 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2015-11-16 23:02:38 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#9) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2015-11-17 22:39:34 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#10) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 6 Vijay Bellur 2015-11-18 17:11:23 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#11) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 7 Vijay Bellur 2015-11-18 23:54:48 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#12) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 8 Vijay Bellur 2015-11-19 19:12:34 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#13) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 9 Vijay Bellur 2015-11-20 04:31:18 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#14) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 10 Vijay Bellur 2015-11-20 07:51:08 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#15) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 11 Vijay Bellur 2015-11-20 08:40:54 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#16) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 12 Vijay Bellur 2015-11-22 12:57:50 EST
REVIEW: http://review.gluster.org/12530 (cluster/tier: readdirp to cold tier only) posted (#17) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 13 Vijay Bellur 2015-11-23 07:05:59 EST
COMMIT: http://review.gluster.org/12530 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3b52c71b0ab57a9daaf31bf3dc8563da37927a66
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Wed Nov 4 15:33:22 2015 -0500

    cluster/tier: readdirp to cold tier only
    
    It is possible a file would get migrated in the middle
    of a readdir operation. If there are four subvolumes A,B,C,D,
    and if readdir reads them in order and reaches subvol B,
    then, if a file is moved from D to A, it will not be included
    in the readdir output.
    
    This phenonema has pre-existed in DHT migration but is more
    apparent in tiering.
    
    When a file is moved off the hashed subvolume a T file is created.
    For tiering, we will make the cold subvolume the hashed subvolume.
    This will ensure the creation of a T file. Readdir will not skip T
    files in the tier translator.
    
    Making the cold subvolume the hashed subvolume ensures the T
    files created on promotions or creates will be less likely to
    fill the volume.
    
    Creates still put the data on the hot subvolume.
    
    Change-Id: Ifde557d3d0e94a4570ca9f115adee3db2ee75407
    BUG:  1281598
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12530
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 14 Niels de Vos 2016-06-16 09:44:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.