Bug 1271976 - RHEV-H TUI HE deployment is interrupted on "VM CONFIGURATION" step
RHEV-H TUI HE deployment is interrupted on "VM CONFIGURATION" step
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Douglas Schilling Landgraf
Ying Cui
: TestBlocker
: 1275571 (view as bug list)
Depends On:
Blocks: 1245143 1269176
  Show dependency treegraph
 
Reported: 2015-10-15 04:18 EDT by Ying Cui
Modified: 2016-03-09 09:40 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:40:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
varlog.tar.bz2 (481.56 KB, application/x-bzip)
2015-10-15 04:29 EDT, Ying Cui
no flags Details
sosreport (5.47 MB, application/x-xz)
2015-10-15 04:30 EDT, Ying Cui
no flags Details
answerfile (3.00 KB, text/plain)
2015-10-15 04:42 EDT, Ying Cui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47354 master MERGED answerfile: fixing type for None value on OVEHOSTED_VM/vmBoot Never
oVirt gerrit 47370 ovirt-3.6 MERGED answerfile: fixing type for None value on OVEHOSTED_VM/vmBoot Never

  None (edit)
Description Ying Cui 2015-10-15 04:18:22 EDT
Summary:
RHEV-H TUI HE deployment is interrupted on "VM CONFIGURATION" step, then hosted-engine failed to deploy!

Test Version:
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151013.76.el7ev)
# rpm -qa ovirt-node ovirt-node-plugin-hosted-engine ovirt-hosted-engine-setup
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-node-3.3.0-0.14.20151013git5f84da0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev.noarch

How reproducible:
100%

Test Steps:
1. Installed RHEVH 7.2 for rhev 3.6.0 successful.
2. Setup Network yet.
3. Set root password on Engine TUI.
3. Deploy HE on RHEV-H TUI.
4. Enable "PXE Boot Engine VM"
5. Click on "Deploy"

=============================
... ...
          --== SYSTEM CONFIGURATION ==--
         
         
          --== NETWORK CONFIGURATION ==--
         
          Please indicate a nic to set ovirtmgmt bridge on: (em1) [em1]: 
          iptables was detected on your computer, do you wish setup to configure it? (Yes, No)[Yes]: 
          Please indicate a pingable gateway IP address [10.66.11.254]: 
         
          --== VM CONFIGURATION ==--
         
[ ERROR ] Failed to execute stage 'Environment customization': The provided boot type is not supported. Please try again
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20151015043012.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
Something went wrong setting up hosted engine, or the setup process was cancelled.

Press any key to continue...

=============================

Actual Result:
HE deployment process is interrupted on "VM CONFIGURATION" step,hosted-engine failed to deploy!

Expect Result:
No such interrupt

Additional info:

# ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20151015074156-3vky16.log
...
2015-10-15 07:44:53 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vm/configurevm.py", line 164, in _customization
    'The provided boot type is not supported. '
RuntimeError: The provided boot type is not supported. Please try again
2015-10-15 07:44:53 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Environment customization': The provided boot type is not supported. Please try again
...
Comment 2 Ying Cui 2015-10-15 04:27:07 EDT
I tested HE on RHEL 7.2 with the same steps, no such issue. so it is RHEV-H TUI specific issue.
# rpm -qa kernel ovirt-hosted-engine-setup
kernel-3.10.0-322.el7.x86_64
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
kernel-3.10.0-320.el7.x86_64
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 Beta (Maipo)

And I tested running HE on RHEV-H 7.2 via cmd, not via TUI.
 # screen hosted-engine --deploy
No such issue.
Comment 3 Simone Tiraboschi 2015-10-15 04:29:22 EDT
Hi Ying,
could you please attach the ansferfile that got generated by ovirt-node-plugin-hosted-engine?
Comment 4 Ying Cui 2015-10-15 04:29 EDT
Created attachment 1083165 [details]
varlog.tar.bz2
Comment 5 Ying Cui 2015-10-15 04:30 EDT
Created attachment 1083166 [details]
sosreport
Comment 6 Simone Tiraboschi 2015-10-15 04:38:50 EDT
Found,
hosted-engine-setup got from node plugin
2015-10-15 08:09:25 DEBUG otopi.context context.dumpEnvironment:510 ENV OVEHOSTED_VM/vmBoot=str:'None'
which is not an allowed value.

Please pass one of:

vmBoot=str:cdrom
vmBoot=str:pxe
vmBoot=str:disk
vmBoot=none:None

The latest is handled as a None value exactly as if there is no value (ovirt-hosted-engine-setup will ask the user).
str:'None' is instead handled a valid string witch fails each comparison and so the issue.
Comment 7 Ying Cui 2015-10-15 04:42 EDT
Created attachment 1083181 [details]
answerfile
Comment 8 Ying Cui 2015-10-15 04:43:44 EDT
(In reply to Simone Tiraboschi from comment #3)
> Hi Ying,
> could you please attach the ansferfile that got generated by
> ovirt-node-plugin-hosted-engine?

Hi Simone, provided on comment 7.
Comment 9 Simone Tiraboschi 2015-11-03 08:08:38 EST
*** Bug 1275571 has been marked as a duplicate of this bug. ***
Comment 10 Ying Cui 2015-11-17 01:14:19 EST
The original issue is fixed on the following builds. But exist another medium defect Bug 1282685 - Should not ask to specify the device to boot the VM when Hosted Engine TUI already selected PXE Boot Engine VM.

Now verified this bug, and trace the another new issue by bug 1282685. 

# rpm -qa ovirt-node-plugin-hosted-engine ovirt-hosted-engine-setup 
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)

Test Steps:
1. Installed RHEVH 7.2 for rhev 3.6 beta 1 successful.
2. Setup Network via dhcp yet.
3. Set root password on Engine TUI.
3. Deploy HE on RHEV-H TUI.
4. Enable "PXE Boot Engine VM"
5. Click on "Deploy"

During VM CONFIGURATION, no such original failed and break happened.
Comment 12 errata-xmlrpc 2016-03-09 09:40:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.