Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1272068 - system-config-kickstart : "Package selection is disabled due to problems downloading package information."
system-config-kickstart : "Package selection is disabled due to problems down...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
7.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
Petr Bokoc
: Patch
: 1315954 (view as bug list)
Depends On:
Blocks: 1420851 1478303
  Show dependency treegraph
 
Reported: 2015-10-15 08:12 EDT by Fabien Malfoy
Modified: 2018-07-03 03:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: system-config-kickstart-2.9.7-1.el7
Doc Type: Bug Fix
Doc Text:
Package selection now works in "system-config-kickstart" A bug in the "system-config-kickstart" graphical Kickstart file creation utility caused the package selection to be unavailable because the tool could not download package information from repositories. This bug is now fixed, and you can now configure package selection in "system-config-kickstart" again.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:01:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repolist of freshly subscribed system (4.46 KB, text/plain)
2016-06-16 11:53 EDT, Marek Hruscak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0835 None None None 2018-04-10 11:01 EDT

  None (edit)
Description Fabien Malfoy 2015-10-15 08:12:07 EDT
Description of problem:
The system-config-kickstart does not allow software packages selection.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.9.2-4.el7

How reproducible:
Install and launch system-config-kickstart. Click on the "Package Selection" tab.

Actual results:
Error message ""Package selection is disabled due to problems downloading package information.""

Expected results:
Selectable list of packages to install.


Additional info:

Code snippet reponsible for the package information download in the following file

####  /usr/share/system-config-kickstart/packages.py

46 class sckYumBase(yum.YumBase):
...
115     def __init__ (self, callback=None):
...
156         # If we're on a release, we want to try the base repo first.  Otherwise,
157         # try development.  If neither of those works, we have a problem.
158         if "fedora" in map(lambda repo: repo.id, self.repos.listEnabled()):
159             repoorder = ["fedora", "rawhide", "development"]
160         else:
161             repoorder = ["rawhide", "development", "fedora"]
162
163         self.repos.disableRepo("*")
164         if callback: callback.next_task()
165
166         self.packagesEnabled = False
167         for repo in repoorder:
168             try:
169                 self.repos.enableRepo(repo)
170                 self.packagesEnabled = True
171                 break
172             except yum.Errors.RepoError:
173                 pass
174
175         if not self.packagesEnabled:
176             return
...
Comment 2 David Cantrell 2016-01-21 14:22:45 EST
Does your system have an active subscription with the CDN?  If it doesn't on RHEL, yum won't be able to find packages.  That's where it gets the information on RHEL.
Comment 3 Marek Hruscak 2016-06-14 06:11:56 EDT
I have tried both options, same message appear after registration to RHN via subscription-manager-gui.
Comment 4 Marek Hruscak 2016-06-16 10:25:51 EDT
*** Bug 1315954 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2016-06-16 11:10:48 EDT
Can you let me know what package repos are enabled after registration with RHN?  What are their names/IDs?  Thanks.
Comment 6 Marek Hruscak 2016-06-16 11:53 EDT
Created attachment 1168782 [details]
repolist of freshly subscribed system
Comment 7 Chris Lumens 2016-06-16 13:40:46 EDT
Could you apply the following patch and let me know how it works for you.  You can either do this against the source tree, or you can drop the src/ part and apply it to the file in /usr/share/system-config-kickstart.  Thanks.

diff --git a/src/packages.py b/src/packages.py
index bb25a9c..8c2a468 100644
--- a/src/packages.py
+++ b/src/packages.py
@@ -153,9 +153,12 @@ class sckYumBase(yum.YumBase):
 
         if callback: callback.next_task()
 
-        # If we're on a release, we want to try the base repo first.  Otherwise,
-        # try development.  If neither of those works, we have a problem.
-        if "fedora" in map(lambda repo: repo.id, self.repos.listEnabled()):
+        repoids = map(lambda repo: repo.id, self.repos.listEnabled())
+        rhelRepos = filter(lambda repoid: "rhel-7" in repoid, repoids)
+
+        if rhelRepos:
+            repoorder = rhelRepos
+        elif "fedora" in repoids:
             repoorder = ["fedora", "rawhide", "development"]
         else:
             repoorder = ["rawhide", "development", "fedora"]
Comment 8 Marek Hruscak 2016-06-21 09:16:55 EDT
This patch works as expected. Packages are visible in package selection spoke.
Comment 14 Marek Hruscak 2017-12-08 06:38:37 EST
note: it displays Package groups and list only for main repository rhel-7-workstation-rpms
Comment 15 John 2017-12-24 23:46:22 EST
IT'S TAKEN OVER TWO YEARS TO FIX THIS?

And it's supposedly fixed now, but I'm looking at this problem right now, on a fully updated centos 7.4

rpm -qi system-config-kickstart
Name        : system-config-kickstart
Version     : 2.9.6
Release     : 1.el7

I suppose CentOS must be lagging a bitm behind the el7 upstream. I guess they can be forgiven for this, when it takes red hat two years to fix a bug like this.
Comment 16 John 2017-12-25 00:06:37 EST
As per the suggestion here:
   https://bugs.centos.org/view.php?id=9611
I've gone and added the "base" repo, to line 161 of /usr/share/system-config-kickstart/packages.py so it now looks like:

        # If we're on a release, we want to try the base repo first.  Otherwise,
        # try development.  If neither of those works, we have a problem.
        if "fedora" in map(lambda repo: repo.id, self.repos.listEnabled()):
            repoorder = ["fedora", "rawhide", "development"]
        else:
            repoorder = ["rawhide", "development", "fedora", "base"]

Merry Xmas to all you clowns at Red Hat. 

So nice of you to leave this bug hanging around for two years, so it could waste my time on Xmas Day 2017.
Comment 17 John 2017-12-25 00:33:16 EST
This is an absolute joke.

I tried running system-config-kickstart on f27, and had to go and dig up dependency system-config-date from f25, not in f27 repos, before i could install. Then it wants my /etc/yum.conf, which has been retired on f27. Why should it need yum.conf, when the system being installed will not have it? So I gave it a yum.conf, and then I still hit this bug, no package selection.

FYI, the Fedora 27 version of system-config-kickstart is this:

rpm -qi system-config-kickstart
Name        : system-config-kickstart
Version     : 2.9.3
Release     : 5.fc27

TWO POINT NINE POINT THREE.

So i go and install system-config-kickstart in an up-to-date centos 7.4 vm. Now, yum.conf is good, but I still hit this bug with no package selection.

centos 7.4 is currently using:

rpm -qi system-config-kickstart
Name        : system-config-kickstart
Version     : 2.9.6
Release     : 1.el7

Newer version than in Fedora 27, but it's not 2.9.7-1.el7, is it. So it still does not have this package selection bug fixed.

So i fix the package selection bug as described in:
  https://bugs.centos.org/view.php?id=9611

And now I have package selection. But what the hell is this? The package selection does not match what is on the ISO that i have selected as the installation source:

cat /mnt/6Tb/Shared-6tb/data/repos/centos/server/iso/repodata/*comps*.xml | grep -A 2 "<environment>" | grep -v "<environment>"
    <id>compute-node-environment</id>
    <name>Compute Node</name>
--
    <id>infrastructure-server-environment</id>
    <name>Infrastructure Server</name>
--
    <id>file-print-server-environment</id>
    <name>File and Print Server</name>
--
    <id>web-server-environment</id>
    <name>Basic Web Server</name>
--
    <id>virtualization-host-environment</id>
    <name>Virtualization Host</name>
--
    <id>minimal</id>
    <name>Minimal Install</name>
--
    <id>graphical-server-environment</id>
    <name>Server with GUI</name>
--
    <id>gnome-desktop-environment</id>
    <name>GNOME Desktop</name>
--
    <id>kde-desktop-environment</id>
    <name>KDE Plasma Workspaces</name>
--
    <id>developer-workstation-environment</id>
    <name>Development and Creative Workstation</name>

Those are the environments available on the centos 7.4 installation sources I've pointed the configurator at. But that is not what I am seeing in the package selection.

Has this configurator thing gone and contacted online centos repository and downloaded package selection from there? What is is doing? There is NO POINT SHOWING ME PACKAGE SELECTIONS THAT ARE NOT ON THE INSTALLATION SOURCE I HAVE SELECTED.

WTF? COULD THIS WHOLE PROCESS BE ANY MORE F#$&@ED UP?
Comment 18 John 2017-12-25 00:52:18 EST
Oh, I've found "Uncategorised -> Core" = "Smallest possible installation".
And there's "System -> Base" = "The basic installation of CentOS Linux."

Great.

But why can't I select an environment like "Compute Node"? 
What a mess.
Comment 19 John 2017-12-25 01:01:42 EST
I mean, I've just gone and deselected EVERY package group, except for "Uncategorised -> Core"

I've deselected "Display Configuration -> Install a graphical environment".

I should have, the "Smallest possible installation"

I go to "Preview", and i see:

@^graphical-server-environment
@core

So, it's still going to install graphical stuff, who knows what. 
Just pathetic.
Comment 22 errata-xmlrpc 2018-04-10 11:01:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0835

Note You need to log in before you can comment on or make changes to this bug.