Bug 1315954 - system-config-kickstart : : "Package selection is disabled due to problems downloading package information."
system-config-kickstart : : "Package selection is disabled due to problems d...
Status: CLOSED DUPLICATE of bug 1272068
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 01:33 EST by Abhijeet Sadawarte
Modified: 2016-06-16 10:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 10:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijeet Sadawarte 2016-03-09 01:33:57 EST
Description of problem:
The system-config-kickstart does not allow software packages selection.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.9.2-4.el7.noarch

How reproducible:

1. With the RHEL 7.2 system registered with the Red Hat network, install and launch system-config-kickstart. Click on the "Package Selection" tab.

2. With RHEL 7.2 system, create a local repository using ISO, install and launch system-config-kickstart. Click on the "Package Selection" tab.


Actual results:
- Error message ""Package selection is disabled due to problems downloading package information."" 

- Its working on RHEL 6.x 


Expected results:
Selectable list of packages to install. 

Additional info:

Code snippet reponsible for the package information download in the following file

####  /usr/share/system-config-kickstart/packages.py

46 class sckYumBase(yum.YumBase):
...
115     def __init__ (self, callback=None):
...
156         # If we're on a release, we want to try the base repo first.  Otherwise,
157         # try development.  If neither of those works, we have a problem.
158         if "fedora" in map(lambda repo: repo.id, self.repos.listEnabled()):
159             repoorder = ["fedora", "rawhide", "development"]
160         else:
161             repoorder = ["rawhide", "development", "fedora"]
162
163         self.repos.disableRepo("*")
164         if callback: callback.next_task()
165
166         self.packagesEnabled = False
167         for repo in repoorder:
168             try:
169                 self.repos.enableRepo(repo)
170                 self.packagesEnabled = True
171                 break
172             except yum.Errors.RepoError:
173                 pass
174
175         if not self.packagesEnabled:
176             return
...
Comment 2 Marek Hruscak 2016-06-16 10:25:51 EDT

*** This bug has been marked as a duplicate of bug 1272068 ***

Note You need to log in before you can comment on or make changes to this bug.